• # Re: Son et slackware

    Posté par  (site Web personnel) . Évalué à 1.

    hum ... plus de tuxfamily :/

    j'aurais peut etre pu aidé :/
    • [^] # Re: Son et slackware

      Posté par  (site Web personnel) . Évalué à 1.

      Le topic est toujours valable :-)

      Je suis aussi interrompu dans la configuration :-/

      Merci de répondre :-)
      • [^] # Re: Son et slackware

        Posté par  (site Web personnel) . Évalué à 1.

        Pour le son il faut les 3 paquetages alsa

        alsaconf pour la configuration
        alsamixer pour le volume par defaut
        alsactl store pour enregistrer les parametres.

        Seul l'admin peut ecouter le son par defaut. Perso je lance "esd" en utilisateur et le message d'erreur apparait me donnant le nom du device utiliser
        (genre /dev/snd/PCM je c plus koi)
        chmod 666 /dev/snd/PCM

        si tu as une carte son isa tu fais
        pnpdump > a
        isapnp a
        tu as le nom de la carte son si elle est détecté et tu regarde sur le net le module a charger ;)

        c t ca la question ?
        • [^] # Re: Son et slackware

          Posté par  (site Web personnel) . Évalué à 1.

          Mmh, en fait c'est un poil plus compliqué ;-)
          Les choses ont évolué entretemps...

          J'essaye de faire petit historique (je ne suis pas sur ladite machine), puisque tuxfamily n'est pas dispo aujourd'hui, et je doute qu'il le soit dans les jours qui viennent:

          - mon but est de pouvoir développer avec gcc en utilisant la librairie fmod (http://www.fmod.org(...))
          - j'ai installé les sources de slackware-current pour alsa suivante: alsa-drivers, alsa-libs, alsa-oss et alsa-utils, le tout en version 1.0.1
          - j'ai foiré, et l'on m'a conseillé de passer au noyau current 2.4.24 (j'étais en 2.4.22), ce qui s'est correctement passé.
          - j'ai cette fois installé les packages slackware current, plutot que les sources d'alsa, sans oublier les ptits coups de alsamixer, alsaconf et alsactl store.

          Petit bilan:
          - j'ai correctement le son sous KDE, en passant pas ALSA.
          - je ne suis plus obligé de lancer 'artsdsp mon_executable', mais simplement l'executable.
          - je ne peux pas sélectionner ALSA avec mes programmes développés maison, mais seulement OSS :-/ Et ca me gêne un peu, j'aurais voulu avoir le choix.
          - j'ai des erreurs sur une deuxieme carte son (dans mon /var/log/syslog de type sound-card-1-XXXXXXX , et rien dans /etc/modules.conf concernant une seconde carte).
          - j'ai après avoir rebooté pas mal d'erreurs d'usb (chipst SiS) au boot :-/

          Donc j'ai encore quelques erreurs, et quelques interrogations, merci de répondre à ces posts :-)
          • [^] # Re: Son et slackware

            Posté par  (site Web personnel) . Évalué à 1.

            faudrait voir si les drivers oss sont chargé ou si ce sont les drivers alsa.

            pour ca il faut faire lsmod et regarder kel genre de driver sont utiliser pour le son
            • [^] # Re: Son et slackware

              Posté par  (site Web personnel) . Évalué à 1.

              ok thx je check ca en rentrant chez moi
            • [^] # Re: Son et slackware

              Posté par  (site Web personnel) . Évalué à 1.

              lsmod en root:
              Module Size Used by Tainted: P
              nvidia 1967936 14 (autoclean)
              snd-pcm-oss 37444 0 (unused)
              snd-mixer-oss 11888 1 [snd-pcm-oss]
              ipt_multiport 728 114 (autoclean)
              ipt_state 568 10 (autoclean)
              ipt_LOG 3448 1 (autoclean)
              iptable_filter 1740 1 (autoclean)
              ip_tables 12320 4 [ipt_multiport ipt_state ipt_LOG iptable_filter]
              usbcore 59276 0
              snd-intel8x0 17896 1
              snd-ac97-codec 43276 0 [snd-intel8x0]
              gameport 1420 0 [snd-intel8x0]
              snd-pcm 56132 0 [snd-pcm-oss snd-intel8x0]
              snd-timer 13572 0 [snd-pcm]
              snd-page-alloc 5972 0 [snd-intel8x0 snd-pcm]
              snd-mpu401-uart 3072 0 [snd-intel8x0]
              snd-rawmidi 12704 0 [snd-mpu401-uart]
              snd-seq-device 3888 0 [snd-rawmidi]
              snd 30436 0 [snd-pcm-oss snd-mixer-oss snd-intel8x0 snd-ac97-codec snd-pcm snd-timer snd-mpu40 1-uart snd-rawmidi snd-seq-device]
              uhci 24476 0 (unused)
              ide-scsi 10192 0
              agpgart 22720 3
            • [^] # Re: Son et slackware

              Posté par  (site Web personnel) . Évalué à 1.

              j'ajoute que je me tape aussi parfois un message 'sound server failure, cpu overloaded' :-/

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.