Journal Doom3 et ATI

Posté par (page perso) .
Tags : aucun
0
27
oct.
2004
Un petit journal pour faire part de mon expérience avec Doom3 et mon ATI Radeon 8500.

Ma config:
- debian sid
- AMD 1.2Ghz Thunderbird / 512RAM

Ce que j'ai fais:
- recompiler/installer xorg en suivant le Howto de freedesktop [1]
- recompiler/installer xorg avec host.def du DRI [2]
- recompiler Mesa/DRM toujours avec howto du DRI
- installation de la lib S3TC [3]
- lancer doom3 comme ça: LD_PRELOAD=/usr/lib/libGL.so ./doom3

et ça marche... pas vite, mais ça marche... en gros, ça va pareil (un poil moins bien quand même) qu'avec une GeForce 2MX qu'on m'avait prété :)
A noté que certaine personne ont remarqué certains bugs, notamment la lampe qui marche mal (la zone directement éclairée serait blanche, mais le halo correct)

[1]: http://www.freedesktop.org/XOrg/CvsPage(...)
[2]: http://dri.sourceforge.net/cgi-bin/moin.cgi/Building(...)
[3]: http://homepage.hispeed.ch/rscheidegger/dri_experimental/s3tc_index(...)
  • # Ouch...

    Posté par . Évalué à 2.

    Déjà que je trouve le driver OpenGL sous Windows pas terrible (il suffit de voir le massacre des Ati sous Doom 3, les problèmes de performances et stabilités rencontrés par les joueur de KotOR sur les forums de BioWare) et que sous Linux, le driver proprio réussit juste à ne pas faire ramer la machine avec un fond d'écran OpenGL, parce que pour UT 2004, c'est le massacre graphique en 5 minutes chrono... Enfin bref, pour l'instant je compatis à ta douleur et soit m'achèterai une nVIDIA soit jouerai sous Windows.
    Il parait néanmoins qu'ils ont embauché une nouvelle équipe pour leur drivers Linux, et qu'ils sont en train de refaire la partie OpenGL de leur driver, on verra bien ce que cela donne, mais ça va peut-être s'arranger dans quelques mois.
    • [^] # Re: Ouch...

      Posté par (page perso) . Évalué à 4.

      ouai, mais je trouve important quand même de pas laisser tomber les pilotes libres, qui marchent tout de même pas trop mal! Certe ils sont limités, mais pour bcp ça suffit (Quake3, etc). Bref, il faut pas les laisser tomber !! :)
      • [^] # Re: Ouch...

        Posté par . Évalué à 2.

        Ouais, chez moi, le pilote libre radeon de Xorg me fait ramer n'importe quel fond d'écran 3D OpenGL, alors bon. Quoique je vais essayer avec ta méthode, avec un peu de chance, ça ne me corrompra pas les graphismes en 5 minutes d'Unreal et vu la pour l'instant piètre qualité des drivers proprio, ça ne devrait pas changer grand chose question perfs. De toutes façons, je tourne à nouveau avec des drivers libres depuis la dernière mise à jour de ma Slackware, les proprios n'ont pas trop aimé semble-t-il, à moins que ce ne soit Xorg qui n'aime plus trop les fichiers de conf taillés pour XFree86 4.3.
        • [^] # Re: Ouch...

          Posté par (page perso) . Évalué à 2.

          bah moi ces pilotes marchent bien. Certe, doom3 fait du 10fps de moyenne, mais il marche. Et le problème rencontré par certain avec la lampe ne s'est pas manifesté... tout est relativement beau ici
        • [^] # Re: Ouch...

          Posté par (page perso) . Évalué à 2.

          Ca ne viendrait pas du fait que les drivers proprio ne fonctionnent pas avec Xorg 6.8.0 ?
          • [^] # Re: Ouch...

            Posté par . Évalué à 2.

            Peut-être aussi, j'ai pas cherché très loin et de toutes façons, vu l'absence d'usage de 3D que je fais sous Linux, je vais pas chercher plus loin avant qu'Ati ne fasse des drivers estampillés Xorg.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.