Journal Plusieurs problèmes avec le Kernel 2.6.4

Posté par .
Tags : aucun
0
22
mar.
2004
Ma config générale.
-MEPIS Debian unstable (dernière grosse à jour en février 2004, surtout pour KDE 3.2)
-Kernel d'origine compilée à ma sauce personnel de façon traditionnel
-J'utilise le démon udev qui remplace devfs
-Carte NVIDIA GeForce4 MX 440SE avec les derniers drivers NVIDIA
-ALSA 1.0.3c avec driver "sbawe"
-XFree 4.3

Premier problème majeur: Les modules kernel du driver propio de NVIDIA(oui celui compatible avec le 2.6.x) ne se charge jamais. Je dois toujours aller faire make install dans le dossier lorsqu'on extract les sources de l'installer. Ensuite je relance kdm et tout marche nickel.

Deuxième problème majeur: Ma clé USB ne marche plus. Lorsque l'insère dans le port USB, ellle n'est même pas activé.

Maintenant les problèmes mineures:
1. Ma souris est gelé au démarrage de XFree86. Je dois la bouger dans tous les sens pour avoir le focus dessus.
2. Ma molette de souris ne marche plus.
3. Les CD-ROM ne sont plus monté automatiquement.
4. Mon PC ne ferme plus automatiquement lors de la commande halt(Je dois peser sur le bouton pour arrêter la machine)
5. Où sont maintenant les fichiers pour configurer les modules à lancer au démarrage(comme snd-pcm-oss par exemple)?

Voici ma config: http://kemul.sourceforge.net/files/config.gz(...) pour vérifier ce que j'ai mal configuré.
  • # Re: Plusieurs problèmes avec le Kernel 2.6.4

    Posté par . Évalué à 1.

    Premier problème majeur: Les modules kernel du driver propio de NVIDIA(oui celui compatible avec le 2.6.x) ne se charge jamais. Je dois toujours aller faire make install dans le dossier lorsqu'on extract les sources de l'installer. Ensuite je relance kdm et tout marche nickel.

    J'ai eu hier la même chose sous Mandrake 10. J'ai du refaire la même manip pour avoir kdm & co... :'( comme je me batais en // avec ma carte réseau et les assistants graphiques de Mdk, je me suis dit qu'il y avait peut être un lien de cause à effet s'il est allé taper dans le fichier des modules ou je sais pas où... :-/

    Par contre, je suis en 2.6.3 de Mdk...
    • [^] # Re: Plusieurs problèmes avec le Kernel 2.6.4

      Posté par . Évalué à 1.

      je l'ai fait jeudi soir chez un ami (pour une mandrake 9.2 je crois) et aucun probleme... vous avez pense a rajouter les modules concernes dans le /etc/modules ?

      (et ne pas oublier que recompiler les modules du noyau tend a enlever les modules ajoutes par dessus (ex le modules proprio pour les cg nvidia))
      • [^] # Re: Plusieurs problèmes avec le Kernel 2.6.4

        Posté par . Évalué à 1.

        bah c'est le script de nvidia qui fait cela tout seul je crois...

        Etrangement, j'ai pas eu de prob avant, c'est juste hier ou cela a déconné un peu... et puis ce matin, tout roule nickel...

        Va savoir... ;-)
  • # Re: Plusieurs problèmes avec le Kernel 2.6.4

    Posté par (page perso) . Évalué à 1.

    Pour la souris, il faudrait que tu en dises en peu plus, mais c'est peut être le même problème que moi (sur une logitech) : maintenant, toutes utilisent le même protocol qui est "ExplorerPS/2"

    va voir http://linuxfr.org/~Fanf/10073.html(...) pour plus de liens
  • # Re: Plusieurs problèmes avec le Kernel 2.6.4

    Posté par . Évalué à 1.

    moi j'ai découvert que pour les modules à lancer au démarrage ou à l'utilisation :

    /etc/modules est remplacé par /etc/modprobe.preload
    /etc/modules.conf est remplacé par /etc/modprobe.conf

    la syntaxe semble changer aussi ...

    je continue mon enquète ...
  • # Re: Plusieurs problèmes avec le Kernel 2.6.4

    Posté par (page perso) . Évalué à 1.

    Pour le module pour ta geforce, moi je fait comme ca : mon modifie le lien de /usr/src/linux vers le nouveau noyau, et apres je reinstall les pilotes
    Et tu rajoute "nvidia" a la fin du fichier /etc/modules.autoload.d/kernel-2.6
    Et en meme temps c'est normale puisqu'un module est compilé pour un noyau et un seul ;)

    Pour ta souris, c'est un pb de noyaux ca aussi, fo vérifié
    pour la molette, a tu bien Option "Buttons" "5" et Option "zAxisMapping" "4 5" dans /etc/XF86Config ?
    pour le cd pb de noyo aussi
    pareil pour le halt

    perso je suis sous gentoo avec un noyo 2.6.5-rc2 je n'ai pas de pb majeur, juste le frambuffer qui déconne avec ma GeForce, mais spa méchant :)
  • # Re: Plusieurs problèmes avec le Kernel 2.6.4

    Posté par . Évalué à 1.

    Pour le halt, est-ce que tu as bien compilé l'APM (ou l'ACPI suivant ta machine) dans le noyau??
  • # Re: Plusieurs problèmes avec le Kernel 2.6.4

    Posté par . Évalué à 1.

    Deuxième problème majeur: Ma clé USB ne marche plus. Lorsque l'insère dans le port USB, ellle n'est même pas activé.

    Par activée tu entend quoi ?
    - L'automount ne fonctionne plus ?
    - Impossible de faire un mount à la main ?
    - Pas de détection de la clef au moyen d'un lsusb ?

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.