Journal roulette de souris absente sous noyau 2.6

Posté par (page perso) .
Tags : aucun
0
4
mar.
2004
Bonjour à tous

Je me suis enfin décidé à passer au noyau 2.6, mais quelques problèmes sont apparus :

Tout d'abord, l'écran est tout noir lors du boot, mais ça, je pense que c'est simplement le frame buffer qui n'est pas activé pour la console (j'ai installé un noyau 2.6.3-1-k7 debian par apt-get).

Par contre, plus embettant (quoi que...), ma souris ne marche plus terrible.
C'est une souris logitech "corless mouseman optical", souris à 4 boutons (2 normaux, 1 roulette et 1 sous le pouce) + molette somme toute assez standard.
Mais je n'arrive pas à avoir les 4 boutons et la molette qui fonctionnent simultannément, alors que sous le noyau 2.4 ça marchait très bien.

Ma config XF86Config-4 était ça :
Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Device" "/dev/psaux"
Option "Protocol" "MouseManPlusPS/2"
Option "Buttons" "6"
Option "ZAxisMapping" "5 6"
EndSection

puis je faisais un :#xmodmap -e "pointer = 1 6 3 2 4 5"
pour que les boutons soient dans le bon ordre.

Avec le 2.6, cela ne marche pas du tout : impossible d'avoir la molette (aucune action détectée par xev)
J'ai changé "Protocol" pour "imPS/2", car google m'a dit par ci par là que ça pouvait poser problème. Et il y a en effet une amélioration, car maitenant je peux avoir soit la molette, mais pas le bouton sur le côté, soit l'inverse.

Est-ce que quelqu'un sait ce qu'il faut faire pour avoir une souris pleinement fonctionnelle ?

[apparemment, le forum ça marche moins bien quand même]

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.