Journal Quelques reflexions sur les applis Linux

Posté par .
Tags : aucun
0
12
mai
2005
Bonjour,

Je me pose pas ma de questions à propos de "l'utilisabilité" des applications "marginales" (j'entend par la, ne faisant pas partie des cannaux de distribution classiques comme freshrpms, dag et autres).

Depuis quelques temps, je regarde les nouveautés KDE proposées sur le site www.kde-apps.org. Certaines de ces petites applis sont vraiment astucieuses, mais n'ont pas la chance d'être intégrées aux binaries KDE, on a donc plusieurs solutions pour les utiliser:
1) le package est dispo pour la bonne distro sur le site de dev (par exemple, des packages pré-compilés sur sourceforge)
2) sinon, rechercher sur rpmseek, si un canal de distribution l'a déja compilé/packagé
3) sinon, récupérer les sources, recompiler, installer

Les problèmes sont toujours les mêmes:
* le point 1 n'est presque jamais possible
* le point 2 peut fonctionner si le canal en question (comme freshrpms) propose des repositories apt ou yum, c'est quelquefois le cas.
* le point 3 pose *toujours* problème: les makefiles/configures sont mal fait, il faut rapatrier d'obscures lib de dev, presque jamais dispo (presque jamais utilisées en standard non-plus) sous forme de packages, du coup on se retrouve avec les même problèmes d'install que l'application qu'on cherche à installer depuis le début, et qd enfin après 3 heures de prise de tête tout semble compiler, 2 minutes d'utilisation suffisent à provoquer un segfault.

J'ai précisément ce genre de soucis avec cdcat, qui permet de cataloguer des CD/DVD Rom et leur contenu: compilation foireuse, plantage et j'en passe ... et dernièrement "kat" (un outil qui permet d'indexer des fichiers, à la manière de GoogleDesktopSearch, qui *lui*, en dépit de toutes les critiques dont il fait l'objet, fonctionne à merveille). Pour "kat", le rpm existe (miracle !!), mais les dependances sont obscures:
error: Failed dependencies:
libaudio.so.2 is needed by kat-0.5.1-2
libexpat.so.1 is needed by kat-0.5.1-2
libsqlite3.so.0 is needed by kat-0.5.1-2
libcairo.so.1 is needed by kat-0.5.1-2
libpixman.so.1 is needed by kat-0.5.1-2
libpoppler-qt.so.0 is needed by kat-0.5.1-2
libpoppler.so.0 is needed by kat-0.5.1-2

D'autres questions fusent: quelles sont ces libs ? quel packages faut-il ? à coup de locate, grep et google, on en trouve une partie précompilée et les autres sont définitivement hors d'atteinte.

Bref c'est le grand bazar Linux quand on sort des sentiers battus ... et je cherche encore d'autres applis :-/ comment synchroniser un GPS (récupérer les traces/routes/waypoints), copier un DVD9 à la manière de dvdshrink, rien n'est complet, les packages sont inexistants, les sources ne compilent pas ... et j'en passe ... moi qui voudrait tant me passer à 100% de windows, je suis un peu décu, c'est visiblement impossible et depuis les nombreuses années que j'utilise Linux, c'est toujours impossible.

Ce genre de choses vous gavent aussi ??

A vos claviers :-)
  • # gps

    Posté par (page perso) . Évalué à 2.

    gpsdrive / gpsd?
  • # Nuance !!!

    Posté par . Évalué à 4.

    Il faut toujours nuancer et éviter les affirmation gratuites ...

    Dernière experience en date :
    ma copine avait oublier son jeu de scrabble chez ses parents ... qui habitent a 800 bornes.

    Moi fier ... pas grave je t'installerait un logiciel de scrabble ça doit bien exister sur la debian ...

    apt-cache search scrabble me sort une miserable réponse d'un jeux en anglais (pour le scrabble c'est pas top) et en mode console (pas glop du tout pour la jeune fille)

    Donc pas de scrabble par le canal officiel ... je ne me décourage pas je cherche un peu (interroge la tribune mais ces moules ont été incapables de me répondre, tas de feignaces :) je trouve un xscrabble repris par un mec de grenoble ... seule les source sont dispo.

    je télécharge, il y a un script build il m'affiche l'aide je doit faire 3 commandes.
    build bin
    build install
    build lang fr (apres avoir téléchargé le pack de langue)

    je lance une premiere fois la compile, ca plante, il me manque le paquet de dev pour X ... j'installe (apt-get install machin-dev ...) et recommance.

    Ca compile comme un charme, build install en root (pour ecrire dans les répertoires qui vont bien ...

    Et ma chérie passe une bonne partie de ses soirées dessus.

    D'ailleur il faut que je fasse un rapport de bug (si on ferme un popup d'aide ou de vérification, ca ferme toute l'appli ...) je vais voir si je peux lire les sources, c'est un petit projet mais je ne connais pas la programation sous X ...

    Dam
    • [^] # Re: Nuance !!!

      Posté par . Évalué à 2.

      Pour le scrabble t'a aussi ça.

      http://jduplicate.sourceforge.net/(...)
    • [^] # Re: Nuance !!!

      Posté par . Évalué à 3.

      Personnellement, j'aurais racheté le jeu de scrabble version plateau ... c'est moins prise de tête ...
      • [^] # Re: Nuance !!!

        Posté par . Évalué à 2.

        Ca a du me prendre en tout et pour tout 10 min ...
        et elle peut jouer contre un bot alors que moi j'aime pas ça

        donc ...

        Dam
        • [^] # Re: Nuance !!!

          Posté par . Évalué à 2.

          d'un autre coté, ca te permet de décrocher de l'écran, de passer un bon moment avec ta copine et tu peux même faire office de bot ;-)
          • [^] # Re: Nuance !!!

            Posté par . Évalué à 2.

            Je voulais dire que je ne suis pas un amateur de scrabble ...
            alors faire le bot...
            et du coup moi je suis pas sur l'ecran quand elle joue :)
            Dam
    • [^] # Re: Nuance !!!

      Posté par . Évalué à -1.

      Il faut toujours nuancer et éviter les affirmation gratuites ...

      J'adore :)

      (et il est interdit d'interdire ?)
      • [^] # Re: Nuance !!!

        Posté par . Évalué à 7.

        T'avais rien de mieux à faire avec ta copine ?


        ................[ ]
  • # DVD9 -> DVD5

    Posté par . Évalué à 3.

    Il existe ça : http://k9copy.free.fr(...)

    Mais bon comme tu le fais très bien remarquer dans ton journal, c'est du bon vieux tar.gz et j'ai pas encore trouvé de paquetages binaires :-(
    • [^] # Re: DVD9 -> DVD5

      Posté par (page perso) . Évalué à 3.

      Magnifique ! Il faut absolument que je l'essaye !
      Ce logiciel serait-il enfin celui que j'attends depuis si longtemps ? Quelqu'un l'a déjà essayé ?
  • # .deb ou .rpm

    Posté par (page perso) . Évalué à 4.

    d'ou peut etre l'utilité pour lees ditributions de choisir un format de paquet et d'homogénéiser le tout pour qu'un paquet marche sur toutes les distributions. Ainsi n'importe quel pequin qui fait un logiciel peut proposer le paquet qui va bien en meme temps que les sourcess ce qui faciliterait les installations mises a jour et autre. Et eviterait peut etre de nombreux problémes.

    Mais bon ce n'est peut etre pas faisable techniquement..... ???
    • [^] # Autopackage

      Posté par . Évalué à 1.

      J'avais, il y a un moment entendu parlé d'autopackage (http://autopackage.org(...) ) qui permettait d'installer des paquets sur n'importe quelle distribution.
      Je sais que Gaim l'utilise déjà (http://gaim.sourceforge.net/downloads.php(...) ) mais je ne sais pas si c'est très répendu. J'avais notamment entendu parlé de problèmes pour les applis KDE.
      Quelqu'un a t-il un retour d'expérience sur Autopackage ?
    • [^] # Re: .deb ou .rpm

      Posté par . Évalué à 2.


      Mais bon ce n'est peut etre pas faisable techniquement..... ???


      Ca serait déja un premier pas, mais le principal problème vient des dépences avec les libs. Il devrait qd même y avoir des packages pour Fedora, RH, Mandrake, Debian et j'en oublie, c'est ca le plus difficile a trouver :-/
    • [^] # Re: .deb ou .rpm

      Posté par . Évalué à 2.

      Compare déjà les distribs qui utilisent les rpm : les paquets sont-ils complètement compatibles ? non : problèmes de dépendance, d'emplacement des fichiers (de moins en moins avec FHS), etc.

      Le format en tant que tel est insuffisant, il faut toute une politique derrière (policy ou philosophie).
      L'uniformisation n'est techniquement pas évidente, politiquement non plus, et je me demande si elle est souhaitable.
  • # euh..

    Posté par (page perso) . Évalué à 2.

    Sors des sentiers battus sous windows et tu vas voir si c'est la joie aussi...

    pour installer toutes les libs qu'ils te manquent c'est pas dur :
    {apt-get urpmi yum etc...} install audio-dev expat-dev sqlite-dev cairo-dev pixman-dev poppler-dev
    ca et quelque search sur le repository et tu l'installe.

    moi ca gave pas, puisque c'est Windows ou je galere le plus...
    • [^] # Re: euh..

      Posté par . Évalué à 2.


      Sors des sentiers battus sous windows et tu vas voir si c'est la joie aussi...


      Je n'utilise presque pas windows, sauf pour certain fichier word/excel qui ne passent pas avec OOo, pour la carto avec le GPS, les jeux et la copie de DVD. C'est vrai que c'est autant la galère sous windows, mais c'est pas non plus une raison pour ne pas améliorer le système sous Linux :-)


      {apt-get urpmi yum etc...} install audio-dev expat-dev sqlite-dev cairo-dev pixman-dev poppler-dev


      ok merci j'essaie ca ce soir ...
      existe-t-il une mothode avec apt, ou bien yum (car je suis sous Fedora) qui puisse me dire /lib/libaudio.so.2 ca fait partie du package audio-dev ?
      En fait si je me souviens bien avec Debian, je n'avais pas ce problème: dans ce cas précis, apt m'aurait dit que je dois installer audio-dev, au lieu de me lister bêtement les libs manquantes.


      moi ca gave pas, puisque c'est Windows ou je galere le plus...


      Je reconnais volontier que ma machine est vraiment plus "réacive" sous linux que sous windows, c'est pour cette raison que je reste 95% de mon temps sous Linux (les antivirus, les anti-spyware, les firewall codés niveau applicatif, ... ca plombait mon windows, c'était affreux, sans compter que pour je ne sais quelle raison, j'étais tout le temps obliger de "réparer la connexion" - comme ils disent ds les config TCP/IP- , certains site ne répondant plus).
      • [^] # Re: euh..

        Posté par (page perso) . Évalué à 2.

        >existe-t-il une mothode avec apt, ou bien yum (car je suis sous Fedora) qui puisse
        >me dire /lib/libaudio.so.2 ca fait partie du package audio-dev ?

        auto-apt search lib/libaudio.so sous Debian
        urpmf libaudio.so sous Mandrake

        Par contre, avec apt-rpm ca n'existe pas et yum je sais pas non plus :p

        http://www.kde-apps.org/content/show.php?content=22135(...)

        Je veux pas dire, mais kat est compilé pour plein de distribs, comme la majorité des trucs sur kdelook/kdeapps. Ton probleme, c'est que tu utilises une distrib que peux de kdeistes utilisent... Croise les doigts pour que le package générique fonctionne ;)
  • # Pas de problème

    Posté par . Évalué à 1.

    3) sinon, récupérer les sources, recompiler, installer [...]
    * le point 3 pose *toujours* problème [...]

    Le point 3 ne pose pas tant de problèmes que ça : puisque tu utilises Fedora, il suffit de t'astreindre à toujours installer les versions '-dev' de tes paquets précompilés. Sans vouloir faire dans le troll veulu, séparer les headers et la documentation de la partie exécutable, et ne pas les installer par défaut m'a toujours hérissé le poil ; bref, vive la slackware. :P
    • [^] # Re: Pas de problème

      Posté par (page perso) . Évalué à 3.

      il devrait y avoir un flag quelque part pour installer tous ça automatiquement... car c'est assez déroutant en effet au premier abord.

      Sinon,l'inconvénient des source est aussi leur force : en cas de plate-formes exotiques, de paquets absent, configuration un peu dépassé/trop en avance, avoir les sources permet de faire des miracles.
  • # 100 % utilisable

    Posté par . Évalué à 1.

    et pourquoi que cela me gaverait ?

    Le principe de l'open source c'est que si tu veux l'améliorer, libre à toi de le faire.

    Si tu trouves que cela ne compile pas bien parce que par défaut tu n'as pas les mêmes bibliothèques de développement que l'auteur, ou que tu as eu la flemme de lire le README et le INSTALL (et oui, ce codeur ingrat n'a même pas pensé à traduire le readme pour les pauvres francophones), et bien tu peux aider à faire des paquets RPM ou DEB, qui aideront à bien indiquer les dépendances, si tu estimes que l'application en vaut la peine.
    C'est aussi la loi du "meilleur", une application qui offre une bonne utilité sera de mieux en mieux soutenue, et rejoindra les paquets "officiels".

    Je reconnais quand même que parfois cela ne compile pas toujours "out of the box" comme on dit, surtout sur un sytème PPC, mais je préfère avoir les sources et me débrouiller avec, plutôt que d'avoir un binaire dont je ne saurais que faire...
    et quand même, contrairement à ce que tu insinues, cela ne pose pas toujours problème de compiler depuis les sources.

    Only wimps use tape backup: real men just upload their important stuff on megaupload, and let the rest of the world ~~mirror~~ link to it

    • [^] # Re: 100 % utilisable

      Posté par . Évalué à 1.


      Le principe de l'open source c'est que si tu veux l'améliorer, libre à toi de le faire.


      Mmm ... je ne suis pas certain que ce genre d'argument soit en sa faveur. Dire a un "early switcher" ou un débutant Linux, que finalement s'il n'est pas content il peut tjs le faire lui même, c'est pas franchement vendeur :-)


      Si tu trouves que cela ne compile pas bien parce que par défaut tu n'as pas les mêmes bibliothèques de développement que l'auteur, ou que tu as eu la flemme de lire le README et le INSTALL


      Je lis tjs ce genre de doc, le problème vient précisement des libs exotiques, dont des versions précises sont requises (au 7.8.1 près, on se demande à quoi servent les numéros mineurs).
      Quand à faire les RPM sois-même, si déja ca ne compile pas à la base, ou ca compile mal (cf les segfaults) ...
      • [^] # Re: 100 % utilisable

        Posté par . Évalué à 1.

        Ce que je voulais rappeler c'est que ce type de programmes est fait et donné gratuitement, donc il n'est pas toujours de bon ton de venir râler en disant que cela ne fonctionne pas bien.
        je comprends que ce n'est pas toujours facile, mais en ce cas un débutant se cantonnera dans un premier temps à utiliser les paquets les plus courants de sa distribution sans chercher à faire plus pour le moment.

        Only wimps use tape backup: real men just upload their important stuff on megaupload, and let the rest of the world ~~mirror~~ link to it

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.