Journal Alsa, xmms, mpg321

Posté par (page perso) .
Tags : aucun
0
17
avr.
2003
Bonsoir mon journal

Voila, j'ai un problème (je crois bien que je t'aime) avec mon linux.
J'ai reussi a installer dessus les modules ALSA, le module de compatibilité OSS, et tout est bien configuré.
Pour preuve xmms fonctionne, mplayer fonctionne, zapping fonctionne.

Oui, mais voila, j'ai voulu tester mpg321 et la, c'est la catastrophe.
Il repete 30 fois la meme demi-seconde de chanson, avant de sauter a autre chose un peu plus loin. C'est horriblement haché.
Et ce n'est pas seulement avec mpg321, mais aussi avec les sound-daemons tels que esd ou arts.

Alors voila, je ne comprend pas, c'est un peu gênant tout de meme.
Pour info, j'utilise la version 0.9.2 des drivers. Mon chipset son est un via8233A intégré a la carte mère (driver via82xxx.o).

Quelqu'un a t il le meme problème ? Quelqu'un a t il su le resoudre ?
  • # Re: Alsa, xmms, mpg321

    Posté par (page perso) . Évalué à 1.

    moi ça marche avec la 0.9.0rc6, alors que ça ne marchait pas avec la dernière version ( pour alsa).
    Pense aussi( sous debian en tout cas) à ajouter ton utilisateur dans le groupe audio.
  • # Re: Alsa, xmms, mpg321

    Posté par . Évalué à 2.

    j'avais eu le meme probleme il y'a qq mois avec une slackware 8.0 (il me semble); j'avais installé (ou recompilé) mad (http://freshmeat.net/redir/mad/6082/url_homepage/mpeg(...)) et mpg321 (ou mpg123) délirait un peu à la façon dont tu le décris.
    J'ai viré mad (removpkg mad-i386...tgz) et tout a fonctionné comme un charme.

    wala wala...
  • # Re: Alsa, xmms, mpg321

    Posté par (page perso) . Évalué à 1.

    salut
    j'ai exactement le meme probleme, avec *toutes* les versions d'alsa que j'ai testées, donc la fameuse 0.9.0rc6 qui ne fonctionne pas mieux que les autres (je suis sous mdk 9.1).
    je n'ai que xmms et mplayer qui fonctionnent en pcm, et bien sur tout ce qui passe par le line-in comme la télé (xawtv)... je dois pouvoir jouer des cds aussi.
    mais pour xmms et mplayer je dois utiliser l'emulation oss, sinon ca freeze...
    et encore quand je dis que ca marche... qd j'arrete une chanson au milieu, j'ai la dernière 1/2 seconde qui se repete 13 fois (j'ai compté ce soir :p)
    enfin c qd mm mieux que les autres (mpg321, ogg123, artsd, etc) qui freezent que ce soit en alsa natif ou en emulation oss...
    si qqn a des idées, nous sommes preneurs :)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.