Journal pbm d'identification avec qmail et vpopmail

Posté par  (site Web personnel) .
Étiquettes : aucune
0
19
jan.
2004
Salut tous :)

après quelques heures de prise de tête, je me résigne à appeler à l'aide...

Cette nuit j'ai eu le "malheur" de mettre à jour ma testing, sur un serveur... en prod

ben oui

bon depuis ben impossible de m'identifier sur les comptes vpopmail (en pop3, en imap ca marche pas non plus mais je m'en fiche)

j'avais installé qmail et vopmail en suivant ce tutoriel : http://www.y0m.net/tutos/qmail-debian/(...)

ca marchait parfaitement jusqu'ici...

si quelqu'un peut avoir la moindre idée...

les programmes tournent tous, j'ai relancé tout ce qu'il fallait (j'ai même redémarré par desespoir de cause)

un rapport avec courier-authdaemon et vchkpw ?

note : l'acces via qmailadmin fonctionne bien...

je suis pret à vous donner toutes les infos nécessaires... si ca peut aider....

d'avance merci
  • # Re: pbm d'identification avec qmail et vpopmail

    Posté par  (site Web personnel) . Évalué à 1.

    Suite de l'enquête :

    à noter que j'ai du modifier mon /etc/init.d/qmail et décommenter la partie relative à pop3... en effet quand je faisais un simple telnet localhost 110 ca me disait que la connexion était refusée...

    mais après étude de la ligne décommentée

    <<
    sh -c "start-stop-daemon --start --quiet --user root \
    --exec /usr/bin/tcpserver -- \
    0 pop-3 /usr/sbin/qmail-popup `hostname`.`dnsdomainname` \
    /usr/bin/checkpassword /usr/sbin/qmail-pop3d Maildir &"
    >>

    on voit que ca ne peut pas vraiment marcher rien qu'avec checkpassword qui va vérifier que l'identification correspond à une identification système (/etc/passwd)

    donc, ok, il ne faut pas que je décommente cette partie... mais... alors... pour le port 110 n'est plus ouvert ????? :(
  • # Re: pbm d'identification avec qmail et vpopmail

    Posté par  (site Web personnel) . Évalué à 1.

    est ce que tu as regardé si tu avais bien compiler les programmes avec les patchs errno sans quoi les installs par defaut de qmail foirent lorsque l'on met a jour les libc6 ??
  • # Re: pbm d'identification avec qmail et vpopmail

    Posté par  (site Web personnel) . Évalué à 1.

    PROBLEME SOLUTONNÉ !!

    En fait lors de la mise à jour, vpopmail-bin a été mis à jour et lors du /etc/init.d/vpopmail start... j'avais le droit à

    <<
    ./vpopmail: xrealloc: ../bash/parse.y:2637: cannot reallocate 256 bytes (0 bytes allocated)
    >>

    bon j'ai cherché longtemps dans le script ce qui pouvait se passer, mais c'était un non sens... dans une ligne, même commentée, passer de "/usr/b" à "/usr/bin" provoquait l'erreur

    J'ai donc décide de "downgradé" mon bash, je l'ai passé en version stable

    et tout est rentré dans l'ordre :)
  • # Re: pbm d'identification avec qmail et vpopmail

    Posté par  . Évalué à 1.

    Il m'arrive la même chose. Je suis en debian sid, et je voulais installer qmail/vpopmail, et je me tape les mêmes erreurs que toi, sauf que moi ca n'a jamais marché avant.

    J'ai essayé en desinstallant bash, mais ca ne change rien. J'ai essayé aussi en sabrant dans le fichier pour voir si je trouvais une erreur quelconque, mais à part changer le fichier qui aime pas le xmalloc, ca change rien non plus.

    Si t'as des nouvelles, ca m'interesse.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.