Journal Question Gentoo et emerge

Posté par  .
Étiquettes : aucune
0
14
sept.
2003
Je me suis mit à installer une Gentoo hier sur mon PC. Maintenant que j'ai le système qui boot et que XFree est installé je voudrais installer gnome 2.4

après avoir fait "emerge sync" les ebuild de gnome 2.4 sont bel et bien présent alors j'ai tenté

cd /usr/portage/gnome-base/gnome
emerge gnome-2.4.ebuild

mais il me fait des erreurs sur les dépendances qu'il ne trouves pas même si les fichiers sont dans leurs dossiers respectifs!

Prendre note que je suis nouveau avec Gentoo alors j'ai à apprendre ;)
  • # Re: Question Gentoo et emerge

    Posté par  (site Web personnel) . Évalué à 1.

    quels sont ces erreurs exactement ? c'est pendant la compilation ?

    ca donne quoi quand tu fais

    ACCEPT_KEYWORD="~x86" emerge -pv /usr/portage/gnome-base/gnome/gnome-2.4.ebuild ?

    si tu veux installer gnome 2.4 il faut que tu sois en non stable de la gentoo...

    En mettant ACCEPT_KEYWORD="~x86" devant la commande emerge, ca l'activera pour cette compilation. Sinon, tu peux choisir de faire cette modification pour tout ton système en passant globalement tout tes paquet en versin unstable (/etc/make.conf)

    Si tu cherches une meilleure aide, je te conseil d'allur sur http://forums.gentoo.org/viewforum.php?f=35(...) et de poster ton message, tu auras une réponse assez rapide à mon avis
    • [^] # Re: Question Gentoo et emerge

      Posté par  . Évalué à 0.

      J'ai encore la même erreur:

      bash-2.05b# ACCEPT_KEYWORD="~x86" emerge -pv /usr/portage/gnome-base/gnome/gnome-2.4.ebuild

      These are the packages that I would merge, in order:

      Calculating dependencies \
      !!! all ebuilds that could satisfy ">=x11-libs/pango-1.2.5" have been masked.
      !!! (dependency required by "gnome-base/gnome-2.4" [ebuild])

      !!! Error calculating dependencies. Please correct.
      • [^] # Re: Question Gentoo et emerge

        Posté par  . Évalué à 3.

        Ne pas oublier le S à
        ACCEPT_KEYWORDS="~x86" emerge -pv /usr/portage/gnome-base/gnome/gnome-2.4.ebuild
        • [^] # Re: Question Gentoo et emerge

          Posté par  . Évalué à 1.

          J'ai fait la manip chez moi pour avoir gnome 2.4
          Même avec les commandes que tu cites et que je connais, portage estime qu'il y a des paquets masqués (boug?). Alors j'ai fait une manip de gros porc, j'ai dupliqué le fichier contenant les masks et je l'ai carrément vidé pour ne plus avoir le problème. Et maintenant ça plante à la compil.
          Je pense que je vais garder les deux ou trois commentaires que j'ai trouvé sur ce journal pour tester, en particulier le -U
  • # Re: Question Gentoo et emerge

    Posté par  (site Web personnel) . Évalué à 1.

    perso je suis en train de le compiler sr la mienne... Un simple

    "emerge gnome -upv" permet de voir ce qu'il peut mettre à jour ton systeme en installant la derniere version de gnome au passage et les "USE" qu'il utilise avec ou non.

    Repère les lignes en rouges: c'est celle qui posent problème.

    Pour ma part pour installer gnome-2.4 j'ai du d'abord faire un "emerge unmerge gnome-utils" ainsi qu'un autre paquet (gnome-vfs peut être, je ne sais plus...) et apres ça roule (et pourtant je suis sous gnome actuellement a moitié 2.2/2.4 car une coupure de courant a coupé mon ordi au milieu de la mise à jour).

    ensuite tu n'a plus qu'a faire "emerge gnome" avec les bon USE que tu veux (d'ou l'interet de "pv" ca te permet de voir ce que tu peux mettre comme USE) que tu rajoute soit dans /etc/make.conf soit avant sur la ligne:
    'USE="+machin +bidule" emerge gnome'
  • # Re: Question Gentoo et emerge

    Posté par  . Évalué à 0.

    franchement, je sais pas ce que vous en pensez, mais portage c'est encore bien buggué :)

    genre pour gedit : emerge gedit plante avec un cannot stat machin.omf.truc, je relance emerge gedit et là ca marche :-/

    et ça, plein de fois pendant l'install de gnome 2.4

    plus les options -doc qui foirent une fois sur 2

    il faut vraiment que je jette un coup d'oeil au projet debtoo moi
  • # au fait

    Posté par  . Évalué à 1.

    J'ai installe Gnome 2.4 bien que les paquets soient masques, mais en dehors de ca j'ai une install de la branche stable.

    Le probleme c'est que maintenant sur un "emerge world" il veut me downgrader Gnome.

    Y'a pas un moyen de dire "je veux des paquets stables, sauf ceux-la ils sont instables mais je les veux quand meme" ?

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.