Forum Linux.debian/ubuntu mpd démarre tout seul

Posté par (page perso) . Licence CC by-sa
Tags :
1
6
déc.
2014

Sous debian unstable, j'ai mpd qui démarre tout seul (lancé par l'utilisateur mpd) alors que je veux le lancer moi-même. C'est comme ça depuis que c'est systemd qui gère mon démarrage. Avant, j'avais simplement lu /etc/default/mpd et fait ce qu'il conseillait (qui autrefois consistait à changer une variable dans le fichier, plus tard à faire le update-rc.d standard).

  • J'ai pourtant refait update-rc.d mpd disable mais il démarre toujours.
  • J'ai aussi fait systemctl disable mpd.service mais il démarre toujours.
  • J'ai changé le fichier de config pour qu'il utilise un autre port que le 6600. Mais il démarre toujours et ce port est toujours occupé !
  • J'ai fait systemctl disable mpd.socket. Mais mpd démarre toujours.
  • J'ai modifié mpd.socket pour utiliser un autre port et mpd utilise effectivement cet autre port. Mais il démarre toujours.

Est-ce que quelqu'un est confronté au même problème ? Est-ce qu'il y a autre chose à faire pour convaincre systemd de ne pas démarrer n'importe quel service ?

Est-ce que c'est normal que le port soit spécifié dans deux fichiers différents ?

  • # pour l'histoire du port

    Posté par . Évalué à 2.

    Est-ce que c'est normal que le port soit spécifié dans deux fichiers différents ?

    en fait oui, cela peut etre un port definit par le system (par defaut), par l'administrateur (dans /etc/default/mpd), par l'utilisateur (fichier de config)

    • [^] # Re: pour l'histoire du port

      Posté par (page perso) . Évalué à 2. Dernière modification le 06/12/14 à 13:53.

      Et c'est normal que les deux ports soient effectivement utilisés ?

      • [^] # Re: pour l'histoire du port

        Posté par . Évalué à 2.

        aucune idée, je ne connais pas MPD,

      • [^] # Re: pour l'histoire du port

        Posté par . Évalué à 0.

        Oui c'est normal : tu as le socket ouvert par systemd et celui ouvert par ta session via XDG.
        Tu as désactivé le socket dans systemd, donc il ne se réactivera pas. Mais tu as juste oublié d'arrêter celui qui est surement en cours avec "systemctl stop mpd.socket".
        Bref, systemd n'est encore une fois pas en cause, c'est dû à une erreur de packaging et une méconnaissance de systemd de la part de l'administrateur.

  • # C'est parce que systemd sait mieux que toi ce qui doit démarrer sur ta machine ....

    Posté par . Évalué à 0.

    Plus sérieusement, c'est le genre de blagues "à la Windows" auxquelles je m'attendais (et je m'attends encore) avec systemd.

    Pourtant c'est censé être simple, un démarrage de système, mais quand on veut tout faire, on rend les choses inutilement complexes.

    Mais il n'y a pas que systemd qui pose ce problème : c'est le cas de beaucoup d'outils censé "simplifier" la vie de l'utilisateur ou de l'administrateur : je vis ça tous les jours au taf, malhereusement : et souvent, c'est utilisé par certaines personnes pour se rendre indispensables et garder un certain pouvoir.

  • # autostart ?

    Posté par (page perso) . Évalué à 3.

    Je vois dans la liste des fichiers (https://packages.debian.org/sid/amd64/mpd/filelist) un :
    /etc/xdg/autostart/mpd.desktop

    C'est pas lui qui te lance mpd ?

    • [^] # Re: autostart ?

      Posté par (page perso) . Évalué à 2.

      D'aileurs c'est ce qui semble être indiqué dans le README.Debian :

      http://anonscm.debian.org/cgit/pkg-mpd/pkg-mpd.git/tree/debian/README.Debian

      • [^] # Re: autostart ?

        Posté par (page perso) . Évalué à 1.

        C'est une bonne piste. Il faudrait voir avec systemctl status mpd si c'est bien systemd qui le lance ou si c'est une debiannerie disons un souci transitoire d'empaquetage. Et si c'est pas systemd le fautif, le commentaire du dessus en mode rageux si-y-a-un-souci-c'est-forcément-ce-connard-de-Lennart serait d'autant plus croustillant :-D.

        • [^] # Re: autostart ?

          Posté par (page perso) . Évalué à 2.

          C'est une bonne piste.

          À voir, parce que le message original dit bien que le démon est lancé par l’utilisateur mpd, ce qui n’est pas très cohérent a priori avec un lancement au démarrage de la session graphique (dans ce cas il serait lancé avec le compte de l’utilisateur de la session).

          Ajouté au fait que le même message dit que le problème est apparu avec systemd (« C'est comme ça depuis que c'est systemd qui gère mon démarrage »), pointer systemd du doigt ne me paraît pas déraisonnable, même si un bug d’empaquetage (plutôt qu’un bug de systemd lui-même) ou un bug d’interface chaise-clavier ne sont pas à exclure.

          (Et si c’est bien systemd le fautif, le commentaire façon « ceux-qui-accusent-systemd-sont-forcément-des-lennart-hatter » serait d’autant plus croustillant. :-D )

          • [^] # Re: autostart ?

            Posté par . Évalué à 1.

            Tututut…
            ça peut être un démarrage du service mpd sur une écoute de socket (local ou réseau).

            Et donc, comme le démon par défaut doit être configuré pour être lancé par l'utilisateur MPD…

            Essaies de faire cela :
            * désactive le service MPD :
            systemctl disable mpd.service
            systemctl disable mpd.socket
            * Relance ta session

        • [^] # Re: autostart ?

          Posté par . Évalué à 3.

          si-y-a-un-souci-c'est-forcément-ce-connard-de-Lennart

          Jamais dit ça …. ce que je voulais dire c'est qu'à vouloir complexifier des choses qui doivent rester simple, on en arrive à ce genre de blagues : que ce soit un problème de packaging, ou même un problème d'utilisateur ne change rien : systemd est complexe (parce qu'il veut en faire trop) ce qui mène à des problèmes de packaging ou de non compréhension de la part des utilisateurs.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.