Forum Linux.debian/ubuntu Pas de son avec Jessie.

Posté par . Licence CC by-sa
Tags : aucun
3
8
mai
2015

Bonjour ! :)
En installant Jessie sur le PC portable d'un ami, je ne parviens pas à avoir de son. Honnêtement, le fonctionnement du son me paraît très obscur sous Linux.

À savoir que sur un Live USB de Linuxmint, cela fonctionne, avec le noyau :

$uname -a
Linux mint 3.13.0-37-generic #64-Ubuntu SMP

Sous Jessie, je n'ai que des bips systèmes (la carte-mère qui bipe quand je quitte, quand il y a une erreur, quand je fais précédent, etc).

$ cat /proc/asound/cards

     0 [Generic        ]: HDA-Intel - HD-Audio Generic
                          HD-Audio Generic at 0xf0344000 irq 41
     1 [Generic_1      ]: HDA-Intel - HD-Audio Generic
                          HD-Audio Generic at 0xf0340000 irq 16

$ lspci | grep "Audio"

    00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] BeaverCreek HDMI Audio [Radeon HD 6500D and 6400G-6600G series]
    00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD] FCH Azalia Controller (rev 01)

$ cat /proc/asound/modules

     0 snd_hda_intel
     1 snd_hda_intel

$ aplay -l

    **** Liste des Périphériques Matériels PLAYBACK ****
    carte 0: Generic [HD-Audio Generic], périphérique 3: HDMI 0 [HDMI 0]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: Generic_1 [HD-Audio Generic], périphérique 0: CX20585 Analog [CX20585 Analog]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0

J'ai installé pavucontrol, et le son a l'air de fonctionner quand je lis un fichier audio. Mais évidemment, aucun son ne sort des enceintes ou d'ailleurs.

Qu'est-ce que j'ai pu oublier ? J'ai fait une migration de Wheezy vers Jessie…Et hum, je ne sais pas trop vers quoi me tourner. Alsa ? Pulse ? Gstreamer ? Je suis un peu perdu.

Je vous remercie d'avance pour vos avis et votre attention !

  • # Même problème sur Wheezy

    Posté par . Évalué à 1.

    J'ai aussi eu ce soucis il y a quelques mois lorsque j'ai installé mon serveur audio (une Wheezy stable pour le coup, avec un noyau 3.2).

    Je n'ai plus les sources, mais si mes souvenirs sont bons, c'était un mauvais support du chipset (NM10/ICH7 sur un netbook Packard Bell (ouai, je sais)) par le noyau, ce qui était réglé dans une version supérieure. Du coup, la solution la plus simple a été d'installer un noyau 3.16, backporté depuis Jessie (alors en testing).

    Je ne sais plus ce que j'avais du faire pour l'installer, mais c'était relativement simple et réversible, tu peux toujours tenter cette option.

  • # quelques tests supplémentaires

    Posté par . Évalué à 2.

    fuser -v /dev/snd/* dit quels sont les processus qui monopolisent la carte son. Si ce n'est pas le bon (celui auquel tu fais lire l'audio), essaye de le tuer avec kill

    Sinon c'est bizarre que ça marche avec mint qui a un noyau 3 versions inférieures à celui de Jessie !

    • [^] # Re: quelques tests supplémentaires

      Posté par . Évalué à 1.

      fuser -v /dev/snd/*

                           UTIL  PID ACCÈS COMMANDE
      /dev/snd/controlCO: franck 1231 F.... xfce4-volumed
                          franck 1297 F.... pulseaudio
      /dev/snd/controlC1: franck 1231 F.... xfce4-volumed
                          franck 1297 F.... pulseaudio
      /dev/snd/pcmC0D3p:  franck 1297 F...m pulseaudio
      /dev/snd/pcmC1D0c:  franck 1297 F...m pulseaudio
      /dev/snd/pcmC1D0p:  franck 1297 F...m pulseaudio
      

      Je dois t'avouer que je n'y comprends pas grand-chose. Je vais fouiller un peu, merci. :)

      • [^] # Re: quelques tests supplémentaires

        Posté par . Évalué à 2.

        Ça veut dire que tu as 2 processus qui accèdent à la carte son, xfce4-volumed et pulseaudio. Leur Process ID sont 1231 et 1297.

        Essaye de les tuer (kill -KILL 1231 1297 ) puis relance ton lecteur audio.
        Parfois pulseaudio se relance, si tu es sous debian tu peux sans doute le désinstaller.

  • # ordre des cartes sons

    Posté par . Évalué à 3.

    D'après ton aplay -l, ta première carte son est la carte HDMI. Il te faut inverser l'ordre des cartes dans ta configuration alsa. Par contre je ne sais plus du tout comment faire.

  • # périphérique audio par défaut de pulse audio

    Posté par . Évalué à 2.

    J'ai eu exactement le même problème sur tous les PCs de la famille quand je suis passé à Jessie, mais je croyais que j'étais un cas isolé car j'utilise MATE au lieu de GNOME et à l'époque Jessie était encore en testing. Avec Wheezy je n'avais jamais eu de problèmes de son.

    En fait il y avait deux problèmes:
    1- le périphérique par défaut de pulse audio était PC Speaker
    2- les paramètres du mixer ALSA n'était pas bon (niveaux trop bas)

    Le premier problème se corrige avec pavucontrol (à refaire pour chaque utilisateur), le deuxième problème se corrige avec mate-volume-control (ou l'équivalent sous GNOME).

    bonne chance

    • [^] # Re: périphérique audio par défaut de pulse audio

      Posté par . Évalué à 1.

      Hé bien, je ne parviens pas à changer quoi que ce soit avec pavucontrol. Tous mes réglages conduisent au même problème : des bips du PC à certains moments. Pas de "volume bas" ou quoi que ce soit qui laisserait espérer une évolution.

      Merci des conseils, cependant. Je continue à fouiller, même si je sature.^

  • # Paquet manquant

    Posté par . Évalué à 1.

    En réinstallant Debian Jessie avec Xfce, j'ai eu ce problème. Pour résoudre ce problème, il a suffit que installe gstreamer1.0-pulseaudio chez moi.

    En espérant que cela puisse t'aider.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.