Forum Linux.général Outils GUI avec utilisateur différent

Posté par .
Tags : aucun
1
15
sept.
2011

Bonjour

Depuis toujours j'utilise les outils en ligne de commande pour l'administration système.
De plus en plus j'ai a faire des scripts et à modifier des petits programmes. Et là les outils CLI ne me conviennent plus car j'aime bien les gestionnaires de fichiers GUI et les éditeurs GUI.

Je me retrouve à faire de chown et chmod dans tous les sens alors que je pense qu'il y a une autre méthode.

Exemple:

  • j'ai une session X ouverte avec l'utilisateur gremous
  • j'ai une arborescence de fichiers sous /srv/erp-de-la-mort/ (utilisateur=erp groupe=erp autorisations=755 à 440 suivant les fichiers)
  • en ligne de commande, il me suffit de passer en root (avec su ou sudo) et je fais ce que je veux
  • comment le faire à partir de ma session X ?
    • pour naviguer dans l'arborescence
    • pour éditer les fichiers

J'ai essayé gksudo -u erp kate monfichier.conf mais par exemple l'éditeur kate refuse de se lancer car il n'a pas accès à ~/.Xauthority
Pareil avec d'autres programmes, il y a toujours un truc qui bloque. Alors qu'en CLI c'est impeccable.

Comment faites-vous ce genre de choses au quotidien ?

  • # xhost

    Posté par (page perso) . Évalué à -2.

    Je ne sais plus quelle est la syntaxe exacte, mais man est ton ami.

    • [^] # Re: xhost

      Posté par . Évalué à 2.

      xhost ?!? arh, nein !

      Pour la gestion des cookies X11, c'est par là
      -> xauth

  • # Mon contournement

    Posté par . Évalué à 2.

    Je me retrouve souvent à devoir faire la même chose (pour des raisons différentes), et pour l'instant, le seul contournement que j'ai, c'est de faire c'est un équivalent de sudo cp $XAUTHORITY ~user2/.Xauthority , et en tant qu'user2, un export XAUTHORITY=~/.Xauthority
    Il faut juste régler les permissions du ~user2/.Xauthority une seule fois en 600 pour éviter que le pirate se serve de ta session X pour devenir root ;)

    Mais c'est vrai que ça n'est pas idéal du tout.

  • # Every gui command sucks but this one sux less.

    Posté par . Évalué à 10.

    sux

    SYNOPSIS
    sux [OPTS] [-] [[username] [ARGS]]
    suxterm [OPTS] [-] [username]

    DESCRIPTION
    sux is a wrapper around the standard su command which will transfer your X credentials to the target user.

    Note, suxterm forces ARGS to be 'xterm', and will try to launch an xterminal window.

    QUICK CALLING
    'sux user' and 'sux - user' behave just like su but transfer $DISPLAY and the X cookies.

    • [^] # Re: Every gui command sucks but this one sux less.

      Posté par . Évalué à 1.

      Ca marche super, merci !
      Ca m'oblige à créer le répertoire de l'utilisateur, mais c'est pareil avec la solution données plus haut. Car mon utilisateur erp est juste présent dans /etc/passwd. Là j'ai créé son home et ça marche.

  • # Ouvrir un terminal

    Posté par (page perso) . Évalué à -4.

    truc@machin$ sudo erp
    erp@machin$ kate monfichier.conf
    erp@machin$ Thunar (ou ce que tu veux comme browser de fichier)

    It's a fez. I wear a fez now. Fezes are cool !

    • [^] # Re: Ouvrir un terminal

      Posté par . Évalué à 3.

      truc@machin$ sudo erp

      C'est pas plutôt "sudo su erp"?

      erp@machin$ kate monfichier.conf

      Nan, ça coince au niveau du serveur X, c'est ce qu'il explique. Essaie.

      THIS IS JUST A PLACEHOLDER. YOU SHOULD NEVER SEE THIS STRING.

      • [^] # Re: Ouvrir un terminal

        Posté par (page perso) . Évalué à 2.

        C'est pas plutôt "sudo su erp"?

        Pourquoi sudo su ?

        sudo -u :

        -u user The -u (user) option causes sudo to run the specified command as a
        user other than root. To specify a uid instead of a user name, use
        #uid. When running commands as a uid, many shells require that the
        '#' be escaped with a backslash ('\'). Security policies may restrict
        uids to those listed in the password database. The sudoers policy
        allows uids that are not in the password database as long as the
        targetpw option is not set. Other security policies may not support
        this.

        C'est-y pas plus simple ?

        • [^] # Re: Ouvrir un terminal

          Posté par . Évalué à 2.

          Bof, entre "sudo -u user" et "sudo su user" je vois pas trop la différence, en nombre de caractères tapés.

          THIS IS JUST A PLACEHOLDER. YOU SHOULD NEVER SEE THIS STRING.

  • # Solution gruik pour ne pas se prendre la tête

    Posté par . Évalué à 1.

    ssh -X erp@localhost
    
    

    Souvent ssh est configuré pour accepter le forward X, cela évite de devoir se pencher sur les cookies X, ou de passer en xhost +

  • # bof

    Posté par . Évalué à 7.

    Moi j'ai pas ce problème, je bosse en tant que root je ne suis pas un NEWBIE moi.

    D'ailleurs la commande que j'avais lancé tout à l'

    Il ne faut pas décorner les boeufs avant d'avoir semé le vent

    • [^] # Re: bof

      Posté par (page perso) . Évalué à 2.

      J'édite en local et cfengine pousse sur le serveur...

      C'est un peu long mais au moins, je sais comment les serveurs sont configurés surtout qu'en local, les fichiers sont versionnés.

  • # Configurer pam

    Posté par . Évalué à 2.

    Tu peux configurer pam pour que su autorise l'autre utilisateur à lancer des applis graphiques :

    /etc/pam.d/su

    # support xauth pour les applis X
    session optional pam_xauth.so

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.