Test de la Mandriva 2008.1

Posté par (page perso) . Modéré par Nÿco.
Tags :
1
23
avr.
2008
Mandriva
Alors que la nouvelle Mandriva Linux 2008.1 est sortie le 9 avril dernier et annoncée sur LinuxFR le jour suivant, j'ai réalisé un test de cette dernière avec les captures d'écran d'usage.

J'ai eu l'occasion d'installer et d'utiliser cette nouvelle version sur plusieurs portables et deux machines de bureau (du Pentium 4 au Core 2 Duo) contenant autant des cartes ATI que Nvidia ainsi que plusieurs types de clés sans fil.

Pour rappel, la Mandriva 2008.1 c'est : GNOME 2.22, KDE 3.5.9 et 4.0.3, Firefox et Thunderbird dernières cuvées, noyau Linux 2.6.24.3 (sauce mandriva avec beaucoup de pilotes ajoutés), Compiz Fusion, Xorg 1.4, Skype 2.0, pilotes nvidia 169.12.

Je vous invite donc à consulter ce petit survol des nouveautés à la sauce FRLinux (petit rappel, comme pour la plupart des distributions testées, le but est de fournir un avis rapide sur une distribution pour l'utilisateur ou le décideur pressé). Au programme de ce survol :
  • Présentation de l'installation sur 2 portables
  • Compiz, ntfs-3g fonctionne avec Vista
  • OpenOffice.org 2.4.0, Miro
  • radio en ligne avec Totem, imprimantes/scanner, synchronisation de PDA, PulseAudio
  • nouvelle mouture d'EasyURPMI
  • avant window manager, support des chipsets wifi
  • # Problème à la mise à jour

    Posté par . Évalué à 6.

    Attention, cette release a un gros bug lorsqu'on fait une mise à jour:
    https://qa.mandriva.com/show_bug.cgi?id=39925
    voir également l'explication dans les errata
    http://wiki.mandriva.com/en/2008.1_Errata#Upgrade_from_previ(...)

    Il ne semble pas pour l'instant qu'il soit prévu de dortir une mise à jour des ISO et de l'installeur pour corriger ce problème, c'est vraiment dommage car si le problème est récupérable (je m'en suis sorti sur les deux machines que j'ai mis à jour), ce n'est tout de même pas trivial et un débutant voyant ça ira surment directement réinstaller, voir laisser tomber.
    • [^] # Re: Problème à la mise à jour

      Posté par (page perso) . Évalué à 4.

      La page est même disponible en français pour ceux qui préfèrent http://wiki.mandriva.com/fr/Mandriva_Linux_2008_Spring_Errat(...)

      En même temps, les mises à jour à partir d'un CD et même DVD qui ne va pas contenir l'intégralité des paquets que tu as pu installer au fur et à mesure du temps...
      J'ai plutôt tendance à pointer directement vers les miroirs des dépôts de la nouvelle version (en ajoutant aussi les main et contrib /updates) ce qui permet de s'affranchir de ce genre de problème...
      Je l'ai fait juste avant la sortie officielle (quand les miroirs n'étaient pas trop chargés) : pour 2500 paquets et ~2,5 Go, cela a pris 5h sur mon portable (plus rapide que d'habitude où cela prenait plutôt 10h), cf. [http://wiki.eagle-usb.org/wakka.php?wiki=UpgradeMandriva2008(...)].
      Cela pose quelques questions de choix pour certains paquets, rien de bien difficile (même s'il vaut mieux l'avoir fait une fois pour s'y retrouver facilement et savoir relancer au besoin si un paquet bloque).

      Là, j'attends que la frénésie de téléchargement se calme sur les miroirs pour upgrader mon poste fixe.
      • [^] # Re: Problème à la mise à jour

        Posté par (page perso) . Évalué à 5.

        Pour le téléchargement, j'ai utilisé bittorrent - j'étais un précurseur (early seeder) - et je le laisse bittorrent -fonctionner pour faire un maximum d'upload.
        En ce moment, avec ktorrent, je vois que les pays européens sont moins actifs mais que les Amériques (USA, Australie, Canada, Mexique, Brésil) sont très présentes.

        Les versions 64 bits Free et PowerPack semblent très prisées. C'est amusant de voir que tous les pays sont concernés et c'est une bonne occasion pour se remémorer les drapeaux de tous les pays et leur localisation sur le globe.
      • [^] # Re: Problème à la mise à jour

        Posté par . Évalué à 2.

        En même temps, les mises à jour à partir d'un CD et même DVD qui ne va pas contenir l'intégralité des paquets que tu as pu installer au fur et à mesure du temps...

        C'est pour ça que j'utilise le mini-CD dual-arch pour ensuite démarrer sur une copie locale de la distrib. Mais comme le bug est dans l'installeur ça fait pareil.

        Pour la prochaine machine je ferai la mise à jour directement par urpmi, ça ne fera pas plus mal.
  • # Petit retour sur un Macbook Pro Santa Rosa

    Posté par . Évalué à 5.

    Salut,

    pour ceux que ça intéresse, j'ai fait un rapide petit retour sur cette distrib en mode live CD version One, sur un Macbook Pro Santa Rosa, cf. ici :

    http://forum.mandriva.com/viewtopic.php?p=473673#473673

    Et meskale a détaillé ici :

    http://forum.mandriva.com/viewtopic.php?p=473819#473819

    comment avoir la télécommande et le clavier apple fonctionnels.

    amusez-vous bien :)
  • # Chaine de connexion PDA

    Posté par . Évalué à 2.

    Quelle est la chaine de connexion vers les PDA ? Synce ?

    Quelles sont les fonctions accessibles entre le PDA et Mandriva ?

    Ou peut on avoir ces détails ?
  • # Sur mon Compaq Evo N600c .....

    Posté par . Évalué à 4.

    Mon portable est certe pas des plus récent
    PIII 1Ghz
    512 MB RAM,
    ATI Mobility M6 (aka Radeon 7000)
    Son ESS Maestro 3

    mais j'ai depuis peu avec certaines distros de sérieux problèmes matériel

    OpenSuse 10.3 : Carte son non reconnu
    Debian Lenny : Si j'utilise le noyau 2.6.24 fourni plus de son
    Pour toutes les noyaux : la carte graphique fonctionne sans accélération. Il faut que j'installe mesa entre autre et modifie xorg.conf pour avoir l'accéleration 3D

    Ubuntu 7.10 : Sommet des problèmes. Jusquz``a l'apparition de gdm l'écran reste noir. Aprés comme pour lenny pas de 3D

    Mandriva 2008 pas de problème TOUT marche!!!!

    Avec une certaine apréhension j'ai donc installé Mandriva one 2008.1 "gnome" et miracle tout marche. Bref pas de problême....
  • # Versions 32bits et 64 bits

    Posté par (page perso) . Évalué à 4.

    J'ai testé depuis la version Alpha2 à la finale les différentes versions sur 6 machines. En version i586 (32 bits) tout fonctionne.
    Pour ceux qui auront pris la version Free et auront voulu la compléter pour aller sur Youtube ou dailymotion, il n'y aura pas de grande difficulté pour un geek mais un utilisateur débutant aura tout intérêt à prendre la solution PowerPack.

    Dans le cas d'une 64 bits, l'extension des fonctionnalités est délicate. En effet, certains logiciels propriétaires n'existent qu'en 32 bits. Il a donc fallu fabriquer des wrappers qui permettent de les utiliser. La version Free est donc relativement délicate et je ne peux que recommander la version PowerPack à ceux qui ne veulent pas y passer trop de temps.
    Il subsiste un petit problème avec le Flash : voyez http://wiki.mandriva.com/fr/Mandriva_Linux_2008_Spring_Errat(...)
    Il vous faudra sans doute désactiver PulseAudio dans le MCC avec Draksound et relancer la session.

    Toujours dans le cas de la 64 bits, j'ai modifié dans konqueror toutes les associations de fichiers de façon à utiliser Kaffeine en priorité sur Totem (appelé Lecteur vidéo).

    Pour toutes les versions : En ajoutant les sources du PLF (easyurpmi dans http://urpmi.org ) j'ai pu charger xine-faad et real-codecs. Ainsi, je peux lire toutes mes vidéos.

    J'ajoute aussi kdegraphics-kuickshow car c'est mon afficheur de photos préféré.

    En conclusion, encore une superbe version de printemps qui n'aura pas trop souffert du passage à PulseAudio. Ainsi, la Mandriva 2009 n'aura plus qu'à affronter la migration complète à Qt4/KDE4 qui n'est pour l'instant qu'une option réservée aux plus téméraires dans la 2008.1.
    • [^] # Re: Versions 32bits et 64 bits

      Posté par (page perso) . Évalué à 3.

      Il subsiste un petit problème avec le Flash

      hum, parce que le gros problème, lui, est en passe d'être résolu, c'est cela ? Quand est-ce disponible en libre alors ? :D

      la migration complète à Qt4/KDE4 qui n'est pour l'instant qu'une option réservée aux plus téméraires dans la 2008.1
      c'est plutôt aux développeurs que c'est réservé, peu de fonctionnalités sont encore disponibles et neoclust met à jour de temps en temps le paquet en contrib pour qu'il soit à jour. Cela permet de porter les applications dans un environnement de bureau cohérent, même s'il est encore en cours de construction sur beaucoup de points afin de proposer une version 4.1 utilisable par le commun des mortels.
      La version 4.0 de KDE, c'est vraiment "pour voir" ne vous attendez pas à ce que ce soit complet ou que cela fonctionne parfaitement ; si vous n'êtes pas prêts à remonter des rapports de bugs, mieux vaudrait peut-être même ne pas regarder, vous risqueriez d'être (très) déçu :-)
      • [^] # Re: Versions 32bits et 64 bits

        Posté par (page perso) . Évalué à 2.

        Je suis sur KDE 4.0 en ce moment-même, et il est vrai que certains petits bugs (essentiellement d'affichage de la barre de démarrage) subsistent ou bien que certaines fonctionnalités sont encore manquantes... Mais il est tellement joli avec ses fameux plasmoïdes que je n'ai pas eu l'envie de me remettre à KDE 3.5... Et Dolphin est vraiment super ! :)
  • # Drivers

    Posté par . Évalué à 1.

    Bonjour à vous tous.

    Tu parles de drivers supplémentaires. Peux-tu nous dire plus s'il te plait ?

    Polytan
  • # Problème quand même

    Posté par . Évalué à 1.

    Bonjour
    Après une mise à jour sans problème j'ai un souci : plus moyen d'écouter les émissions enregistrées de la BBC avec leur iPlayer : pas de son sous Firefox et coupure au bout d'une ou deux mn sous Konqueror. Quelqu'un pour confirmer ?
    • [^] # Re: Problème quand même

      Posté par (page perso) . Évalué à 2.

      Je suppose que c'est du Flash ?
      Il y a deux soucis identifiés (au moins) avec Flash
      http://wiki.mandriva.com/fr/Mandriva_Linux_2008_Spring_Errat(...) dont l'un est imputable à Adobe (et ne peut pas être corrigé, à ma connaissance Flash n'étant pas disponible en libre...).
      ça fonctionnait avec les greffons Gnash ou en:Swfdec ?

      Qu'as-tu regardé comme sources potentielles du problème ?
      Il est toujours intéressant de regarder les notes de version pour voir ce qui change http://wiki.mandriva.com/fr/Mandriva_Linux_2008_Spring_Notes
    • [^] # Re: Problème quand même

      Posté par . Évalué à 3.

      je touche la minute bbc world de deux manières différentes selon la carte vidéo de mes portables

      -si chipset intel : j'installe mplayer + le plugin/mozilla, + win32codec et je vire le plugin mozilla de gstreamer. Ensuite j'installe l'extension mediaplayer connectivity et je parametre mon fichier .mplayer pour la sortie vidéo comme indiqué dans les erratas du wiki (j'ai gardé compiz)

      -si chipset ATI, lors du lancement du plugin gtreamer dans firefox, je demande la lecture dans totem, qui me demande de télécharger successivement une série de greffons avec codéine (pas chez fluendo evidemment mais dans les paquets mdv ou plf). Après 3 séries de téléchargement, j'ai ma minute BBC world

      Pour les nouveaux enregistrements, ils utilisent le plugin flash qui ne me pose pas de pb majeur sur portable+ chipset intel mais que je dois mettre à jour sur les portables avec chipset ATI

      (dans tous les cas j'ai gardé compiz et ça marche)
      J'avais quitté mdv en 2006, j'y retourne :) cette version est remarquable

      je n'attends qu'une chose, un lancement optimise pour l'eeepc...
  • # Ralink et Mandriva 2008 Spring

    Posté par (page perso) . Évalué à 3.

    C'est marrant, au début tu dis que tu as eu des succès moyens avec le Wi-Fi à base de chipset Ralink, et à la fin, tu dis que ça c'est bien amélioré...

    En fait, pour moi, cette 2008 et Ralink, c'est un cauchemar, et pour beaucoup de gens du forum Mandriva... À tel point que beaucoup reviennent à la solution ndiswrapper : un comble pour un matériel dont le constructeur a la courtoisie de livrer des spécifications et des pilotes libres !
    D'après les développeurs eux-mêmes du pilote rt2500pci, celui inclus dans le noyau 2.6.24 est buggué, et les corrections n'ont été intégrées que dans le noyau 2.6.25.

    On en parle plus en détail sur ces posts du forum :
    http://forum.mandriva.com/viewtopic.php?t=84402
    et là : http://forum.mandriva.com/viewtopic.php?t=84388
    • [^] # Re: Ralink et Mandriva 2008 Spring

      Posté par . Évalué à 3.

      Le "problème" avec Ralink est qu'il y a deux drivers. L'ancien avec sa pile et le nouveau qui utilise la nouvelle pile Linux. Pour le nouveau c'est encore en plein évolution. Ubuntu et Fedora ont décidé de passer à la nouvelle pile. Ça ne marche peut-être pas mieux que l'ancien système, mais ça a plus d'avenir.
      Je crois que la nouvelle pile n'est pas encore upstream (pour 2.6.27 ?).
      • [^] # Re: Ralink et Mandriva 2008 Spring

        Posté par (page perso) . Évalué à 3.

        depuis 1 an, plus moyen d'utiliser ma RT2500...

        donc j'ai arrêté d'essayer, je ne voulais pas de ndiswrapper... j'attends doucemetn que ça revienne.

        Note : j'ai essayé TOUS les drivers (les anciens (CVS) et les nouveaux )
        • [^] # Re: Ralink et Mandriva 2008 Spring

          Posté par . Évalué à 2.

          > Note : j'ai essayé TOUS les drivers (les anciens (CVS) et les nouveaux )

          Les nouveaux demandent la nouvelle pile 802.11 et donc ce n'est pas que changer de driver.
          Fedora qui est proche des développements (Red Hat employe le mainteneur du sous-ensemble wifi de Linux) a une grosse pile de patchs. Et à ma connaissance il n'y a que Ubuntu et Fedora qui fournit la nouvelle pile 802.
          • [^] # Re: Ralink et Mandriva 2008 Spring

            Posté par . Évalué à 4.

            La nouvelle pile 802.11 (devicescape) est incluse depuis longtemps dans le noyau en mainstream, depuis le 2.6.22 si l'on en crois ce qui est indiqué ici : http://linuxfr.org/2007/07/09/22676.html , et c'est du patrick-g ;-)
            • [^] # Re: Ralink et Mandriva 2008 Spring

              Posté par . Évalué à 2.

              Autant pour moi.
              Mais le patch dans F8 (2.6.24) est tellement gros qu'il y a de quoi douter :
              $ cat linux-2.6-wireless*.patch | diffstat | tail -1
              380 files changed, 86306 insertions(+), 62511 deletions(-)
              • [^] # Re: Ralink et Mandriva 2008 Spring

                Posté par . Évalué à 3.

                Oui, mais la tu comptes (si je ne m'abuse) :

                - les patchs sur la stack wifi
                - Et les patchs sur les drivers wifi, qui pour accentuer le tout sont en train de passer sur la nouvelle stack (ben oui, c'est pas parce que la pile est entrée dans le noyau que les drivers ont été portés dessus immédiatement).
                - Les patchs spécifiques Fedora sur le wifi

                p.ex. : C'est dans le 2.6.24 que le driver rt2x00 a fait son entrée dans le noyau
          • [^] # Re: Ralink et Mandriva 2008 Spring

            Posté par (page perso) . Évalué à 4.

            si si t'inquiète... je suivais le noyau d'aussi près que possible, à savoir que j'utilisais toujours le dernier "kernel-linus" de la cooker de mandriva (ouais, tu sais, y'a ps que redHat et fedora qui ont des trucs moumoute)

            style : sur ma bécane actuelle :
            Linux localhost 2.6.24.4-desktop-1mnb #1 SMP Thu Mar 27 14:34:39 CET 2008 i686 Intel(R) Core(TM)2 Duo CPU E6750 @ 2.66GHz GNU/Linux

            sur une bécane cooker :
            kernel-linus-2.6.25-1mdv

            donc bon... oui j'étais à jour, que ce soit avec la pile ou sans.
          • [^] # Re: Ralink et Mandriva 2008 Spring

            Posté par (page perso) . Évalué à 3.

            La nouvelle pile wi-fi était déjà dans la Mandriva 2008.
            http://wiki.mandriva.com/fr/Mandriva_Linux_2008_Nouveaut%C3%(...)
        • [^] # Re: Ralink et Mandriva 2008 Spring

          Posté par (page perso) . Évalué à 4.

          Chez moi, les pilotes rt2500 CVS marchent bien, je les avais compilés et installés dans la 2007 Spring.
          Pour la 2008, ceux inclus marchaient bien (c'était bien encore les rt2500)
          Pour la 2008 Spring, les nouveaux rt2x00 avec la nouvelle pile mac80211 ne marchent pas.
          Alors j'ai compilé et installé les rt2500 CVS, modifié /etc/modprobe.conf pour les prendre en compte et blacklister le module rt2500pci issu du pilote rt2x00, et maintenant, ça marche nickel. Les modules mac80211 et rt2500pci ne montent plus, c'est bien rt2500 CVS qui prend en charge ma carte, tout va bien.
          Seul truc qui marche pas : l'applet net_applet qui se met pas à jour dynamiquement quand la qualité du lien change. Elle reste calée à ce qu'elle a détecté à son lancement. Mais c'est pas grave, net_applet est un des premiers trucs que je vire du démarrage - sur un PC de bureau, fixe, elle se justifie pas.
          Pour info, ma carte est une Belkin 54g PCI.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.