Journal Nouvelle version de gnash : la 0.8.8

Posté par (page perso) .
Tags : aucun
10
24
août
2010
Comme vous le savez tous, gnash est un lecteur flash libre sous licence GNU GPLv3, il peut marcher en tant que simple lecteur ainsi que dans Firefox, Chrome, Konqueror et tout un tas d'autres butineurs basés sur Geko.

Qu'apporte cette nouvelle version ?
Les principales sont pour moi :
* Youtube marche maintenant à 100%, si vous avez des problèmes il est conseillé d'effacer vos cookies.
* Le rendu peut être fait au travers de Cairo, OpenGL ou AGG
* Il peut switcher entre FFMpeg et Gstreamer pour la lecture des différents médias.
* Il peut tirer partie de la librairie VAAPI pour le décodage vidéo.

Et oui ! Gnash est bien le seul lecteur flash linux à tirer partie du hard pour la lecture de vidéos, information qui ravira les heureux possesseur d'une carte intel utilisant VAAPI, un lecteur flash et des pilotes libres miam !!!

Le petit lien qui va bien avec toutes les infos :
http://gnashdev.org/?q=node/76


PS: J'ai hésité à poster le lien sur la tribune des rédacteurs au cas ou ça intéresserai quelqu'un d'écrire une dépêche ou à poster un journal vite avec une traduction approximative des nouveautés.
  • # Journal proposé

    Posté par (page perso) . Évalué à 3.

    C'est fait, j'ai proposé un journal.
    Il y a une phrase qui m'a posé pas mal de problèmes et que j'ai préféré mettre de côté, un validateur pourra toujours l'intégrer si quelqu'un trouve une traduction digne de ce nom :
    Improved input device handling when using a raw framebuffer

    Commentaire sous licence LPRAB - http://sam.zoy.org/lprab/

    • [^] # Re: Journal proposé

      Posté par (page perso) . Évalué à 7.

      >> C'est fait, j'ai proposé un journal.

      Tu veux dire une dépêche ?

      >> Improved input device handling when using a raw framebuffer

      Gestion améliorée des périphériques d'entrée quand un raw framebuffer est utilisé.
      Gestion améliorée des périphériques d'entrée quand un framebuffer brut est utilisé.
      • [^] # Re: Journal proposé

        Posté par . Évalué à 1.

        >> Gestion améliorée des périphériques d'entrée quand un framebuffer brut est utilisé.

        Gestion améliorée des périphériques d'entrée quand un tampon de trames brutes est utilisé.
      • [^] # Re: Dépêche proposée

        Posté par (page perso) . Évalué à 2.

        Aneffé, /me se mélange les pinceaux.

        Merci pour les suggestions, tout compte fait je pense qu'il vaut mieux laisser intact le raw framebuffer même si j'ai bien ri des traductions proposées :)

        Commentaire sous licence LPRAB - http://sam.zoy.org/lprab/

        • [^] # Re: Dépêche proposée

          Posté par (page perso) . Évalué à 3.

          Correction : « /moi se mélange les pinceaux. » À prononcer « barre oblique moi » évidemment.

          DLFP >> PCInpact > Numerama >> LinuxFr.org

  • # Comme depuis bien longtemps

    Posté par . Évalué à 10.

    Je teste régulièrement les nouvelles versions des lecteurs flash alternatifs qui sortent, mais je n'ai jamais réussi à en faire fonctionner un de manière satisfaisante.
    Celle ci confirme la règle également.

    Résultat d'une visite de youtube :
    Sous Konqueror, crash direct.
    Sous Firefox, j'ai droit à un beau carré noir à la place de la vidéo (je suppose que le lecteur doit planter aussi, mais il n'y a aucun log dans le terminal).
    Sous chrome, la ça ne plante plus mais après avoir utilisé le CPU à 100% pendant 1min et affiché un beau rectangle gris, il me dit qu'une erreur est arrivée et qu'il ne peut pas lire la vidéo.

    Pour finir sur une touche positive, j'ai quand même réussi à lancer une animation parmi celles proposées sur le wiki :
    http://www.cse.unsw.edu.au/~ywid062/pf/toy.swf
    • [^] # Re: Comme depuis bien longtemps

      Posté par . Évalué à 4.

      euuuh t'aurais pas plus un souci de lecture video ? à l'inverse du plugin flash d'adobe, gnash utilise ce qui est dispo sur ta machine, en clair si ce qui est installé niveau lecture video est foireux, gnash foirera aussi... donc creuse peut être plus dans ce sens... non ? des soucis avec la lecture video ? lecture de fichiers flv par exemple avec gstreamer par exemple ?
      • [^] # Re: Comme depuis bien longtemps

        Posté par . Évalué à 3.

        Totem arrive à lire des vidéos flv / mp4 donc je suppose que le problème ne viens pas de gstreamer
        En plus il n'y a pas que les vidéos youtube qui ne fonctionnent pas.
    • [^] # Re: Comme depuis bien longtemps

      Posté par (page perso) . Évalué à 3.

      Vire les cookies liés à Youtube et réessaie pour voir ?

      Commentaire sous licence LPRAB - http://sam.zoy.org/lprab/

    • [^] # Re: Comme depuis bien longtemps

      Posté par . Évalué à 2.

      En tout cas, sur la page de test Adobe Flash [http://www.adobe.com/software/flash/about/], ça marche nickel ! Et ça ne peut pas être le lecteur officiel, je suis en amd64.

      Bon sur Youtube, ça déconne, mais le lecteur et les contrôles s'affichent. Ne manque que la vidéo...

      Article Quarante-Deux : Toute personne dépassant un kilomètre de haut doit quitter le Tribunal. -- Le Roi de Cœur

      • [^] # Re: Comme depuis bien longtemps

        Posté par (page perso) . Évalué à 1.

        Pas compris "Et ça ne peut pas être le lecteur officiel, je suis en amd64.". Flash tourne avec nspluginwrapper. Bon chez moi ça arrête pas de planter mais bon...
        • [^] # Re: Comme depuis bien longtemps

          Posté par . Évalué à 2.

          Bah lecteur officiel pour amd64, quoi. C'est-à-dire aucun depuis qu'ils ont arrêté le support...

          Article Quarante-Deux : Toute personne dépassant un kilomètre de haut doit quitter le Tribunal. -- Le Roi de Cœur

          • [^] # Re: Comme depuis bien longtemps

            Posté par (page perso) . Évalué à 2.

            Le lecteur désormais non supporté en x86_64 donc qu'Adobe ne propose plus, et pour Flash 10.0, ça te va ?
            http://heldroe.org/~zarmakuizz/libfp_10.0-linux-x86_64.tar.g(...)

            Commentaire sous licence LPRAB - http://sam.zoy.org/lprab/

            • [^] # Re: Comme depuis bien longtemps

              Posté par . Évalué à 2.

              Celui avec ou sans les trous de sécu qui n'ont jamais été patchés en x86_64 depuis la fin du support...
              • [^] # Re: Comme depuis bien longtemps

                Posté par (page perso) . Évalué à 3.

                Sans, bien évidemment. Si quelqu'un a la version avec, ou juste la 10.1 à des fins de test, je suis preneur.

                Commentaire sous licence LPRAB - http://sam.zoy.org/lprab/

                • [^] # Re: Comme depuis bien longtemps

                  Posté par . Évalué à 4.

                  Donc tu proposes à quelqu'un, en toute connaissance de cause, d'installer un lecteur flash qui permet à n'importe quel site visité d'exécuter du code sous l'id de l'utilisateur faisant tourner le navigateur ? Je vois pas d'autre mot que "Whaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa"
                  • [^] # Re: Comme depuis bien longtemps

                    Posté par (page perso) . Évalué à 2.

                    Je suis pas sûr qu'avec un bouzin à jour on soit tout autant protégé puisque le support a été arrêté avant le signalement d'une autre faille de sécurité corrigée partout sauf la version linux 64bits, ce qui rend les anciennes failles obsolètes s'il faut attaquer des utilisateurs de distributions Linux 64bits (qui sont tout de même fort peu nombreux face à l'utilisateur lambda sous windows).

                    Commentaire sous licence LPRAB - http://sam.zoy.org/lprab/

                    • [^] # Re: Comme depuis bien longtemps

                      Posté par . Évalué à 1.

                      C'est ce que j'essais de te faire remarquer ironiquement depuis deux messages ! Avoir un lecteur flash x86_64 sous linux implique forcément que tu as un énorme trou béant et que tu ne peux pas contrôler. N'importe quel site peut s'amuser à faire ce qu'il veut.

                      Pour remettre du contexte; je rappelle qu'on disait avant qu'il n'y avait plus de lecteur officiel 64 bits flash et toi tu arrives avec "Sisi regarde voilà le lien vers mon lecteur (passoire)". Tu es grand, tu fais ce que tu veux, mais de là à le proposer à quelqu'un...
                      • [^] # Re: Comme depuis bien longtemps

                        Posté par (page perso) . Évalué à 3.

                        C'est ce que j'essaie de te faire remarquer ironiquement depuis deux messages

                        rha, mais lis un peu ce qu'il te dit : il n'est plus supporté donc pouf, zou, napu de failles ! (oui c'est magique ce genre de raisonnement, je trouve aussi :D).
                        • [^] # Re: Comme depuis bien longtemps

                          Posté par . Évalué à 2.

                          Si ne plus être supporté revenait à ne plus être utilisé, ce raisonnement pourrait se tenir... Mais le problème c'est que certains continuent à le proposer en téléchargement.

                          Article Quarante-Deux : Toute personne dépassant un kilomètre de haut doit quitter le Tribunal. -- Le Roi de Cœur

          • [^] # Re: Comme depuis bien longtemps

            Posté par (page perso) . Évalué à 1.

            Moui, enfin comme dit Maxime le lecteur 32 bits fonctionne très bien sur une distrib' 64 bits (enfin très bien, comme sur une 32 quoi) donc ce n'est pas parce que tu es sur amd64 que tu ne peux pas avoir un Flash officiel qui tourne.
            • [^] # Re: Comme depuis bien longtemps

              Posté par . Évalué à 3.

              Pour moi, un lecteur officiel est un lecteur qui fonctionne de manière native sur la plate-forme que j'utilise.

              Le cas que vous me présentez ne me paraît pas être l'usage officiel, même si c'est parfaitement possible.

              Article Quarante-Deux : Toute personne dépassant un kilomètre de haut doit quitter le Tribunal. -- Le Roi de Cœur

              • [^] # Re: Comme depuis bien longtemps

                Posté par (page perso) . Évalué à 1.

                Je t'avouerais que j'ai juste installé flash sans me poser la question de si c'était une version 32 ou 64bits. Sur ma distro orientée grand public, c'était complètement transparent que j'avais même pas fait gaffe.
                Cela dit, je retenterai gnash, surtout si ça me permet de regarder des vidéos sans utiliser autant mon CPU...
              • [^] # Re: Comme depuis bien longtemps

                Posté par . Évalué à 2.

                Le code 32 bits s’exécute « nativement » sur un processeur 64 bits. Compatibilité tout ça…
                • [^] # Re: Comme depuis bien longtemps

                  Posté par . Évalué à -1.

                  Pas sur les processeurs IA-64, comme les Itaniums (sauf pour ceux d'avant 2006 qui possédaient une couche d'abstraction pour compabilité, mais qui les rendaient moins performants que leurs équivalents IA-32).

                  Article Quarante-Deux : Toute personne dépassant un kilomètre de haut doit quitter le Tribunal. -- Le Roi de Cœur

                  • [^] # Re: Comme depuis bien longtemps

                    Posté par (page perso) . Évalué à 2.

                    C'est vrai que c'est le genre de processeur répendu chez les utilisateurs desktop.

                    « Rappelez-vous toujours que si la Gestapo avait les moyens de vous faire parler, les politiciens ont, eux, les moyens de vous faire taire. » Coluche

      • [^] # Re: Comme depuis bien longtemps

        Posté par . Évalué à 2.

        Bon alors, maintenant j'ai un bug bien bizarre : quand je suis sur une page où une vidéo Youtube est intégrée, ça passe très bien (on ne voit pas la différence avec le lecteur d'Adobe), par contre si je clique sur la vidéo pour la regarder directement dans Youtube, j'ai le message « An error occured » et pas de vidéo.

        Suprenant. J'ai vidé mes cookies et tout mais pas mieux, et je ne vois pas d'où ça peut venir.

        Article Quarante-Deux : Toute personne dépassant un kilomètre de haut doit quitter le Tribunal. -- Le Roi de Cœur

  • # Très bonne version, enfin utilisable.

    Posté par . Évalué à 3.

    100% youtube, jusque là je confirme, ca fait 2 jours que je l'utilise et pas de problème de ce coté.
    Certaines autres animations comme les pubs fonctionnent aussi (super !...), d'autres non, et les jeux faut oublier.

    Par contre je remarque de gros lags sur youtube quand la souris passe devant la vidéo, et pire encore si je fait joujou avec le menu de lecture de youtube.

    A part ça c'est tout à fait utilisable sur youtube, et la qualité est aussi bien que le plugin officiel.

    Le plein écran est pire que lent par contre, encore plus que le flahsplugin...

    Pour ceux dont l'usage de flash se résume à youtube et encore plus pour ceux qui sont en x64 (puisqu'adobe a laché cette plateforme... et ne sort plus de mises a jour dessus) , vous pouvez enfin passer à gnash sans problèmes, ou dans quelques versions :P
    • [^] # Re: Très bonne version, enfin utilisable.

      Posté par (page perso) . Évalué à 3.

      J'ai testé 1 jour :
      - youtube la plupart du temps opérationnel mais avec le CPU qui tourne à 100% alors que la vidéo est sur pause. Parfois ça plante.
      - d'autres sites qui proposent des vidéos déconnent avec des minicoupures "buffer 0%"...
      - Pas moyen d'écouter la radio sur le mouv'

      Bref, c'est beaucoup mieux qu'avant mais c'est pas encore utilisable pour moi :/. Projet que je vais suivre de près en tout cas. Enfin, vivement que l'html5 remplace bien des cas d'utilisation du flash... !

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.