Forum Linux.général corriger un filsystem

Posté par . Licence CC by-sa
Tags : aucun
2
7
oct.
2013

Salut,

J'ai un problème plutôt ardu avec un filesystem.
Il y a des entrées dedans qui correspondent à aucun inode et avec aucun droit. Ca donne ça :

ll /usr/share/man/pt/man5
ls: cannot access /usr/share/man/pt/man5/apt_preferences.5.gz: Invalid argument
ls: cannot access /usr/share/man/pt/man5/sources.list.5.gz: Invalid argument
total 16
-rw-r--r-- 1 root root 15414 Apr 15 2011 apt.conf.5.gz
-????????? ? ? ? ? ? apt_preferences.5.gz
-????????? ? ? ? ? ? sources.list.5.gz

Évidemment pas moyen simplement de faire rm.
Et ça se complique car dès que j'accède à ces fichiers, même un simple ls, ça (...)

Forum Linux.général [Urgent] Problème avec rsync : file too large

Posté par .
Tags : aucun
2
23
août
2012

Salut,

Pour sauvegarder toutes mes données avant de partir en vacance j'essaye de faire du rsync d'un nas (Thecus) vers un autre nas (Netgear).
Des deux coté, l'OS est un linux (2.6.31 et 2.6.33) et le filsystem destination est un ext4.
Mon soucis concerne les gros fichiers, videos ou isos.
J'ai des erreurs rsync comme celle là :

rsync: send_files failed to open "/raid0/data/Nas/backup/PC Mururoa/Jeux/StarCraft II/Campaigns/Liberty.SC2Campaign/base.SC2Assets": Value too large for defined data type (75)

La limite semble être 2 GB. (...)

Forum Linux.debian/ubuntu Debian Stick @ boot

Posté par .
Tags : aucun
0
26
juil.
2012

Salut,

J'ai un comportement bizarre de ma debian (wheezy) avec vmware server.
Au bout ça affiche :

.
.
.
[3.413454] sd 0:0:0:0 [sda] Assuming drive cache: write through
[3.413843] sd 0:0:0:0 [sda] Assuming drive cache: write through

et puis rien pendant environ 3 minutes.
Et ensuite ça continue à booter comme si de rien n'était et je n'ai pas de dysfonctionnement une fois démarrée.
Si j’enlève l'option quiet dans le boot je vais jusqu'à :

[3.493454] sd 0:0:0:0 [sda] (...)

Forum Linux.redhat Pourquoi ce #%$$ de système s'obstine à swapper ?

Posté par .
Tags : aucun
0
21
sept.
2011

Salut,

J'ai un serveur (en VM) en RHEL 5.5 qui s'obstine à swapper avec PLEIN de ram disponible.
Avec une swappiness à 15 j'ai déjà 25 MB dans le swap moins d'une heure après un reboot alors que la free ram n'a jamais été inférieure à 250 MB. Et je ne parle pas du cache mais de la ram réellement libre.
Pas d'erreur dans les logs.
Donc j'ai mis la swappiness à 0 mais j'aimerai bien comprendre pourquoi le système (...)

Forum Linux.debian/ubuntu USB 3.0 --> remount read only

Posté par .
Tags : aucun
1
9
juil.
2011

Salut, J'ai connecté un Stick USB 3.0 à une machine sous debian squeeze. Je le partitionne, crée un volume LVM, je crée les LV et je les formate (ext3 ou ext4). Ensuite le les monte et je lance un rsync pour transférer des données dessus. Et là ça ne rate pas, ça commence à copier normalement et puis ça freeze. Quand je regarde dans les logs j'ai des kilometres de : "usb 3-1: Device not responding to set address." Et (...)

Forum Linux.général High load

Posté par .
Tags : aucun
1
4
avr.
2011

Salut,

J'ai une vm (vmware) avec un high load (~19-20) par moment avec une redhat 5 et je n'arrive pas à trouver ce qui cause cette charge. Les tools sont à jour et le serveur vmware n'est pas surchargé. La configuration réseau est optimale et le stockage est sur le SAN.

J'ai vérifié :

  • accès disques ok
  • utilisation cpu ok
  • utilisation réseau ok
  • ram libre ok ~ 250 process

Donc pas de surcharge cpu, pas de io wait et utilisation (...)

Forum Linux.debian/ubuntu dhcp3-server ne démarre pas ... au boot

Posté par .
Tags : aucun
2
12
jan.
2011
Salut,
J'ai un problème avec le démarrage de dhcp3-server sur une debian (5.0.7) up to date.
Le serveur dhcp3-server ne démarre pas mais seulement au boot avec un message classique "Not configured to listen to any interfaces!" dans le syslog.
Pourtant j'ai bien dans /etc/default/dhcp3-server :
INTERFACES="eth0"
Et le truc qui fait que je ne comprends pas ce qui se passe c'est que si je me connecte sur le serveur et que je démarre le dhcpd à la main ça (...)

Forum Linux.général Probleme de cache et de swap

Posté par .
Tags : aucun
0
29
nov.
2010
Salut,
J'ai un comportement très bizarre sur certains de mes serveurs.
Le cache se rempli progressivement jusqu'à occuper toute la ram libre. Jusque là c'est un peu intrigant mais pas forcement anormal.
Là ou je ne comprends pas c'est que lorsque le cache est arrivé à 'manger' toute la ram et que beaucoup de process sont créés alors le système ne vide pas le cache pour faire de la place, ou pas complètement, mais utilise de la swap.
Par exemple (...)

Forum général.petites-annonces Baie SCSI --> 15 €

Posté par .
Tags : aucun
2
4
mar.
2010
Salut,

Je vends une baie externe SCSI car je n'en ai plus l'usage.
C'est une baie SUN Ultra SCSI pour 6 disques. Un multipack. Ca se connecte bien sur à un PC aussi.
Vendue avec 6 disques 18 GB (Ultra 160, 10K rpm) + 3 disques de 18 GB en spare(idem) + le câble + le bouchon actif.

Prix : 15 €
A ce prix c'est cadeau pour jouer avec les raids et/ou zfs.

Vente en MP sur Lyon.

Forum général.cherche-logiciel Raid offline

Posté par .
Tags : aucun
0
30
oct.
2009
Salut,
Je cherche à faire un 'raid offline'.
En clair au lieu de faire du raid1 je veux synchroniser les deux disques offline (boot sur livecd ou usb stiick ou mini partition) avec un outil du type ghost/clonezilla pour pouvoir me servir du deuxième disque pour booter si le premier lâche.
Pas de problème pour faire la copie, un simple dd ferait l'affaire d'ailleurs, mais ce que je cherche c'est un outil capable de ne copier que les blocks qui (...)

Forum Programmation.shell code retour sed ?

Posté par .
Tags : aucun
0
12
oct.
2009
Salut,

J'essaye de faire un "change or add" avec sed mais ça ne passe pas.

sed --in-place '/^MaxMem/ c\MaxMem = default' /tmp/test || echo "MaxMem = default" >> /tmp/test

mais si le sed ne trouve pas la ligne qui commence par MaxMem le echo n'est executé. Si il la trouve il la modifie correctement.
Ou est le problème ??
Le sed ne devrait pas retourner un code d'erreur si le search ne marche pas ?

Forum Linux.redhat Traduction please

Posté par .
Tags : aucun
1
7
oct.
2009
Salut,
J'ai testé un bout de script sur une debian et ça passe nickel mais sur une redhat ça coince méchament :

echo "1 2 3 4/awk" | awk {' print $2" "substr($4,match($4,/\//)+1) '}

Debian :
2 awk

redhat :
awk: cmd. line:1: print $2" "substr($4,match($4,/\//)+1)
awk: cmd. line:1: ^ syntax error

C'est très probablement lié aux différences awk/gawk/nawk mais je n'arrive pas à trouver la bonne syntaxe sur la redhat. Pourtant, dans le man, les fonctions substr et match (...)

Forum Linux.debian/ubuntu Mise à jour

Posté par .
Tags : aucun
0
17
nov.
2008
Bonjour,
Je n'arrive pas à trouver une méthode pour faire une mise à jour debian jusqu'à une date donnée. J'ai cherché un peu partout dans preferences, apt-get, dpkg mais rien de concluant.
Le but c'est d'avoir des serveurs identiques quelle que soit leur date d'installation.
La seule astuce c'est d'avoir une liste de paquets par dpkg --get-selections et de les réappliquer ensuite mais c'est moyen parce que si on ajoute le moindre paquet il va forcement arriver à la dernière (...)