Journal Mesa 12.0(.1) est publié

Posté par . Licence CC by-sa
27
10
juil.
2016

Hello velyday,
Mesa 12.0.1 a été publié le 08.
Pour mémoire la version 10 était sorti fin 2013, tandis que la version 11 en septembre 2015. Voilà, en ce début de juillet 2016, la nouvelle mouture de cette célèbre bibliothèque offrant une implémentation libre des spécifications OpenGL. En résumé : support complet de la spécification OpenGL 4.3, plus :

  • Vulkan sur le matériel Intel de génération Ivy Bridge ;
  • OpenGL 4.3 pour nvc0, radeonsi & i965 (Gen8+)
  • OpenGL ES 3.1 pour nvc0 & radeonsi
  • GLVND support sur GLX, OpenGL
  • Gallium, mise à jour du rendu logiciel (SWR)
  • DRI3, activation pour VDPAU, OMX & VAAPI

Du Lourd, donc. Et à un rythme de sortie légèrement plus intense/soutenu qu'auparavant.

Dépêche de référence
Dépêche sur la v11

hop, j'retourne faire une session Xcom2 en mode légende, désolé, pardon aux mamans toussa

  • # Software rendering

    Posté par (page perso) . Évalué à 3.

    Quelle version d'OpenGL est supportée par le renderer software?

    • [^] # Re: Software rendering

      Posté par . Évalué à 4.

      toujours 3.3 pour les renderer habituels, 3.1 pour le nouveau truc d'intel

      source : https://mesamatrix.net/

      splash!

      • [^] # Re: Software rendering

        Posté par (page perso) . Évalué à 4. Dernière modification le 11/07/16 à 16:37.

        Tu t'emmêles entre OpenGL et OpenGL ES : en OpenGL, Intel est à 4.3. Pour le rendu logiciel, c'est pareil!

        … vivement la nouvelle API Vulkan pour que ce soit encore plus confus!

        ⚓ À g'Auch TOUTE! http://afdgauch.online.fr

  • # VAAPI et compagnie

    Posté par . Évalué à 3.

    J'ai pas encore compris le fonctionnement de VAAPI, et plus spécifiquement, ce qu'il faut faire pour en bénéficier. Faut il installer certains paquets pour en bénéficier? Est ce qu'il faut un support au niveau du lecteur de vidéo, etc?
    Par exemple, j'utilise fedora, et, après l'installation, les paquets vaapi-intel ou gstreamer-vaapi ne sont pas installés, ce qui rend la découverte de cette fonctionnalité pas évidente pour le grand public.
    De même, est ce que cette accélération fonctionne directement dans les browsers, ou idem, faut il installer des plugins supplémentaires?
    Merci pour vos détails :)

    • [^] # Re: VAAPI et compagnie

      Posté par . Évalué à 2.

      Tu installes les libs, et tu dis à ton player préféré de passer par vaapi (avec mpv hwdec=vaapi). Et voilà.

      (https://wiki.archlinux.org/index.php/Hardware_video_acceleration#Configuring_VA-API)

    • [^] # Re: VAAPI et compagnie

      Posté par (page perso) . Évalué à 4. Dernière modification le 11/07/16 à 16:42.

      Oui, les distributions n'activent pas l'accélération vidéo libre par défaut, souvent par oubli. Pour VAAPI, le mieux est d'installer vainfo, qui va te dire si tout est là. Ensuite, tu n'auras pas l'accélération par défaut dans le navigateur Firefox pour l'instant. Il utilise gstreamer, donc ça devrait bientôt arriver.

      Pour ma part, ça marche bien avec transmaggedon pour convertir des vidéos, et mpv pour lire des vidéos comme indiqué dans le commentaire ci-dessus (sur Mageia, j'ai activé VAAPI par défaut dans mpv, car il faut bien que ça soit facile à utiliser pour avoir des utilisateurs).

      ⚓ À g'Auch TOUTE! http://afdgauch.online.fr

      • [^] # Re: VAAPI et compagnie

        Posté par (page perso) . Évalué à 3.

        Dans vlc aussi il faut changer un paramètre dans la conf (simple, un combobox dont j'ai oublié le nom), mais encore faut savoir que cela existe alors que la case "accélération hardware" est coché et la sortie vidéo en auto.
        Madame Michu aura sa vidéo qui sacade et macrobloc donc.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.