Forum général.cherche-logiciel Comment se faire passer pour un Windows ?

Posté par .
Tags : aucun
0
17
sept.
2007
Bonjour,
J'accède à Internet via une connection wifi fournie par ma résidence universitaire. Rapide, pas cher... très bien.
Mais.
Mais la boite qui fournit le service a eu sur son cahier de charge "Poste client sous windows", qu'ils ont traduit par Internet Explorer comme navigateur. Et ils ont configuré tout leur bazard (parfeu, proxy, que sais-je...) pour IE, WLM et leurs frangins. Je le sais, je les appelé: ils m'ont répondu sur le ton de "Non mais déjà qu'on supporte windows, vous voudriez pas qu'on supporte les macs aussi ?"

Donc mes logiciels se vautrent alègrement dans la semoule pour accéder à l'extérieur: firefox totalement dans les choux, opera arrive parfois à charger une page ou deux, plus facilement si je le configure pour envoyer le user agent de IE, apt s'imagine que le serveur de OVH a pour IP 1.0.0.0, ce dont je doute. Idem pour sylpheed, dillo, pidgin... bref tout.
Le seul qui s'en tire, c'est links2, qui lui passe très bien.
Mais essayez de consulter un webmail type gmail avec links2 et vous comprendrez mon problème.

J'en viens donc à ma question: comment faire passer tout ça pour du windows ? Car mes collègues sous windows n'ont pas de problème: nagivation fluide, meme avec firefox, mises à jour du système...
Pour firefox j'ai essayé une extension modifiant le useragent, ça ne change rien.

Voilà, désolé d'avoir été long et bravo a ceux qui m'ont suivit jusqu'ici. Je crois vous avoir filé toutes les infos importantes... sinon je suis sous debian testing sur un iBook g4.

A vot'bon coeur...

antoine
  • # faux probleme...

    Posté par . Évalué à 3.

    je ne suis pas sur que le probleme viennent de l'identification du useragent IE.

    en effet firefox sous windows a bien le useragent firefox ou gecko

    donc je penses que le probleme vient plutot de la configuration du proxy et de l'identification sur celui-ci (NLM ou autre).

    c'est surement de ce coté là qu'il te faut chercher.

    il te faudra peut-etre configurer le proxy dans chacun des logiciels, ou bien alors dans la config general.
    • [^] # Re: faux probleme...

      Posté par (page perso) . Évalué à 1.

      Salut!

      Pour essayer de faire avancer le schminblik.... Essaye les choses suivantes, et copie ici ce que cela te donne (commandes a taper dans un terminal):

      *ping 217.146.186.221

      *ping yahoo.fr

      Si le premier fonctionne mais pas le second, cela veut dire que c'est la resolution DNS qui ne marche pas. Si les deux fonctionnent, cela veut dire que le probleme se situe au dela (proxy?). SI aucun ne fonctionnent, alors la....

      (a verifier aupres d'autres plus competents que moi en reseau): pour le proxy, peut etre que aller faire un tour (avec links2, vu qu'il a l'air de marcher!) sur http://www.getip.org/ . Cette page va te retourner l'IP de la machine qui consulte sa page (donc ton IP si tu es connecté directement à Internet, celle du proxy (?) si tu passe a travers un proxy/passerelle). Ensuite, j'essayerais bien de mettre cette IP en tant que proxy dans la configuration de Firefox...

      Mathias
      PS: merci a ceux qui maitrisent le reseau de me corriger!
      • [^] # Re: faux probleme...

        Posté par . Évalué à 1.

        alors on corrige :

        les pings, sans les * devant c'est mieux ;-)
        sinon je suis d'accord avec les tests et ce que cela induit comme resultat.


        l'histoire du proxy, helas il a des chances que tu ais l'adresse "internet" du proxy et pas l'adresse LAN par laquelle tu dois le contacter

        en tout cas c'est se qui se passe chez moi :

        Real IP: 10.0.0.X
        Internal IP: 10.0.0.X
        External IP 10.0.0.X
        Country: -
        State or Province: -
        City or Town: -
        Internet Service Provider: Private ip address lan
        Browser: Mozilla 1.8
        Proxy IP: 217.X.Y.Z


        alors que mon proxy est en 10.0.0.Y

        par contre, aller voir chez les copains sous windows comment est réglé le proxy peut aussi etre une solution.
  • # C'est vraiment etrange ...

    Posté par . Évalué à 1.

    ...qu'ils ce soit fais chier à ce point !

    La seul methode que je connaisse pour savoir le type de systeme utilisé c'est de regarder, attention jvais utiliser un mot que je maitrise pas, la taille des fenetres ip ... (ce que fais nmap).

    J'ai lue quelque part qu'il etait possible , mais instable , de changer ce comportement, pour etre identifier comme un windows, à voire.

    Mais la encore je sais même pas si c'est ça, un scan c'est longt, et j'imagine que vous etes nombreux.
    Ou alors ca ce passe au momnt de la connexion au wifi...

    Je vais suivre le thread au cas ou quelqu'un aurais une explication, ca m'interesse .

    Allez tous vous faire spéculer.

    • [^] # Re: C'est vraiment etrange ...

      Posté par . Évalué à 2.

      que dois tu faire pour te connecter ? C'est en dhcp ? Cela demande un proxy ?

      je doute que cela puisse faire quelque chose, mais au cas où, regarde si en désactivant temporairement le window scaling cela améliore quelque chose :

      echo 0 > /proc/sys/net/ipv4/tcp_window_scaling

      (pour info un site qui avait un routeur foireux empêchant toute connexion, j'avais pu me connecter (une seule fois il est vrai) avec links, mais pas avec le reste)
      Peux-tu pinger l'extérieur ?

      Il est également possible de modifier le MTU (maximum transfert unit, c-à-d la taille maximale de chaque paquet IP transmis) avec :

      ifconfig ppp0 mtu 800

      La valeur par défaut est de 1500. Baisser cette valeur peut être efficace sur une connexion modem ou qui a des difficultées.

      là encore, je ne pense pas que cela soit ça, mais on ne sait jamais.

      Only wimps use tape backup: real men just upload their important stuff on megaupload, and let the rest of the world ~~mirror~~ link to it

  • # Si links2 marche...

    Posté par (page perso) . Évalué à 1.

    ... c'est que quelque-part tout n'est pas perdu.

    Le problème vient donc surement de la conf de tes navigateurs (or links2). As-tu paramétré ton firefox pour le "(parfeu, proxy, que sais-je...)" ? Utilises-tu le même serveur de nom et et le même serveur DHCP que tes petits camarades ? Apparemment non si tu as des problèmes de résolution d'IP.
    • [^] # Re: Si links2 marche...

      Posté par . Évalué à 1.

      ... Je n'ai eu aucune configuration à faire autre que choisir le réseau, entrer la clé wep et donner mon login et pass sur la première page affichée (je suis TRES incompétent en réseaux). Mais pour links2 je n'ai rien eu à configurer. En fait je pensai à un filtrage parce-que opera passe... une fois sur vingt, et un peu plus s'il a l'useragent de IE.

      En tous cas merci à tous les trois, dès que j'ai finit les cours je suis ces pistes, et je vous dis ce que ça donne.

      antoine
  • # Requete DNS IPv6

    Posté par . Évalué à 1.

    J'ai eu un problème similaire : toutes les réponses DNS reçues par firefox donnent 1.0.0.0 alors que les ping passent sans problème.

    Je me suis rendu compte que les requêtes DNS AAAA (pour IPv6) donnaient toutes une adresse dans le genre 1.0.0.0, alors que les requêtes normales (uniquement IPv4) donnaient des résultats cohérents.

    Résultat : toutes les applications demandant des IPv6 aux DNS ne fonctionnaient pas, par contre pas de problème pour le ping.

    La solution : j'ai changé de serveurs DNS.

    Quelqu'un sait-il comment désactiver les requêtes AAAA au niveau système ?
    • [^] # Re: Requete DNS IPv6

      Posté par . Évalué à 1.

      Je rajouterai que ton problème ressemble à ceci :
      https://bugs.launchpad.net/ubuntu/+bug/81057

      Ca peut peut-être aider...
    • [^] # Re: Requete DNS IPv6

      Posté par . Évalué à 2.

      je pense aussi que c'est une couille liée à Firefox, regarde si dans le about:config :

      network.dns.disableIPv6 mis à true

      ca continue à gêner ensuite
      • [^] # Re: Requete DNS IPv6

        Posté par . Évalué à 1.

        Ce problème n'était pas lié directement à firefox, mais à tous les programmes qui faisaient des requêtes DNS IPv6 (firefox, evolution, wget, pidgin, etc.).

        Le fait de modifier firefox ne ferait pas forcement fonctionner les autres applications. Il faudrait faire une modification au niveau du système ... mais je ne sais pas comment le faire, ni si c'est tout simplement réalisable.
        • [^] # Re: Requete DNS IPv6

          Posté par . Évalué à 2.

          heureusement google est notre ami
          disable ipv6 linux

          nous renvoie :
          http://www.cyberciti.biz/tips/linux-how-to-disable-the-ipv6-(...)

          qui dit

          Sometime you just need to disable IPv6 protocol. In some case, you do not need it at all or it may increase browsing speed.

          Linux has Internet Protocol Version 6 (IPv6) enabled by default, almost all distro enable it.

          Open your modprob.conf file (Red Hat and friends) and add following line:
          # vi /etc/modprobe.conf

          Add following line:
          alias net-pf-10 off

          Save and close the file. Reboot the system.
          -------------------------
          If you are using Debian/Ubuntu linux (thanks to beranger), open file /etc/modprobe.d/aliases
          # vi /etc/modprobe.d/aliases
          Find the line:
          alias net-pf-10 ipv6
          Replace to
          alias net-pf-10 off
          alias ipv6 off


          • [^] # Re: Requete DNS IPv6

            Posté par . Évalué à 1.

            ... et c'est NeoX qui l'emporte avec sa désactivation de IPv6 !

            Bon j'ai d'abord joué du ping: pas de problème de résolution DNS.
            J'ai configuré Firefox pour qu'il n'utilise pas IPv6... rien.
            Mais après avoir désactivé IPv6 sur la machine... tout remarche.

            Merci à tous pour vos conseils, NeoX je t'aime.

            antoine
            • [^] # Re: Requete DNS IPv6

              Posté par . Évalué à 2.


              ... et c'est NeoX qui l'emporte avec sa désactivation de IPv6 !

              sauf que j'ai triché, car c'est fogoh qui a évoqué la solution, merci à lui donc

              je n'ai fait que chercher comment faire la desactivation de IPV6


              [...]NeoX je t'aime.

              heu, on va se calmer là, hein
              :-p
        • [^] # Re: Requete DNS IPv6

          Posté par . Évalué à 1.

          > Ce problème n'était pas lié directement à firefox, mais à tous les programmes qui faisaient des requêtes DNS IPv6 (firefox, evolution, wget, pidgin, etc.).

          ah, j'avais lu le contraire, disoli.
  • # installer IE pour Linux ?

    Posté par (page perso) . Évalué à 1.

    Bon c'est pas fun, mais tu devrais essayer d'installer

    http://www.tatanka.com.br/ies4linux/page/Fr/Installation

    Multitasking — The art of doing twice as much as you should half as well as you could.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.