Forum général.cherche-matériel configuration geforce 210

Posté par . Licence CC by-sa.
Tags : aucun
0
2
jan.
2013

Bonjour à tous,

JE viens de récupérer un nouveau PC. Il y a une carte graphique intégrée, mais j'ai ajouté une geforce 210 (Asus).
Je suis sous mageia2. Sans trop de difficulté j'ai configuré la sortie VGA en 1680x1050, mais impossible pour la sortie DVI. Elle reste bloquée à 640x480, ce qui fait pas beaucoup…
JE tourne en rond depuis plusieurs jours sans succès quelle que soit la méthode.
Si une bonne ame a la solution, je suis preneur.
Je tiens vraiment à utiliser la sortie DVI, pour laisser le connecteur VGA du moniteur libre pour y mettre un portable.
Merci

  • # booter dessus et eventuellement utiliser les pilotes non libre

    Posté par . Évalué à 2.

    tu as donc 2 cartes graphiques et 3 ports de sorties :
    - VGA sur carte integrée,
    - VGA sur Nvidia210
    - DVI sur Nvidia210

    1°) branches ton ecran sur nvidia210/dvi
    2°) regles ton bios pour booter sur la nvidia210 plutot que sur la carte integrée (voire desactive la carte integrée pour recuperer la RAM qu'elle utilise en memoire video.

    3°) le fait de booter dessus devrait activer la carte et lui faire voir les resolutions de l'ecran.

    si ce n'est pas le cas, regarde si tu as bien le pilote "nouveau" d'installer,
    voire, si tu n'es pas integriste du libre, essaie d'installer les pilotes "nvidia-glx" fournit par la distrib.

    • [^] # Re: booter dessus et eventuellement utiliser les pilotes non libre

      Posté par . Évalué à -1.

      Ca ne change rien ! Jusqu'à présent j'avait le VGA et le DVI de connecté. J'ai essayé ce que tu suggère : laisser que le DVI. Rien à faire, je n'arrive pas à lui faire sortir autre chose que du 640x480. J'ai le pilote proprio d'installé (en tout ca un lsmod me renvoie bien un nvidia comme module chargé). J'ai essayé de bricoler le fichier xorg.conf, essayé les outils nvidia (nvidia-setting et nvidia-xconfig), j'ai aussi essayé par le centre de control de mageia : toujours pareils.
      voila ce que me retourne un xrandr :
      Screen 0: minimum 320 x 175, current 640 x 480, maximum 640 x 480
      c'est comme si mon écran était inconnu.
      Je commence à désespérer.
      Merci quand même d'avoir pris la peine de me répondre.

      • [^] # Re: booter dessus et eventuellement utiliser les pilotes non libre

        Posté par . Évalué à 1.

        ca ressemble à un truc que j'avais sur une carte, il fallait faire un xorg personnalisé avec une option pour "Ignorer EDID" qui ne renvoyer rien ou renvoyait des infos erronées.

        • [^] # Re: booter dessus et eventuellement utiliser les pilotes non libre

          Posté par . Évalué à 0.

          je vien d'essayer avec une option "UseEDID" "false", et je patauge pas mal. Je suis arrivé à
          monter la résolution à 1024x768 sur le DVI. Le plus étrange c'est que dans le fichier xorg.conf, il
          y a plein de résolutions mais pas celle là !le pilote proposé par ma distrib est trop vieux ?
          c'est le 295.49-2.mga2, il me semble qu'il y a 360 qui existe ?
          mais pas dans la distrib pour l'instant.

          • [^] # Re: booter dessus et eventuellement utiliser les pilotes non libre

            Posté par . Évalué à 2.

            si tu as des resolutions dans ton xorg.conf

            il faut faire du menage, les distribs recentes detectant automatiquement la(les) carte(s) graphique(s) et interrogeant directement l'ecran pour connaitre les resolutions.

            le premier test pourrait etre de sauvegarder le fichier en xorg.conf.bak
            et de carrement le supprimer
            puis de redemarrer X (ou le PC) pour voir comment cela reagit.

            • [^] # Re: booter dessus et eventuellement utiliser les pilotes non libre

              Posté par . Évalué à 0.

              Dans ce cas ca ne marche pas, la carte graphique croit réellement qu'il y a un écran 640x480 de branché, je vois ça aussi bien avec la commande xrandr qu'avec nvidia-setting. C'est pour cela que je n'y suis pas arrivé avec les différents outils (nvidia-settin, ou le ccm de mandriva).

  • # resolu

    Posté par . Évalué à 1.

    Je suis arrivé à résoudre mon probleme. J'ai récupéré le xorg?conf de mon ancien pc qui avait aussi une carte nvidia avec ce meme moniteur.
    J'ai juste remplacé à la main la champs BoardName. Effectivement ca vient bien d'un pb avec edid, il y a dans mon ancien fichier une option pour ça (pas celle que j'ai tenté de mettre à la main, c'est un peu plus complexe, cf en dessous "NoDFPNativeResolutionCheck" . Au cas ou certains auraient le même pb je met la partie device du xorg.conf :

    Section "Device"
    Identifier "device1"
    VendorName "nVidia Corporation"
    BoardName "GeForce 210"
    Driver "nvidia"
    Option "DPMS"
    Option "TwinViewOrientation" "Clone"
    Option "ModeValidation" "NoWidthAlignmentCheck, NoDFPNativeResolutionCheck"
    Option "AddARGBGLXVisuals"
    Option "ExactModeTimingsDVI"
    Option "TwinView"
    EndSection

    Merci pour votre aide à tous, sans cela je ne suis pas certain d'y être arrivé.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.