Forum général.cherche-matériel Imprimantes (epson) dans soluOS

Posté par . Licence CC by-sa.
Tags : aucun
0
20
jan.
2016

J'essaye solusOS : assez sympathique, mais non standardisé en ce qui concerne les installations de paquets.
J'ai essayé en vain de faire fonctionner un imprimante epson XP-329 : impossible d'installer son driver ./configure renvoie à l'erreur :

configure: error: C compiler cannot create executables

et c'est le cas pour les autres tentatives d'installation (inkscape, par ex)

Quelqu'un utilise-t-il cette version rare de linux?
Cordialement

Alain CROCQ

P.S. J'utilise principalement Debian, mais, comme chacun, j'aime essayer une distribution "légère".

  • # Il manque des packets justement

    Posté par . Évalué à 1.

    On dirait que gcc ou libc-dev ne sont pas installés, donc il faut voir avec le gestionnaire exotique comment le faire.

  • # distrib legere ?

    Posté par . Évalué à 2.

    P.S. J'utilise principalement Debian, mais, comme chacun, j'aime essayer une distribution "légère".

    ben essaie Debian
    en partant d'une netinstall tu installes uniquement ce dont tu as besoin,
    c'est donc leger, configurable, avec une grande base de paquet.

    • [^] # Re: distrib legere ?

      Posté par . Évalué à 1.

      À toute fin utile, voici les messages d'erreurs :
      /home/MyName/Téléchargements/epson-inkjet-printer-escpr-1.6.2/config.log 3687/7388 49%
      configure:2708: result: yes
      configure:2882: checking for gcc
      configure:2898: found /usr/bin/gcc
      configure:2909: result: gcc
      configure:3138: checking for C compiler version
      configure:3147: gcc --version >&5
      gcc (Solus Project) 5.2.0
      Copyright (C) 2015 Free Software Foundation, Inc.
      This is free software; see the source for copying conditions. There is NO
      warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

      configure:3158: $? = 0
      configure:3147: gcc -v >&5
      Using built-in specs.
      COLLECT_GCC=gcc
      COLLECT_LTO_WRAPPER=/usr/lib64/gcc/x86_64-solus-linux/5.2.0/lto-wrapper
      Target: x86_64-solus-linux
      Configured with: ../gcc-5.2.0/configure --prefix=/usr --with-pkgversion='Solus Project' --libdir=/usr/lib64 --libexecdir=/usr/lib64 --with-s
      ystem-zlib --enable-shared --enable-threads=posix --enable-_cxa_atexit --enable-plugin --disable-gold --enable-ld=default --enable-clocale=
      gnu --enable-multilib --with-multilib-list=m32,m64 --enable-lto --with-bugurl=https://bugs.solus-project.com --with-arch_32=i686 --enable-li
      nker-build-id --build=x86_64-solus-linux --target=x86_64-solus-linux --enable-languages=c,c++,fortran
      Thread model: posix
      gcc version 5.2.0 (Solus Project)
      configure:3158: $? = 0
      configure:3147: gcc -V >&5
      gcc: error: unrecognized command line option '-V'
      gcc: fatal error: no input files
      compilation terminated.
      configure:3158: $? = 1
      configure:3147: gcc -qversion >&5
      gcc: error: unrecognized command line option '-qversion'
      gcc: fatal error: no input files
      compilation terminated.
      configure:3158: $? = 1
      configure:3178: checking whether the C compiler works
      configure:3200: gcc conftest.c >&5
      gcc: error trying to exec 'as': execvp: No such file or directory
      configure:3204: $? = 1
      configure:3242: result: no
      configure: failed program was:
      | /* confdefs.h */
      | #define PACKAGE
      NAME "Epson Inkjet Printer Driver (ESC/P-R) for Linux"
      | #define PACKAGE_TARNAME "epson-inkjet-printer-escpr"
      | #define PACKAGE_VERSION "1.6.2"
      | #define PACKAGE_STRING "Epson Inkjet Printer Driver (ESC/P-R) for Linux 1.6.2"
      | #define PACKAGE_BUGREPORT "Seiko Epson Corporation linux-printer@epson.jp"
      | #define PACKAGE_URL ""
      | #define PACKAGE "epson-inkjet-printer-escpr"
      | #define VERSION "1.6.2"
      1Aide 2SansRLg 3Quitter 4Hex 5Aller à 6 7Rech 8Brut 9Fmter 10Quitter

      • [^] # Re: distrib legere ?

        Posté par . Évalué à 1.

        gcc: error trying to exec 'as': execvp: No such file or directory

        On dirait que les binutils ne sont pas installé, chez moi en faisant
        whereis as
        j'obtient
        as : /usr/bin/as

        et chez toi ?

        • [^] # Re: distrib legere ?

          Posté par . Évalué à 1.

          as:
          et c'est tout

          • [^] # Re: distrib legere ?

            Posté par . Évalué à 1. Dernière modification le 21/01/16 à 21:41.

            Merci! J'ai installé binutils et ça avance, mais j'ai toujours une erreur :
            Manque-t-il encore quelque chose? Mon installation présente-t-elle des incompatibilités???
            Cordialement.

            /home/korrigan/Téléchargements/inkscape-0.91/config.log 1296/35541 3%

            This file contains any messages produced by compilers while running configure, to aid debugging if configure makes a mistake.
            
            It was created by inkscape configure 0.91, which was generated by GNU Autoconf 2.69.  Invocation command line was
            
              $ ./configure
            
            ## --------- ##
            ## Platform. ##
            ## --------- ##
            
            hostname = korrigane
            uname -m = x86_64
            uname -r = 4.3.3
            uname -s = Linux
            uname -v = #1 SMP PREEMPT Tue Jan 19 19:29:23 UTC 2016
            
            /usr/bin/uname -p = unknown
            /bin/uname -X     = unknown
            
            /bin/arch              = unknown
            /usr/bin/arch -k       = unknown
            /usr/convex/getsysinfo = unknown
            /usr/bin/hostinfo      = unknown
            /bin/machine           = unknown
            /usr/bin/oslevel       = unknown
            /bin/universe          = unknown
            
            PATH: /usr/sbin
            PATH: /usr/bin
            PATH: /sbin
            PATH: /bin
            
            
            ## ----------- ##
            ## Core tests. ##
            ## ----------- ##
            
            configure:2990: checking build system type
            configure:3004: result: x86_64-unknown-linux-gnu
            configure:3024: checking host system type
            configure:3037: result: x86_64-unknown-linux-gnu
            configure:3076: checking for a BSD-compatible install
            configure:3144: result: /usr/bin/install -c
            configure:3155: checking whether build environment is sane
            configure:3210: result: yes
            configure:3361: checking for a thread-safe mkdir -p
            configure:3400: result: /bin/mkdir -p
            • [^] # Re: distrib legere ?

              Posté par . Évalué à 1.

              Un petit conseil.. ou deux, déjà résolvons tous les problèmes jusqu'as la fin avant de changer d'activité (c'est plus simple a suivre).

              Au début du poste on était sur la compilation d'un driver pour une espon, et la, de la compilation d'inkscape.

              Ensuite si il y à une erreur elle doit s'afficher dans ton fichier /home/korrigan/Téléchargements/inkscape-0.91/config.log
              mais plutôt vers la fin, pas dans les 3 premier % que tu poste ici.
              Ne pouvant deviner ce qui manque, on ne pourra pas vraiment t'aider, sauf si tu liste les dépendance d'inkscape (que tu doit trouver sur leur site) avec ce qui est installé chez toi.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.