Forum général.général DNS mobiles "foireux" chez SFR et Bouygues ?

Posté par  . Licence CC By‑SA.
Étiquettes :
2
6
juin
2021

Bonjour,
J'ai mis en place chez moi un auto-hébergement, avec nom de domaine, sous domaines, reverse proxy, Let's Encrypt, etc.

Sur mon iPhone, que ce soit depuis SFR ou Bouygues, je ne peux PAS accéder à mes services sans passer par le VPN 1.1.1.1 de Cloud Flare. Le navigateur n'arrive pas à se connecter, la requête n'aboutit jamais.

Ca fonctionne bien sur nickel depuis n'importe quelle box, wifi public, et ça marche même depuis les pays Africains (pour mon boulot), en 4G chez Orange.

Ca vous "parle" ?

Merci

  • # Est-ce vraiment le DNS ?

    Posté par  . Évalué à 5 (+4/-0). Dernière modification le 06/06/21 à 21:56.

    Ça peut aussi être un proxy qui bloque certaines plages d'IP.

    Le navigateur n'arrive pas à se connecter, la requête n'aboutit jamais

    Mais est-ce que la résolution de noms fonctionne ?

    Pour commencer, je testerai en mettant l'IP au lieu du nom, pour savoir si c'est le DNS qui est foireux ou si ce sont les connexions qui sont bloquées.

    J'imagine qu'en faisant un partage de connexion vers un PC depuis ton téléphone, tu peux voir quels serveurs de noms sont utilisés et quelles requêtes fonctionnent. Et surtout avoir des vrais outils d'analyse genre wireshark, ou même ping ;).

    Est-ce que le navigateur affiche la même chose quand tu mets un domaine délibérément bidon et un domaine existant mais injoignable ?

    Les serveurs de noms sont-ils chez toi ? (donc accès aux logs du serveur)

  • # un probleme pas DNS

    Posté par  . Évalué à 3 (+1/-0). Dernière modification le 07/06/21 à 09:02.

    le probleme c'est que tous les routeurs ne permettent pas de sortir de la box pour y re-rentrer (j'ai oublié le nom du truc)

    du coup, quand tu t'auto-héberges, tu ne peux pas joindre tes services par l'IP publique quand tu es chez toi, mais ca marche nickel quand tu es dehors.

    dans ton cas,

    • si tout internet est bloqué, là il faut regarder en effet les DNS, le routage, etc

    • si tout internet fonctionne, mais pas ton autohebergement, ca pourrait etre ca, et en effet tu le solutionnes avec un VPN qui te renvoie totalement à l'extérieur, pour revenir chercher ton service.

    autre méthode pour résoudre cela, faire un DNS interne chez toi, qui va fournir les IPs locales pour les domaines qui sont en auto-hébergement.

    ex :
    sur ton DNS publique :
    tonservice.tondomaine.tld => IP de la box

    sur ton DNS dans la maison
    tonservice.tondomaine.tld => IP du serveur

    • [^] # Re: un probleme pas DNS

      Posté par  . Évalué à 1 (+0/-0).

      du coup, quand tu t'auto-héberges, tu ne peux pas joindre tes services par l'IP publique quand tu es chez toi, mais ca marche nickel quand tu es dehors.

      Si j'ai bien compris, son problème se manifeste depuis le réseau de certains opérateur mobiles.

      • [^] # Re: un probleme pas DNS

        Posté par  . Évalué à 2 (+0/-0).

        ah oui, 👍 j'étais vraiment pas réveillé quand j'ai lu sa question,
        du coup j'ai répondu à coté de la plaque.

  • # News...

    Posté par  . Évalué à 1 (+0/-0).

    Bonjour,
    Désolé pour cette réponse tardive, mais j'étais à l'étranger et ne pouvait faire les tests suggérés. Et comme précisé plus haut, depuis le réseau Orange en Afrique, aucun problème.

    Effectivement, si je fais un partage de connexion sur mon téléphone, et que je fais un "nslookup mondomaine.tld", ça me renvoie bien la bonne IP.

    Si je me connecte avec un navigateur sur "mondomaine.tld", j'ai bien la page par défaut de mon serveur, qui est vide.

    Maintenant si je fais : "nslookup articles.mondomaine.tld", j'obtiens la même IP, jusque là, tout est ok.

    Je me suis amusé à faire "traceroute articles.mondomaine.tld", et là, la requête de perd dans les limbes d'internet, mais j'ai du mal à savoir si ce test est pertinent :

    traceroute to mondomaine.tld (82.64.172.242), 64 hops max, 52 byte packets
     1  172.20.10.1 (172.20.10.1)  113.715 ms  10.716 ms  8.049 ms
     2  * * *
     3  10.4.2.12 (10.4.2.12)  46.673 ms
        10.4.1.12 (10.4.1.12)  50.602 ms
        10.4.0.12 (10.4.0.12)  167.802 ms
     4  172.19.168.252 (172.19.168.252)  46.251 ms  47.702 ms  41.895 ms
     5  181.231.154.77.rev.sfr.net (77.154.231.181)  43.135 ms  161.396 ms  38.916 ms
     6  129.10.136.77.rev.sfr.net (77.136.10.129)  44.782 ms  40.852 ms  47.013 ms
     7  129.10.136.77.rev.sfr.net (77.136.10.129)  63.816 ms  103.784 ms  40.302 ms
     8  38.195.118.80.rev.sfr.net (80.118.195.38)  33.381 ms  34.743 ms  43.266 ms
     9  * * *
    10  * * *
    11  * * *
    12  * * *
    13  * * *
    14  * * *
    15  * * *
    ...
    31  * *^C
    

    La requête a tourné 6 mns avant que je ne l'arrête. Si les navigateurs ont un timeout de 30 , cela semble logique que la requête finisse en impasse. Mais le test n'est pas forcément significatif car, au même moment, connecté depuis un wifi public, j'arrive à me connecter avec Firefox à "articles.mondomaine.tld" alors que le traceroute se perd aussi je ne sais où.

    Bref, je ne comprends pas le problème. Mais comme il ne se produit qu'avec SFR et Bouygues, je me dis qu'il n'est pas forcément de mon côté. Se pourrait-il que ce soit lié à un mix IPv4/IPv6 mal fichu ?

    • [^] # Re: News...

      Posté par  . Évalué à 3 (+1/-0).

      essaie tcptraceroute IP (ou FQDN) port

      exemple tcptraceroute google.com 80

      le traceroute de base utilise le protocole ICMP et ping il me semble
      suffit que certains équipements ne répondent pas au ping pour qu'on ait l'impression que ca se perd.

      • [^] # Re: News...

        Posté par  . Évalué à 1 (+0/-0).

        Merci, ben ça marche. tcptraceroute me renvoie bien la bonne adresse IP. Le problème est donc ailleurs, mais où ?

        • [^] # Re: News...

          Posté par  . Évalué à 1 (+0/-0).

          Si depuis le même réseau mobile, depuis l'iPhone ça ne fonctionne pas, mais que depuis le PC ça fonctionne, oui c'est curieux.

          Se pourrait-il que l'iPhone utilise des paramètres de réseau différents quand tu es en partage de connexion ? Par exemple des serveurs DNS différents, une gateway différente ?

          Je ne sais pas si c'est possible d'afficher les paramètres réseau de l'iPhone, mais comparer avec le PC serait une première étape. Voir déjà avec un site qui affiche ton IP depuis le téléphone et depuis le PC. C'est un peut tiré par les cheveux, mais sait-on jamais ?

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.