Forum général.général Mount, ext3 et ta mère

Posté par .
Tags : aucun
0
7
juil.
2004
Plop,

J'essaie de monter une partoche au format ext3fs avec des droits particuliers mais sans succès.

Qq1 sait-il si c'est possible ?

L'idée c'est de monter une partition /media/phtos dans laquelle tous les utilisateurs appartenant au groupe photos pourrait lire et écrire et après exporter tout ça dans un bon vieux NFS des familles.

On va quand même pas me dire que c'est pas possible ? Si ?

Merci
  • # ben...

    Posté par . Évalué à 3.

    Comment veux tu qu'on te reponde si tu ne nous montre pas ta commande mount et ton exportfs ?
    • [^] # Re: ben...

      Posté par . Évalué à 2.

      Non non non tu n'as pas compris !!

      Ce que je veux faire c'est un équivalent du gid/uid du FAT mais pour le ext3

      En vfat, tu peux ajouter les options gid/uid/umask dans ton fstab pour signaler à mount que le FS doit être monté avec ce gid/uid.

      Je sais que le ext3 ne permet pas ce genre de choses mais je cherche un moyen de contourner le problème.

      Concernant exportfs, je n'ai aucun problème :p

      Voilà, hopte that's help
      • [^] # Re: ben...

        Posté par . Évalué à 2.

        si tu utilisais samba au lieu de nfs , tu aurais les options "force user xxx" et "force group yyy" qui feraient exactement ce que tu demande.
  • # Re: ext3

    Posté par . Évalué à 0.

    Si c'est toujours le même (user ou group) qui écrit sur la partition je ne vois pas où est le problème. Au pire, il faut faire un "chown -R user:group" au début.
    • [^] # Re: ext3

      Posté par . Évalué à 2.

      J'ai l'impression que je me suis mal exprimé.

      Cette partition _doit_ être accessible en _lecture_ *et* _ecriture_ pour une partie des utilisateurs de mon rezal. Ceux qui ont le droit d'accéder et écrire dans ce répertoire sont rassemblés dans un groupe que j'ai appelé "photos".

      Donc sur mon vg j'ai un lv 'lv_photos' sur lequel j'ai créé un FS ext3.

      J'ai créé le répertorie dans /media/photos et j'ai tout de suite changé les droits/owner du _répertoire_ seulement.

      Le problème c'est que si je lance un mount du FS sur /media/répertoire, les permissions sont modifiées et deviennent root:root 755.

      Donc mon idée c'est soit de 1) forcer le montage sous une autre identité 2) jouer de l'ACL 3) simplement créer un répertoire dans ce '/media/photos/' et lui coller les bons droits. Le 3) fonctionne bien mais ce n'est pas l'effet voulu.

      J'esprèe que j'ai été plus claire là :)

      Merci
      • [^] # Re: ext3

        Posté par . Évalué à 1.

        il me semble que ce que tu cherche se trouve dans les options de mount, non ?
        quelquechose comme un gid correspondant au numero du groupe photos, bien placé, suivi d'un umask des familles...
        man mount gros gros ami, puis placer tout ca dans le /etc/fstab
        • [^] # Re: ext3

          Posté par . Évalué à 2.

          Justement non; ext ne supporte pas le uid/gid.

          A ma connaissance seul fat sait gérer ces options. Crois-moi j'aurais pas demandé de l'aide si c'était simplement une question de RTFM :p

          Finalement j'ai trouvé un bon compromis: les ACLs.

          C'est un peu goret mais ça fonctionne et c'est tout ce qui m'interesse pour le moment.
          • [^] # Re: ext3

            Posté par . Évalué à 1.

            arg scuse...
            le but n'etait surtout pas RTFM ;-D ... et c'est vrai que je l'utilise sur une partition NTFS. Pas pensé que ext pouvait deconner avec ca. Bizarre quand meme :-(
      • [^] # Re: ext3

        Posté par . Évalué à 1.

        > Le problème c'est que si je lance un mount du FS sur /media/répertoire, les permissions sont modifiées et deviennent root:root 755.

        Exemple :
        # ll -d boot
        drwxr-xr-x 2 root root 4096 mai 9 00:10 boot
        # ll -d boot/
        drwxr-xr-x 2 root root 4096 mai 9 00:10 boot/
        # mount boot/
        # ll -d boot/
        drwxr-xr-x 5 root root 2048 jun 28 11:27 boot/
        # chown nobody:nobody boot/
        # ll -d boot/
        drwxr-xr-x 5 nobody nobody 2048 jun 28 11:27 boot/
        # umount boot/
        # ll -d boot/
        drwxr-xr-x 2 root root 4096 mai 9 00:10 boot/
        # mount boot/
        # ll -d boot/
        drwxr-xr-x 5 nobody nobody 2048 jun 28 11:27 boot/

        Donc sur ce point précis, je n'ai toujours pas compris le problème.
        • [^] # Re: ext3

          Posté par . Évalué à 2.

          Effectivement.

          Je n'ai pas observé ce comportement chez moi :(

          Quoiqu'il se passe, mon point de montage passe en root/root alors que je fais les mêmes manipulations.

          Quoique, attends je ne l'ai pas fait dans cet ordre.
          • [^] # Re: ext3

            Posté par . Évalué à 1.

            Ce qui me bluffe c'est de ne m'etre jamais posé la question...
            Y'a un truc, comme dirait Boris, qui cloche la-dedans...
  • # P'tetre chmod...

    Posté par (page perso) . Évalué à 1.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.