Forum général.général Ovh, modem en mode bridge et téléphonie

Posté par . Licence CC by-sa.
0
15
juin
2013

Bonsoir,

J'ai récemment souscrit une offre ADSL Pro chez OVH, et j'essaie désespérément de faire fonctionner la téléphonie avec le modem en mode bridge. D'après ce que j'ai vu sur les forums OVH, le mode bridge désactive la téléphonie, j'ai donc essayé de mettre en place la manipulation décrite ici :
http://forum.ovh.com/showthread.php?t=83471

J'ai mis en place la configuration suivante, mais le voyant téléphone reste éteint sur le modem OVH :
[modem ADSL] <-> [mon routeur tp-link] <-> [port wan du modem OVH] <-> téléphone RJ11

Le modèle du modem que j'ai reçu est un Thomson 789vn

Est ce que des personnes chez OVH ont déjà mis en place ce type de configuration avec succès ?

Merci d'avance.

  • # dommage, on est samedi

    Posté par . Évalué à 2.

    si j'ai bien compris, tu connectes un modem adsl au modem OVH via un routeur…

    déjà, vire le routeur , enlève le modem dit "ADSL" et remplace le par le modem OVH!

    cette config devrait mieux fonctionner …

    tant va la cruche à l'eau qu'à la fin elle t'explose en pleine tête

    • [^] # Re: dommage, on est samedi

      Posté par . Évalué à 1.

      Bonjour,

      Non tu n'as pas compris :-) mais je me suis peut être mal exprimé.
      Je ne veux pas utiliser le modem OVH qui est très bof niveau fonctionnalités, je préfère utiliser mon propre routeur OpenWRT. Initialement j'avais la configuration suivante, mais il est impossible de faire fonctionner la téléphonie dans ce mode :

      [routeur OVH en mode bridge] <-> [mon routeur tp-link]
                  |
                  |
           [Téléphone RJ11]
      
      

      C'est pourquoi j'ai cherché un peu et je suis tombé dans les forums OVH sur la configuration décrite dans mon premier post, mais je n'arrive pas à la faire fonctionner.

      • [^] # Re: dommage, on est samedi

        Posté par . Évalué à 1.

        Sur la liste de diff, je crois que Bash avait filé la bonne info. Je ne la garde pas, désolée.

        Pour un sextumvirat ! Zenitram, Tanguy Ortolo, Maclag, xaccrocheur, arnaudus et alenvers présidents !

  • # Problème résolu

    Posté par . Évalué à 3.

    Bon, ça y est j'ai trouvé. Je détaille la solution, si ça peut dépanner quelqu'un. Par contre cette solution nécessite d'avoir un modem ADSL.

    Ma configuration est la suivante :
    [Modem ADSL] <-> [Routeur OpenWRT] <-> [Routeur OVH] <-> [Téléphone RJ11 classique]

    Le routeur OpenWRT attribue des IP sur le segment 192.168.2.0
    Le routeur OVH attribue des IP sur le segment 192.168.1.0. Il est relié au routeur OpenWRT par son interface WAN (port rouge), et il est administrable sur l'IP 192.168.1.254 en connectant un PC sur son switch (un des ports jaunes).
    Le routeur OpenWRT attribue une IP en 192.168.2.X à l'interface WAN du routeur OVH via DHCP.
    Le routeur OVH est configuré de la façon suivante (en telnet, le login par défaut est Administrator sans mot de passe), après un reset complet :

    eth ifadd intf=eth-wan
    eth ifconfig intf=eth-wan dest=ethif5 wan=enabled priotag=disabled
    eth ifattach intf=eth-wan
    ip ifadd intf=ip-wan dest=eth-wan
    nat ifconfig intf=ip-wan translation=enabled
    ip ifattach intf=ip-wan
    dhcp client ifadd intf=ip-wan
    dhcp client ifconfig intf=ip-wan metric=20 dnsmetric=20 broadcast=enabled serverroute=disabled followlabel=disabled
    dhcp client rqoptions add intf=ip-wan option=default-routers
    dhcp client rqoptions add intf=ip-wan option=subnet-mask
    dhcp client rqoptions add intf=ip-wan option=domain-name-servers
    dhcp client ifattach intf=ip-wan
    
    

    Quelques autres commandes utiles :

    • Désactiver le timeout de session telnet :

      env get var=SESSIONTIMEOUT
      env set var=SESSIONTIMEOUT value=0
      
    • Changer le mot de passe du compte Administrator

      user config name=Administrator password=mypassword
      
    • Désactive le système IDS :

      ids config state=disabled
      
    • Désactiver la journalisation des sites web visités

      dsd config state=disabled
      
    • Désactiver le wifi

      wireless radio state=disabled
      

    Une documentation plus complète est disponible ici : http://npr.me.uk/telnet.html

    Voilà, j'espère que mes explications sont suffisamment claires.

    • [^] # Re: Problème résolu

      Posté par . Évalué à 0. Dernière modification le 24/07/13 à 23:58.

      Bonjour,

      Tout d'abord, un grand merci pour ton message et la solution que tu as posté.
      Je suis exactement dans le même cas que toi et j'ai ainsi pu conserver mon propre matériel et n'utiliser ce modem que pour la téléphonie.

      J'ai bien tenté d'utiliser le modem fournit par OVH mais globalement, sa gestion du LAN ne me satisfait pas :
      - il ne voit pas tout le temps les machines pour lesquelles je veux configurer l'IP manuellement.
      - il ne veux bien placer en DMZ que les machines dont l'IP est attribuée en DHCP (pourquoi pas, mais ce n'est pas comme ça que je veux faire).
      - cet après midi, j'ai même eu des pertes régulières de connexion au LAN sur une de mes machines et sans que je comprenne pourquoi, tout est revenu à la normale au bout de quelques dizaines de minutes.

      Ma config est un presque identique à la tienne, mis à par que j'utilise un netgear DG834G qui fait office de modem et de routeur (pour info, j'ai aussi un serveur auto-hébergé que j'ai placé en DMZ sur le netgear). Le modem d'OVH est configuré comme tu le préconise.

      Une seule chose : ce n'est pas indiqué mais une fois les commandes tapées, il ne faut pas oublier de faire "saveall" avant de fermer la connexion telnet avec le modem, sinon les modifs ne sont pas conservées après redémarrage (sont elles mêmes prises en compte tout court sans ça ?) -> je me suis fait avoir au premier essai en tout cas :p .

      Merci encore !!!

      Fred

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.