Forum général.général Sortie de veille non désirée

Posté par (page perso) .
Tags : aucun
0
18
avr.
2009
Bonjour,

depuis hier mon PC portable (Lenovo 3000 N100, environ 2 ans et demi) rencontre des problèmes de sortie de veille non désirée (suspend to ram).

Symptomes :
1) Je le mets en veille, puis à peine entré dans le mode veille il se réveille, sans que j'y ai touché. À partir de là, à chaque fois que je le mets en veille il me refait ce coup là, il tient pas 1 seconde en veille. Je pense qu'il entre quand même bien en mode veille puisque j'entends le HD et le ventillo du CPU se couper, ainsi que la LED « veille » qui s'allume.

2) Je le mets en veille, puis il se réveille tout seul quelques heures plus tard (ça m'est arrivé cette nuit/matin).

J'aimerai donc savoir s'il est possible :
1) de connaître la raison qui réveille le PC ;
2) qu'un logiciel puisse causer d'une manière ou d'une autre le réveil du PC ;
2) qu'un matériel provoque un faux contact et le réveil (apparemment seul le clavier, le bouton power et l'ouverture de l'écran peuvent le sortir de veille).

Une fois bloqué dans le cycle malicieux de la veille/sortie de veille directe, j'ai arrêté la machine, enlevé la batterie, coupé le secteur, puis redémarré :
- j'ai essayé un coup sous windows, ça marchait correctement ;
- sous ubuntu, ça marchait... puis ça ne marchait plus, donc je n'arrive pas à reproduire à 100% le problème.

Autre chose bizarre, lorsqu'il se met à faire des sorties de veilles directes après mise en veille, le fait de me déconnecter (écran de gdm), arrive à le remettre en veille normalement. Et quand j'ai fait les essais sous l'écran de connexion (gdm), je n'ai pour l'instant pas encore réussi à obtenir le problème. C'est pour ça que je demande plus haut si un logiciel pouvait causer la sortie de veille.

Merci.
  • # Indices

    Posté par (page perso) . Évalué à 2.

    Tu indiques que sous Windows ça a l'air de fonctionner correctement. Cela tend à écarter l'hypothèse du problème matériel. Peut-être une mise à jour malvenue.

    Pour en avoir le coeur net, utilise une distribution vive (une proposition de traduction de live-distribution ?) pour tester.
    • [^] # Re: Indices

      Posté par (page perso) . Évalué à 1.

      Je n'ai essayé qu'un coup sous Windows. Sous Linux, ça fonctionne aussi quand je le fais depuis l'écran de connexion, et « un peu » depuis le desktop gnome chargé (c'est-à-dire qu'au bout de quelques tentatives, il va peut-être se mettre à bugger). Donc je ne peux pas encore écarter l'option matérielle.

      Je ne l'ai fait qu'un coup sous Windows et ensuite, je me suis dit que c'était OK, donc reboot. Je me suis apperçu ensuite que le problème ne survenait pas forcément sous Linux (en tous cas, pas forcément dès le début). Et ça me fait chier de retourner sous Windows ;) surtout si je dois tester pendant plusieures heures/jours.

      Ce qui m'intrigue vraiment, c'est pourquoi lorsqu'il se met à dysfonctionner sous le bureau gnome (et à partir de là, il ne fonctionnera plus du tout...), il se remet à fonctionner correctement lorsque je me déconnecte de ma session.
      • [^] # Re: Indices

        Posté par . Évalué à 2.

        Peut-être parce qu'un process lancé par le Gnome fait des accès disque, ce qui empêche a mise en veille.
        Pour trouver le coupable:
        /etc/init.d/klogd stop
        echo 1 > /proc/sys/vm/block_dump


        La seconde ligne permet de voir quel process accède au disque. La première sert à désactiver klogd, pour éviter que l'écriture du buffer sur le disque ne soit lui-même loggé, sinon ça part en boucle.
        Les traces sont visibles avec 'dmesg'.
  • # La souris ?

    Posté par . Évalué à 2.

    As-tu vérifié si la souris n'était pas à même de le sortir de veille, également ?
    • [^] # Re: La souris ?

      Posté par (page perso) . Évalué à 1.

      Non, quand je la bouge ou que je clic, ça ne sort pas la machine de la veille. Ni même le touchpad.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.