Forum général.général Utilisation d'IE6

Posté par .
Tags : aucun
0
2
jan.
2008
Hello tout le monde,
Je souhaiterais utiliser un logiciel Windows sur ma Mandriva 2008.
Ce logiciel nécessite la présence d'Internet Explorer 4.01 ou plus.

J'ai donc installé IE6.

Malheureusement, lors de l'installatlion le logiciel s'arrête et m'indique qu'IE n'est pas installé (j'utilise Wine).

D'après vous, comment faire en sorte qu'IE soit bien identifié dans le système ?

Merci d'avance pour votre aide.
Bonne année à tous.
A+
Peter
  • # Tu as installé IE dans Wine ou ies4linux

    Posté par (page perso) . Évalué à 2.

    dispo à
    http://www.tatanka.com.br/ies4linux/page/Main_Page

    Multitasking — The art of doing twice as much as you should half as well as you could.

    • [^] # Re: Tu as installé IE dans Wine ou ies4linux

      Posté par . Évalué à 1.

      j'ai utilisé ies4linux
      ça peut être la raison ?
      • [^] # Re: Tu as installé IE dans Wine ou ies4linux

        Posté par (page perso) . Évalué à 2.

        Si tu as installé IE avec ies4linux, fais bien attention de définir la variable WINEPREFIX. En effet, ies4linux n'installe pas IE dans le répertoire wine par défaut (~/.wine) mais dans un répertoire que tu peux préciser lors de l'installation (je ne connais pas le répertoire par défaut). Du coup il faut lancer ton programme comme suit :
        WINEPREFIX=/path/vers/ies4linux/ie6 wine tonprogrammequicasselesbonbons.exe

        p'tet j't'ai aidé, p'tet pas
  • # wine

    Posté par . Évalué à 2.

    j'avais une application dans le même cas, après installation d'IE dans wine, cela fonctionnait bien, à mon avis tu as dû manquer qque chose ou bien ton appli est très vicieuse (c'est quoi au fait ?)

    Tu peux essayer cela également :

    http://www.tatanka.com.br/ies4linux/page/Main_Page

    Only wimps use tape backup: real men just upload their important stuff on megaupload, and let the rest of the world ~~mirror~~ link to it

    • [^] # Re: wine

      Posté par . Évalué à 2.

      je me suis peut-être un peu avancé.
      Sur l'application que j'avais (dont il existe maintenant une version linux), je n'utilisait qu'un binaire simple, pas tout l'ide. L'ide a toujours besoin d'IE, et se plaint même si on a wine. Il y a un truc ici, mais cela ne fonctionne pas chez moi :

      http://bugs.winehq.org/show_bug.cgi?id=4796

      sinon tu peux utiliser une image virtuelle de windows avec virtualbox

      Only wimps use tape backup: real men just upload their important stuff on megaupload, and let the rest of the world ~~mirror~~ link to it

      • [^] # Re: wine

        Posté par . Évalué à 1.


        sinon tu peux utiliser une image virtuelle de windows avec virtualbox


        ce qui pressuppose d'avoir une license Windows Valide.
        • [^] # Re: wine

          Posté par (page perso) . Évalué à 1.

          ie6 avec Wine ou par ie4linux nécessite aussi une licence Windows valide...

          \_o<

          • [^] # Re: wine

            Posté par . Évalué à 1.

            ben alors tant qu'a devoir utiliser une license windows autant faire une vrai machine virtuelle windows.

            mais je croyais que l'interet de passer par Wine c'etait justement de ne pas avoir besoin de license windows.

            ca perd tout son interet le truc ie4linux s'il faut une license windows...

            enfin je dis ca, mais j'ai pas essayé non plus.
        • [^] # Re: wine

          Posté par . Évalué à 2.

          bah non, pour les puristes on peut toujours utiliser la version shareware valable 30 jours et la réinstaller à chaque fois... ;)

          Only wimps use tape backup: real men just upload their important stuff on megaupload, and let the rest of the world ~~mirror~~ link to it

          • [^] # Re: wine

            Posté par . Évalué à 1.

            il manque plus qu'un script Xnee pour automatiser le tout ...
    • [^] # Re: wine

      Posté par . Évalué à 1.

      Bon... j'ai essayé ce que vous m'avez proposé sans succès :-(
      Toujours le même msg d'erreur.

      Le soft qui me pose souci est celui-ci:
      http://www.torrentz.com/c6410817cd6149c22a9f5773b9791e063e41(...)

      ou là:
      http://www.cannell.co.uk/944_workshop_Manual/pet6.zip

      Vous avez des idées ???

      Merci d'avance.
      A+
      Pierre
      • [^] # Re: wine

        Posté par . Évalué à 2.

        chez moi avec :
        WINEPREFIX=/home/tonlogin/.ies4linux/ie6 wine tonprogrammequicasselesbonbons.exe

        cela permet d'installer le logiciel et de le faire fonctionner.

        Only wimps use tape backup: real men just upload their important stuff on megaupload, and let the rest of the world ~~mirror~~ link to it

        • [^] # Re: wine

          Posté par . Évalué à 1.

          ça marche avec le soft dont j'ai mis le lien ????
          (pet6)

          je n'y comprends rien :-(
          • [^] # Re: wine

            Posté par . Évalué à 1.

            Je rectifie, ça fonctionne beaucoup mieux, je n'ai plus le message d'erreur au début. J'étais resté en root, désolé...

            Merci de votre aide !
            • [^] # Re: wine

              Posté par . Évalué à 1.

              Bon install nickel, mais au lancement, nouveau message d'erreur.
              Il m'annonce une erreur dans le fichier ETKA_ALL.INI

              farvardin, si tu as installé le soft, as-tu le même message d'erreur ?

              Faut-il modifier les fichiers INI quand on utilise wine ?

              Meci d'avance de votre aide.
              A+
              Pierre
              • [^] # Re: wine

                Posté par . Évalué à 1.

                En fait, je pense qu'il ne trouve pas les fichiers ini.

                J'ai essayé ça:
                WINEPREFIX=/home/monlogin/.ies4linux/ie6/drive_c/PET_PROG wine PET.EXE

                et j'ai ça:
                Warning: the specified Windows directory L"c:\\windows" is not accessible.
                Warning: the specified System directory L"c:\\windows\\system32" is not accessible.Warning: could not find DOS drive for current working directory '/home/monlogin/.ies4linux/ie6/drive_c/PET_PROG', starting in the Windows directory.
                wine: could not load L"c:\\windows\\system32\\PET.EXE": Module not found
                • [^] # Re: wine

                  Posté par . Évalué à 2.

                  non j'ai juste cliqué sur l'icône qui est venu dans le menu. Pour info ce raccourci lance cette commande :

                  env WINEPREFIX="/home/monlogin/.ies4linux/ie6" wine "C:\PET_PROG\w_select.exe"

                  Only wimps use tape backup: real men just upload their important stuff on megaupload, and let the rest of the world ~~mirror~~ link to it

                  • [^] # Re: wine

                    Posté par . Évalué à 1.

                    OK !!!
                    ta méthode fonctionne
                    l'autre solution consiste à déplacer les répertoires PET installés de ie6 vers drive_c

                    Merci ;-)
                    A+

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.