Forum général.hors-sujets [Echec]Config de base APACHE [Post fermé]

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
0
24
nov.
2016

Bonjour à tous,

Je voudrais mettre en place un serveur HTTP Apache pour mon site web.
Pour cela je dispose d'un ordinateur, que je voudrais transformer en serveur.
J'ai donc installé apache 2 sur mon pc puis j'ai crée une page index.html

répertoire du fichier html: le fichier /vat/www/dezert/index.html

Ensuite j'ai configuré les deux fichiers suivants tel quel:

fichier /etc/apache2/sites-avalaible /dezert.conf

<VirtualHost *:80>
DocumentRoot /var/www/dezert/index.html
<Directory /var/www/dezert>
Order allow,deny          
Allow from all                
</Directory>
</VirtualHost>    

fichier etc/network/interfaces

        #iface wlan0 inet static
        #address 192.168.0.12
        #netmask 255.255.255.0
        #broadcast 192.168.0.255
        source /etc/network/interfaces.d/*
        #loopback network interface
        auto lo
        iface lo inet loopback            

Au départ j'avais enlevé les diez, mais je n'avais plus de connections. Alors je les ai remis.
J'ai bien sûr activer le site et les répertoires pour que Apache puisse travailler dessus.

Après redémarrage, connexion au 192.168.000.012 >>> Forbidden
connexion au 192.168.0.12 >> Unable to connect
A ce point je suis perdu
Qui peut m'aider ? Merci.

ma config: Debian + Free

  • # Bonjour

    Posté par  . Évalué à 5.

    Je ne sais pas si ton problème vient de là mais pour la directive DocumentRoot d’Apache il faut indiquer un répertoire, pas un fichier.

  • # Bonjour

    Posté par  . Évalué à 1.

    Bonjour à vous,
    j'ai bien changé le répertoire comme tu m'as dit mais sans succès.
    j'ai regardé aussi les fichiers logs mais ils sont vides (/var/log/apache2/access error other .log)

    • [^] # Re: Bonjour

      Posté par  (site Web personnel) . Évalué à 2.

      C'est pas normal, tu n'arrive même pas sur la machine en question…

      pb de routage / filtrage ?

      Système - Réseau - Sécurité Open Source

      • [^] # Re: Bonjour

        Posté par  . Évalué à 1.

        je sais pas vraiment …

        il y un filtrage mac que j'ai fait moi même sur ma box (free).
        A part ça, j'en sais pas trop plus.

  • # Droits d'accès sur /var/www/dezert

    Posté par  . Évalué à 1.

    L'utilisateur www-data a-t-il bien les droits en lecture sur le répertoire /var/www/dezert ? (et sur index.html)

    Autre idée : as-tu bien fait "a2ensite dezert ; service apache2 reload" après avoir créé ton fichier de configuration ?

  • # a2ensite

    Posté par  . Évalué à 1. Dernière modification le 26/11/16 à 00:13.

    Oui je l'avais fait des le départ avant de poster sur le forum.

    Je l'ai tout de même refait au cas ou, voici le retour:

    a2ensite dezert : service apache2, reload
    site dezertik already enabled
    Failed to reload apache2\x2c.service: Unit apache2\x2c.service not found.
    Il a l'air d'être déjà activé. Mais y'a un tas de services Apache non activé je comprends pas pourquoi.

    • [^] # Re: a2ensite

      Posté par  . Évalué à 1.

      … je vais tout recommencer à zéro je pense

      • [^] # Re: a2ensite

        Posté par  . Évalué à 1.

        Je vais ouvrir un nouveau post
        et repartir sur un Kubuntu au lieu d'un Debian
        Je vous remercie tous grandement pour votre aide. Vraiment.
        Ensemble on y arrivera !!!

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.