Forum Linux.debian/ubuntu Accélération 3D désactivé suite à passage vers Squeeze

Posté par  .
Étiquettes : aucune
0
26
août
2009
Bonjour,


J'ai voulu faire mon kakou en upgradant ma Lenny vers Squeeze (bon en vérité c'était pour lire avec Evolution mes mails du boulot qui sont sur un serveur Exchange 2007). Le dist-upgrade s'est bien passé, mais au moment de tout checker, je me suis rendu compte que l'accélération 3D de la carte graphique n'était plus activée. En gros, voilà ce que ça donne :

# fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (2.1 Mesa 7.0.4)

J'ai donc commencé par vérifier que tout ce qui devait etre installé l'était effectivement (fglrx-source fglrx-kernel-src fglrx-driver fglrx-modules-2.6.30-1-686...) et je me suis lancé dans un m-a a-i fglrx (solution qui avait fonctionné sous Lenny) mais une fois les headers installés, la configuration de fglrx plante avec dans les logs, ceci :

/usr/src/modules/fglrx/firegl_public.c:3227: warning: return makes
pointer from integer without a cast
/usr/src/modules/fglrx/firegl_public.c:3229: warning: return makes
pointer from integer without a cast
/usr/src/modules/fglrx/firegl_public.c: In function 'KAS_Ih_Execute':
/usr/src/modules/fglrx/firegl_public.c:4204: warning: 'return' with no
value, in function returning non-void
make[5]: *** [/usr/src/modules/fglrx/firegl_public.o] Erreur 1
make[4]: *** [_module_/usr/src/modules/fglrx] Erreur 2
make[3]: *** [sub-make] Erreur 2
make[2]: *** [all] Erreur 2
make[2]: quittant le répertoire « /usr/src/linux-headers-2.6.30-1-686 »
make[1]: *** [build] Erreur 2
make[1]: quittant le répertoire « /usr/src/modules/fglrx »
make: *** [kdist_image] Erreur 2

J'ai essayé aussi de mettre une section "DRI" dans le xorg.conf mais rien n'y fait, les fglrxinfo me retourne toujours la même chose.

J'utilise massivement GoogleEarth en ce moment et ceux qui l'utilisent aussi doivent savoir que sans accélération 3D, c'est une horreur, donc j'ai vraiment besoin d'une solution, sinon je vais devoir revenir à Lenny... avec une réinstallation from scratch à la clé. Merci pour votre aide.

--
Rénald
  • # google et le BTS Debian sont tes amis :-)

    Posté par  . Évalué à 6.

    En cherchant le message d'erreur de la construction du module, on tombe sur :
    http://bugs.debian.org/543529
    qui a été fusionné avec http://bugs.debian.org/542140

    Ce dernier bug fournit une version à jour pour squeeze (le temps que la correction migre de unstable vers testing).

    D'une manière générale, la source d'information est le système de suivi des bugs, pour le paquet fglrx: http://bugs.debian.org/cgi-bin/pkgreport.cgi?src=fglrx-drive(...)
    • [^] # Re: google et le BTS Debian sont tes amis :-)

      Posté par  . Évalué à 1.

      Au moins ça fait plaisir de voir que je suis pas le seul avec ce problème, mais aucune solution n'est encore donnée. J'ai essayé en démarrant sur le noyau 2.6.26, et cette fois le m-a a-i fglrx se déroule bien, mais fglrxinfo me retourne toujours le même résultat. Donc je crois que je vais retourner sur Lenny et attendre que Squeeze soit un peu plus mur.

      Rien ne sert de secouer le cocotier, la noix tombera quand elle sera mure. Il suffit d'attendre... mais pas dessous. (proverbe tahitien).


      --
      Rénald

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.