Forum Linux.debian/ubuntu activation de proftpd sur mon serveur gandi.

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
1
27
avr.
2020

bonjour à tous
je suis très enchanté de faire partir de ce forum.
je débute dans l'utilisation de linux et franchement je pense deja que je m'en passerai plus.
j'ai pu télécharger puis installer le paquet proftpd sur mon serveur.le problème est qu'après réinitialisation du proftpd.service un message me notifie que mon proftpd n'est pas activé. comment résoudre ce problème?
merci pour les contributions.

  • # suivant la distribution

    Posté par  . Évalué à 2.

    sur les distributions modernes, c'est systemd qui gere cela, et c'est la commande
    systemctl enable proftpd qui va gérer cela

    tu verifies l'activation ou gères le démarrage, l'arrêt avec
    systemctl status proftpd

    systemctl start proftpd
    systemctl stop proftpd

    etc

    • [^] # Re: suivant la distribution

      Posté par  . Évalué à 1.

      j'ai essayer ce que vous me proposez comme solution mais voilà ce que sa m'affiche
      root@fasosurvey:~# systemctl enable proftpd
      proftpd.service is not a native service, redirecting to systemd-sysv-install
      Executing /lib/systemd/systemd-sysv-install enable proftpd
      perl: warning: Setting locale failed.
      perl: warning: Please check that your locale settings:
      LANGUAGE = (unset),
      LC_ALL = (unset),
      LANG = "en_US.UTF-8"
      are supported and installed on your system.
      perl: warning: Falling back to the standard locale ("C").
      perl: warning: Setting locale failed.
      perl: warning: Please check that your locale settings:
      LANGUAGE = (unset),
      LC_ALL = (unset),
      LANG = "en_US.UTF-8"
      are supported and installed on your system.
      perl: warning: Falling back to the standard locale ("C").
      root@fasosurvey:~# /lib/systemd/systemd-sysv-install enable proftpd
      perl: warning: Setting locale failed.
      perl: warning: Please check that your locale settings:
      LANGUAGE = (unset),
      LC_ALL = (unset),
      LANG = "en_US.UTF-8"
      are supported and installed on your system.
      perl: warning: Falling back to the standard locale ("C").
      perl: warning: Setting locale failed.
      perl: warning: Please check that your locale settings:
      LANGUAGE = (unset),
      LC_ALL = (unset),
      LANG = "en_US.UTF-8"
      are supported and installed on your system.
      perl: warning: Falling back to the standard locale ("C").

      • [^] # Re: suivant la distribution

        Posté par  . Évalué à 3.

        root@fasosurvey:~# systemctl enable proftpd
        proftpd.service is not a native service, redirecting to systemd-sysv-install

        Executing /lib/systemd/systemd-sysv-install enable proftpd
        perl: warning: Setting locale failed.
        perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "en_US.UTF-8"
        are supported and installed on your system.
        perl: warning: Falling back to the standard locale ("C").
        perl: warning: Setting locale failed.
        perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "en_US.UTF-8"
        are supported and installed on your system.
        perl: warning: Falling back to the standard locale ("C").

        probleme de locale, c'est pas bloquant
        que dit la commande systemctl status proftpd

        • [^] # Re: suivant la distribution

          Posté par  . Évalué à 2.

          C'est pas bloquant, mais c'est signe de mauvaise installation du serveur… il y a peut-être eu d'autres problèmes non visibles ici!

          ⚓ À g'Auch TOUTE! http://afdgauch.online.fr

        • [^] # Re: suivant la distribution

          Posté par  . Évalué à 1. Dernière modification le 27/04/20 à 17:30.

          voici ce qu'elle affiche

          root@fasosurvey:~# systemctl status proftpd
          ● proftpd.service - LSB: Starts ProFTPD daemon
             Loaded: loaded (/etc/init.d/proftpd; bad; vendor preset: enabled)
             Active: failed (Result: exit-code) since Mon 2020-04-27 13:45:34 CEST; 3h 12m
               Docs: man:systemd-sysv-generator(8)
          
          Apr 27 13:45:34 fasosurvey proftpd[1929]:  * Starting ftp server proftpd
          Apr 27 13:45:34 fasosurvey proftpd[1929]: 2020-04-27 13:45:34,079 fasosurvey pro
          Apr 27 13:45:34 fasosurvey proftpd[1929]: 2020-04-27 13:45:34,090 fasosurvey pro
          Apr 27 13:45:34 fasosurvey proftpd[1929]: 2020-04-27 13:45:34,090 fasosurvey pro
          Apr 27 13:45:34 fasosurvey proftpd[1929]: 2020-04-27 13:45:34,091 fasosurvey pro
          Apr 27 13:45:34 fasosurvey proftpd[1929]:    ...fail!
          Apr 27 13:45:34 fasosurvey systemd[1]: proftpd.service: Control process exited,
          Apr 27 13:45:34 fasosurvey systemd[1]: Failed to start LSB: Starts ProFTPD daemo
          Apr 27 13:45:34 fasosurvey systemd[1]: proftpd.service: Unit entered failed stat
          Apr 27 13:45:34 fasosurvey systemd[1]: proftpd.service: Failed with result 'exit
          • [^] # Re: suivant la distribution

            Posté par  . Évalué à 1.

            Salut,

            Toi aussi tu as le clavier qui se blo

            C'est un problème pénible car on voit jamais la f

            Essaye peut-être un systemctl status proftpd | less

            Ou de farfouiller dans les logs ;)

            Bon, sinon oui, ton proftpd ne se lance pas. Mais là, sans les bouts de fin de ligne…

            Matricule 23415

          • [^] # Re: suivant la distribution

            Posté par  . Évalué à 2.

            quelle distribution utilises-tu ?

            suivant la distribution, il vaut mieux télécharger/installer via le gestionnaire de paquet,
            et parfois ca pose des questions avant le premier lancement

            • [^] # Re: suivant la distribution

              Posté par  . Évalué à 1.

              je suis sur windows mais je me sert de putty comme interface.
              la version de l'éditeur que j'utilise est GNU nano 2.5.3
              de plus j'ai tentai de le désinstaller mais ce n'est pas possible à mon niveau.
              en définitive je pense qu'il va falloir que j'approfondisse considérablement mes connaissances sur la prise en main de LINUX.
              je galère vraiment et sa me met dans un tel état

              • [^] # Re: suivant la distribution

                Posté par  . Évalué à 2.

                Salut,

                je suis sur windows mais je me sert de putty comme interface.

                C'est pas ça que te demandais NeoX :)

                Sur ton serveur, c'est quoi d'installé ?

                ce n'est pas possible à mon niveau.

                Tu sais, et je crois que personne ne me contredira contre cette affirmation, ici, on a tous commencé au level 0.

                Que ce soit windows ou linux (et les petits copains comme bsd ;) ), d'ailleurs.

                Donc ce n'est pas très grave de se sentir un peu perdu, surtout au début.

                On ne va pas te jeter un caillou parce qu'au début c'est difficile.

                Nan. On te tend la main pour que tu puisse faire pareil plus tard, quand on sera nous grabataires et que la mémoire aura fait sa RAZ :p

                Matricule 23415

                • [^] # Re: suivant la distribution

                  Posté par  . Évalué à 1.

                  merci sa me fait deja du bien

                  • [^] # Re: suivant la distribution

                    Posté par  . Évalué à 1. Dernière modification le 27/04/20 à 18:47.

                    Salut,

                    Alors par contre attention, il y a ce qu'on appelle des grammar-nazi ici (j'en fais partie, même si des "fôtes", j'en fais joyeusement à la pelle), mais confondre sa et ça… j'en connais à qui ça arrive, mais pour des raisons assez spécifiques :)

                    Je dis juste ça comme ça. Je dis (presque) rien. :)

                    Donc, la question était et reste : c'est quoi le système d'exploitation sur ton serveur ?

                    Edith : lu que tu avais répondu ;)

                    Matricule 23415

                    • [^] # Re: suivant la distribution

                      Posté par  . Évalué à 1.

                      bien reçu!!

                      • [^] # Re: suivant la distribution

                        Posté par  . Évalué à 1.

                        Salut,

                        Pas de problème, c'était juste pour te donner un petit conseil ;)

                        On a des quelques "codes", que tu pourra apprendre au fur et à mesure, en parallèle de l'exploration d'un système d'exploitation :)

                        Le clavier qui se blo

                        est très classique, par exemple.

                        Tu peux trouver (le cadavre de Pierre) quelques autres exemples dans la section Folklore local.

                        Oui, oui, on aime bien s'amuser aussi, surtout quand on est blo

                        Matricule 23415

            • [^] # Re: suivant la distribution

              Posté par  . Évalué à 1.

              sur mon serveur c'est ubuntu qui est utilisé

              • [^] # Re: suivant la distribution

                Posté par  . Évalué à 3.

                ubuntu, donc desinstalles ton proftpd que tu as 'telechargé'

                puis installes le simplement avec
                apt update
                apt install proftpd

                ca va te demander si tu veux un usage standalone ou inetd, choisis standalone.

                ca doit faire ce qu'il faut.

      • [^] # Re: suivant la distribution

        Posté par  . Évalué à 1. Dernière modification le 27/04/20 à 15:06.

        Salut,

        Bah tout ça c'est juste des warnings, donc rien de grave…

        Il répond sur quelle IP ton serveur ?

        Grilled by NeoX :)

        Matricule 23415

Suivre le flux des commentaires

Note : les commentaires appartiennent à celles et ceux qui les ont postés. Nous n’en sommes pas responsables.