Forum Linux.debian/ubuntu Changement de carte Wifi, ne détecte pas la nouvelle carte

Posté par  (site Web personnel) . Licence CC By‑SA.
Étiquettes :
5
15
mai
2021

Bonjour

J’ai besoin d’une petite aide SVP.

Sur mon PC portable j’avais la carte wifi : Intel® Wirless-AC 9560 160MHz

Elle avait un dysfonctionnement, j’ai donc fais changer ma carte Wifi chez LDLC.

Et ils m’ont posé elle à la place : Intel® Wi-Fi 6 AX201 160MHz

(je leur avait pourtant bien précisé que je voulais exacte la même carte Wifi… Dans le bon de commande qu’ils m’avaient fait payé en avance, c’était aussi écris "Intel Wirless-AC 9560"…)

Le problème c’est que mon Ubuntu ne détecte pas du tout cette carte Wifi… (Windows 10 qui est en dual-bool lui la détecte bien).

Ici : https://www.intel.com/content/www/us/en/support/articles/000005511/wireless.html

j’ai pourtant bien téléchargé ces drivers : wlwifi-Qu-48.13675109.0.tgz

Je les ai mis ici : /lib/firmware

puis reboot.

Mais rien à faire…

Et cette commande : dmesg | grep iwlwifi

Me retourne rien du tout.

Mon OS exacte : Kubuntu 20.04.2 LTS

J’ai aussi essayé avec un live USB cette OS : Kubuntu 21.04

ça ne change rien (cette carte Wifi n’est toujours pas détectée…).

Une idée SVP ?

Merci d’avance.

  • # drivers chargés ?

    Posté par  . Évalué à 2 (+0/-0).

    La commande lsmod | grep iw donne-t-elle quelque chose (le iw doit attraper les drivers wifi intel sauf erreur) ?

    Sinon pour investiguer coté matériel hwinfo --network ce qui permet de voir le matériel détecté et aussi les drivers utilisés dans ce cas.

    hwinfo --network
    32: None 00.0: 10701 Ethernet                                   
      [Created at net.126]
      Unique ID: Mqes...
      Parent ID: hAO_...
      SysFS ID: /class/net/wlp3s0
      SysFS Device Link: /devices/pci0000:00/0000:00:1c.3/0000:03:00.0
      Hardware Class: network interface
      Model: "Ethernet network interface"
      Driver: "ath9k"
      Driver Modules: "ath9k", "ath9k
      Device File: wlp3s0
      HW Address: xxxx
      Permanent HW Address: xxxx
      Link detected: no
      Config Status: cfg=new, avail=yes, need=no, active=unknown
      Attached to: #1 (Ethernet controller)
    
    
    • [^] # Re: drivers chargés ?

      Posté par  (site Web personnel) . Évalué à 1 (+0/-0).

      lsmod | grep iw

      iwlwifi 331776 0
      cfg80211 704512 2 iwlwifi

      hwinfo --network

      21: None 00.0: 10700 Loopback

      [Created at net.126]
      Unique ID: ZsBS.GQNx7L4uPNA
      SysFS ID: /class/net/lo
      Hardware Class: network interface
      Model: "Loopback network interface"
      Device File: lo
      Link detected: yes
      Config Status: cfg=new, avail=yes, need=no, active=unknown

      • [^] # Re: drivers chargés ?

        Posté par  . Évalué à 3 (+1/-0).

        Elle ne semble carrément pas détectée sous Linux.
        Vu la version des drivers que tu as choisi, tu es bien avec un noyau 5.2.x ?

        Je suppose que lspci (probablement redondant avec hwinfo) ne te sors pas non plus l'info de ta carte.

        En cherchant un peu, il semble y avoir des problèmes récurrents avec les dualboots sous windows avc fastboot d'activé et les cartes wifi :

        https://askubuntu.com/questions/1083369/ubuntu-18-04-cannot-recognized-intel-wireless-ac-9260

        cf réponse validée du post.

        It is a problem with fast startup mode of Windows. I think because in that mode, Windows keeps the wireless adapter for itself when shut down. hence Linux cannot detect it.

        Est-ce le cas chez toi ?

        • [^] # Re: drivers chargés ?

          Posté par  . Évalué à 2 (+0/-0). Dernière modification le 16/05/21 à 12:46.

          suffirait de désactiver le fastboot de windows (y a plein de toto sur internet)
          puis s'arrêter windows (au lieu de rebooter) puis de démarrer le linux.

          verifier aussi s'il y a un bouton physique sur l'ordi pour couper le wifi, et qu'il faudrait rallumer au démarrage du linux.

        • [^] # Re: drivers chargés ?

          Posté par  (site Web personnel) . Évalué à 1 (+0/-0).

          J'ai le Kernel 5.4

          • [^] # Re: drivers chargés ?

            Posté par  . Évalué à 2 (+0/-0). Dernière modification le 16/05/21 à 16:56.

            Peut être compiler les drivers spécifiquement avec ce noyau alors ou booter sur un noyau 5.2 pour coller avec la version compilée par intel que tu as téléchargé ?

          • [^] # Re: drivers chargés ?

            Posté par  (site Web personnel) . Évalué à 2 (+1/-0).

            J'ai eu un problème similaire au changement de carte wifi sur mon portable, en passant à une carte wifi6 Intel, elle n'était pas reconnue. C'est sur u18.04, mais peut être que c'est le même soucis en 20.04 : j'ai installé le paquet "backport-iwlwifi-dkms" et la carte a été reconnue.

  • # Quel format

    Posté par  (site Web personnel) . Évalué à 2 (+0/-0).

    Ta carte WiFi se présente avec quelle connectique ?

    Python 3 - Apprendre à programmer dans l'écosystème Python → https://www.dunod.com/EAN/9782100809141

  • # Commentaire supprimé

    Posté par  . Évalué à 1 (+0/-0). Dernière modification le 18/05/21 à 11:09.

    Ce commentaire a été supprimé par l’équipe de modération.

  • # Commentaire supprimé

    Posté par  . Évalué à 0 (+0/-1). Dernière modification le 03/06/21 à 14:05.

    Ce commentaire a été supprimé par l’équipe de modération.

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.