Forum Linux.debian/ubuntu Comment tester sa carte graphique

Posté par . Licence CC by-sa.
Tags : aucun
0
21
avr.
2019

Bonjour,

Comment puis-je vérifier que ma carte graphique fonctionne bien ?

Informations :

Mes deux écrans sont branché sur ma carte graphique, un en HDMI et l'autre en DVI.

  • HardWare
    • Carte mère : Asus TUF Z390-PLUS GAMING WIFI
    • CPU : Intel Core i7 9700K (3.6 GHz)
    • GPU : Asus ROG STRIX-GTX1080-8G-GAMING Nvidia GeForce GTX 1080, 1771 MHz, 8GB GDDR5X 256 bit, DirectCU III
    • RAM : Corsair Vengeance LPX 16Go (2x8Go) DDR4 3000MHz C15 XMP 2.0
    • Disque system : Intel SSD 760P Series, 256 Go, M.2 (Type 2280)
  • SoftWare
    • cat /etc/linuxmint/info
    • RELEASE=19
    • CODENAME=tara
    • EDITION="MATE"
    • DESCRIPTION="Linux Mint 19 Tara"
    • DESKTOP=Gnome
    • TOOLKIT=GTK
  • # Mais encore ...

    Posté par . Évalué à 5 (+4/-0).

    Qu'est-ce qui te fait croire à un problème ? D'où viennent tes soupçons ?

  • # trop vague

    Posté par . Évalué à 6 (+4/-0).

    Qu'est-ce que tu entends par « fonctionne bien » ?
    Le fait que quand tu la branches elle soit détectée et affichée dans dmesg ou Xorg.log ou que quand tu branches un écran dessus il soit reconnu dans les paramètres d'affichage (de Gnome ou de nvidia-settings) est déjà un début.
    Sinon lancer des benchmarks, des jeux ou divers rendus GPGPU, te donnera une idée des performances ou de la stabilité (électronique et logicielle). J'irais regarder du côté de la Phoronix Test Suite qui permet facilement d'installer et comparer différents tests.

  • # Précisions

    Posté par . Évalué à 6 (+4/-0).

    Plutôt que de nous donner la marque des ventilateurs de ton boîtier, tu pourrais préciser où tu branches ton écran : sur la carte mère ou sur la carte graphique ?

    Si c'est sur la carte graphique, elle a l'air de bien marcher, surtout si tu as la bonne résolution de ton écran. Et si tu veux plus de détails, les benchmark comme cités dans un autre commentaire t'aideront à vérifier que l'accélération 3D est bien correctement prise en compte.

    Sinon tu as aussi la commande glxinfo qui est très complète, mais assez ardue à lire et interpréter.

    En théorie, la théorie et la pratique c'est pareil. En pratique c'est pas vrai.

  • # Quelques précisions

    Posté par . Évalué à 1 (+0/-0). Dernière modification le 22/04/19 à 10:59.

    Merci pour toutes vos réponses !

    alors dans l'ordre :

    @cyberjunkie, mes soupçons viennent :

    • Borderland 2 à de gros problème d'affichage de la 3D
    • DeadCells à des décalage entre la partie haute et basse de l'écran
    • au démarrage un de mes écrans est noir, il faut que je revalide ma configuration d'affichage sans rien modifier pour que l'affichage refonctionne
    • si je fait une MAJ global (apt-get update && apt-get upgrade) ou si MAJ le pilote de la carte graphique via l'outil de Linux Mint ou en exécutant le pilote fournie sur le site de NVIDIA j'ai une faible résolution sur 1 seul écran sans possibilités de faire de configuration d'affichage.

    @xev, je vais aller regarder du côté de la Phoronix Test Suite .

    @gUI, effectivement j'ai fait un simple copier coller d'une note sur ma configuration…
    Je vais éditer ça!
    Mes deux écrans sont connecter sur ma carte graphique en DVI et en HDMI.
    Merci pour la commande glxinfo.

  • # Quelques commandes

    Posté par . Évalué à 1 (+0/-0). Dernière modification le 22/04/19 à 11:34.

    Je viens de lancer quelques commandes :

    $ glxinfo | grep rendering
    direct rendering: Yes

    Donc l'accélération graphique est activé.

    Mais avec glxgears pour avoir une première idées :

    • mon GPU (GeForce GTX 1080) : 17331 frames in 5.0 seconds = 3466.033 FPS
    • trouver sur un site (j'ai pas trouver mon model) : Nvidia GeForce GTX 1050 Ti 126726 frames 25345.195 FPS

    J'aurais du être au moins aussi performant non ?

    • [^] # Re: Quelques commandes

      Posté par . Évalué à 2 (+0/-0).

      J'aurais du être au moins aussi performant non ?

      Pas forcément, le test en lui-même est très synthétique (à ce niveau de fps ça ne veut plus rien dire) et des facteurs extérieurs peuvent très bien affecter les résultats (RAM, SSD, CPU, PCIe, etc.).

      Mais vu les glitches et les résultats que tu as, je me demande si ta carte ne tourne qu'à sa fréquence de base comme si tu n'avais que le pilote libre nouveau et pas celui propriétaire. Et j'ai l'impression que le fait que le direct rendering soit actif confirme cela vu qu'à ma connaissance le pilote propriétaire nvidia ne gère toujours pas le Direct Rendering Manager.

      • [^] # Re: Quelques commandes

        Posté par . Évalué à 1 (+0/-0).

        Ok, mais je ne peux pas mettre le pilote à jour : j'ai l'impression que le carte graphique n'est plus prise en compte après !

        Je ne sais pas quoi faire !

        Tester différentes versions du pilote jusqu'a en trouver une qui marche ? :s

        • [^] # Re: Quelques commandes

          Posté par . Évalué à 2 (+0/-0).

          Ok, mais je ne peux pas mettre le pilote à jour : j'ai l'impression que le carte graphique n'est plus prise en compte après !

          Hmm… je pense que tu n'as pas compris. Si tu as bien installé le pilote propriétaire nommé nvidia, il ne semble pas correctement configuré.
          Lance nvidia-settings avec les droits admin. Si le programme est introuvable ou affiche une erreur, c'est que ton Linux n'utilise pas le pilote propriétaire mais le pilote libre très limité en performances.

          Les GPU Pascal et Maxwell sont encore pris en charge par le pilote propriétaire, aucun problème pour le moment.
          Vérifie aussi si dans etc/X11/xorg.conf ta carte graphique est configurée pour utiliser le pilote nommé nvidia et pas le pilote nommé Nouveau. Si le fichier est vide, c'est certainement ce dernier qui est utilisé par défaut et il te faudra éditer ce fichier de configuration.

          • [^] # Re: Quelques commandes

            Posté par . Évalué à 1 (+0/-0).

            En fait après avoir tenter de mettre à jour le pilote vu que ça fonctionnait moins bien j'ai fait une restauration avec Timeshift.

            Je le réinstalle ^

          • [^] # Re: Quelques commandes

            Posté par . Évalué à 1 (+0/-0).

            Je ne parviens plus à installer le pilote NVIDIA (même après redémarage).

            voici le log :

            nvidia-installer log file '/var/log/nvidia-installer.log'
            creation time: Mon Apr 22 14:46:24 2019
            installer version: 418.43
            
            PATH: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/snap/bin
            
            nvidia-installer command line:
                ./nvidia-installer
            
            Unable to load: nvidia-installer ncurses v6 user interface
            
            Using: nvidia-installer ncurses user interface
            -> Detected 8 CPUs online; setting concurrency level to 8.
            -> Installing NVIDIA driver version 418.43.
            -> Running distribution scripts
               executing: '/usr/lib/nvidia/pre-install'...
            -> done.
            -> The distribution-provided pre-install script failed!  Are you sure you want to continue? (Answer: Continue installation)
            ERROR: The Nouveau kernel driver is currently in use by your system.  This driver is incompatible with the NVIDIA driver, and must be disabled before proceeding.  Please consult the NVIDIA driver README and your Linux distribution's documentation for details on how to correctly disable the Nouveau kernel driver.
            WARNING: One or more modprobe configuration files to disable Nouveau are already present at: /etc/modprobe.d/nvidia-installer-disable-nouveau.conf.  Please be sure you have rebooted your system since these files were written.  If you have rebooted, then Nouveau may be enabled for other reasons, such as being included in the system initial ramdisk or in your X configuration file.  Please consult the NVIDIA driver README and your Linux distribution's documentation for details on how to correctly disable the Nouveau kernel driver.
            ERROR: Installation has failed.  Please see the file '/var/log/nvidia-installer.log' for details.  You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.
            
            • [^] # Re: Quelques commandes

              Posté par . Évalué à 2 (+0/-0).

              Si tu lis

              ERROR: The Nouveau kernel driver is currently in use by your system. This driver is incompatible with the NVIDIA driver, and must be disabled before proceeding. Please consult the NVIDIA driver README and your Linux distribution's documentation for details on how to correctly disable the Nouveau kernel driver.

              C'est que tu as toujours une session graphique d'ouverte. Ouvre un tty, arrête le serveur X et relance ton installation depuis un tty.

              T'es passé par ton gestionnaire de paquets habituel ou tu as utilisé l'installeur officiel du site de Nvidia ?

              • [^] # Re: Quelques commandes

                Posté par . Évalué à 1 (+0/-0).

                J'ai utilisé l'installeur officiel du site de Nvidia.

                J'ai fait service lightdm stop pour couper mon server x, ce n'est pas bon ?

                Parce que j'ai toujours les mêmes logs.

                Encore merci pour ton aide !

                • [^] # Re: Quelques commandes

                  Posté par (page perso) . Évalué à 4 (+2/-0).

                  Tu devrais utiliser les paquets de ta distribution, c'est quand même fait pour!

                  ⚓ À g'Auch TOUTE! http://afdgauch.online.fr

                • [^] # Re: Quelques commandes

                  Posté par . Évalué à 2 (+1/-0).

                  Selon comment tu es arrivé sur Mint 19, par upgrade d'une version 18 ou installation fraîche de la 19, il se peut que ton système utilise MDM plutôt que LightDM.

                  Un petit coup de systemctl list-units --type=service | grep dm.service devrait te renseigner.

                  Puis CTRL-ALT-F1 pour basculer en mode console et là sudo service lightdm (ou mdm) stop pour tuer ton display manager.

                  Ensuite tu fais ton truc avec le driver proprio nVidia.

                  Mais perso, je préférerai installer le driver Nouveau via le gestionnaire de drivers de Mint, histoire de virer le driver nVidia que tu utilises actuellement, puis reboot, puis install du driver propriétaire nVidia via le gestionnaire de drivers puis reboot.

                  Ça fait assez Windows-like comme procédure mais ça devrait faire le boulot.

                  • [^] # Re: Quelques commandes

                    Posté par . Évalué à 1 (+0/-0).

                    J'ai fait une installation fraîche de la 19.

                    systemctl list-units --type=service | grep dm.service
                    lightdm.service        loaded active running Light Display Manager
                    

                    merci pour les infos je test ça

                  • [^] # Re: Quelques commandes

                    Posté par . Évalué à 1 (+0/-0).

                    Alors en fait je suis déjà sur le driver nouveau par défaut.

                    Lorsque j'ouvre le gestionnaire de pilote Mint j'ai un erreur non bloquante :

                    E:Repository 'http://ppa.launchpad.net/webupd8team/java/ubuntu bionic InRelease' changed its 'Label' value from 'Oracle Java (JDK) 8 Installer PPA' to 'Oracle Java (JDK) 8 Installer PPA (DISCONTINUED)'
                    

                    je viens d'installer le driver recommander :
                    * je n'ai plus qu'un écran qui fonctionne
                    * je n'ai plus de configuration d'affichage
                    * redshift ne fonctionne plus

                    Quelqu'un à une idée (j'ai un point de sauvegarde timeshift au cas où)

                    • [^] # Re: Quelques commandes

                      Posté par . Évalué à 2 (+0/-0).

                      Déjà, pour quelles raisons tu as installé ce dépot tiers ? et pourquoi avoir la version Oracle de Java ? OpenJDK fait bien souvent le job et est installable directement depuis les dépots officiels de ta distribution.

                      Ensuite, c'est normal que les paramètres de configuration de ton environnement de bureau ne fonctionnent pas avec le pilote propriétaire nvidia. Pour accéder à ceux-ci, il faut utiliser nvidia-settings qui habituellement est installé directement avec ce pilote. Si tu ne le trouve pas dans le menu des applications, ouvre le programme via un terminal (avec les droits d'administration sinon ça fonctionnera pas).

                      Pour Redshift, je ne sais pas. Pareil, ouvre-le dans un terminal ou regarde les logs pour obtenir des informations sur ce qui cloche.

                      • [^] # Re: Quelques commandes

                        Posté par . Évalué à 1 (+0/-0).

                        Je ne me souviens pas avoir installer un dépôt tiers…

                        Pour Redshift c'est pas grave, au pire je m'en passe

                        Je n'ai que deux menu dans nvidia-settings

                        Application Profiles
                        nvidia-settings Configuration, avec
                        * Display Status Bar
                        * Slider Text Entries
                        * Include x Display Name in the config File
                        * Show "Really Quit?" dialog
                        * Update Rules an Application Profile Name Changes

                        Avec ça je ne parviens pas à récupérer mon deuxième ou une meilleur résolution…

                        Lorsque je lance nvidia-settings je viens de voire que j'ai ça dans le terminal :

                        ERROR: NVIDIA driver is not loaded
                        
                        
                        ERROR: Error querying enabled displays on GPU 0 (Missing Extension).
                        
                        
                        ERROR: Error querying connected displays on GPU 0 (Missing Extension).
                        
                        ** Message: 21:19:13.818: PRIME: No offloading required. Abort
                        ** Message: 21:19:13.818: PRIME: is it supported? no
                        
                        
                        • [^] # Re: Quelques commandes

                          Posté par . Évalué à 2 (+0/-0).

                          OK apparemment ce dépôt tiers est inclus dans Mint et les conditions d'utilisation de Oracle Java ont changé (il faut maintenant se logger sur le site d'Oracle pour l'utiliser) donc le mainteneur l'a désactivé.

                          Si Nouveau tourne toujours après redémarrage, je pense que la configuration de Xorg est la seule solution qui reste pour forcer l'utilisation du pilote propriétaire nvidia. C'est quand même étrange que Mint ne fasse pas ce boulot automatiquement.

            • [^] # Re: Quelques commandes

              Posté par . Évalué à 3 (+1/-0).

              Tout est ecrit il faut lire

              ERROR: The Nouveau kernel driver is currently in use by your system. This driver is incompatible with the NVIDIA driver, and must be disabled before proceeding.

              il est detecté le driver appelé "nouveau" qui gere les cartes nvidia par defaut sous linux

              Please consult the NVIDIA driver README and your Linux distribution's documentation for details on how to correctly disable the Nouveau kernel driver.

              il faut aller lire la documentatation de la distribution sur comment desactiver le pilote nouveau pour permettre l'usage du pilote nvidia

              WARNING: One or more modprobe configuration files to disable Nouveau are already present at: /etc/modprobe.d/nvidia-installer-disable-nouveau.conf. Please be sure you have rebooted your system since these files were written. If you have rebooted, then Nouveau may be enabled for other reasons, such as being included in the system initial ramdisk or in your X configuration file.

              normalement le pilote nouveau est deja interdit d'utilisation lors du demarrage,
              mais il semble chargé ailleurs dans la config

              Please consult the NVIDIA driver README and your Linux distribution's documentation for details on how to correctly disable the Nouveau kernel driver.

              Consulter le manuel de votre distribution linux pour savoir comment desactiver completement ce pilote.

              donc comme ca au pif, et comme c'est une linux Mint,
              je dirais qu'il faut faire un

              apt purge nouveau

              ou apt purge xorg-nouveau

              puis redemarrer la machine, qui devrait alors demarrer avec le pilote VESA
              et te permettre ensuite d'installer le pilote nividia

              evidemment il doit y avoir un paquet nvidia ou nvidia-settings qui doit permettre de le faire pile comme il faut pour ta distrib

    • [^] # Re: Quelques commandes

      Posté par . Évalué à 2 (+1/-0). Dernière modification le 22/04/19 à 21:05.

      J'aurais du être au moins aussi performant non ?

      Je confirme que pour un GPU comme le tien tes valeurs me semblent plutôt faibles.

      Pour comparaison, mon vieux Q9650 à 3GHz avec une vieille GT640 (driver propriétaire nvidia 384.130 sous Mint 18.3 Cinnamon) me renvoie une valeur d'environ 12000 FPS à la commande

      vblank_mode=0 glxgears
      
  • # Résumé

    Posté par . Évalué à 1 (+0/-0). Dernière modification le 27/04/19 à 10:33.

    Merci pour toute l'aide déjà apporté :

    Pour résumer :

    après avoir mise à jour mon pilote GPU via l'outil Mint la qualité graphique c'est dégrader (résolution, un seul écran …).

    en m' appuient sur https://doc.ubuntu-fr.org/xorg j'ai fait :

    • sudo dpkg-reconfigure -phigh xserver-xorg, puis redémarrer mais ça n'a rien changé.
    • sudo nvidia-xconfig, la commende n'existe pas.
    • sudo apt-get install nvidia-xconfig, le paquet n'existe pas.

    puis la section "Comment régénérer un nouveau fichier xorg.conf en mode console ?"

    • sudo service lightdm stop
    • sudo X -configure, la commande n'existe pas…

    Quelqu'un a une idée svp…

    • [^] # Re: Résumé

      Posté par . Évalué à 1 (+0/-0).

      Grace au "Rencontres Accès Libre" de http://www.linux-azur.org jai pu résoudre mon problème : une option de mon bios (je ne sais plus laquelle) était sur windows au lieu de other os …

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.