Forum Linux.debian/ubuntu Conflit de port NGINX

Posté par  . Licence CC By‑SA.
Étiquettes :
1
20
août
2021

Bonjour à tous!
Je viens vers vous car j'ai un petit soucis avec mon NAS et celui-ci fonctionne sous OpenMediaVault…
J'ai installé Nextcloud sur docker puis par la suite j'ai voulu tester AMP CubeCoders et je l'ai installé comme ça sur ma machine… Sauf qu'en installant AMP CubeCoders, celui-ci s'est approprié les ports 80 et 443 pour son interface d'administration sauf que j'utilisais ses ports pour Nextcloud. J'ai donc désinstallé AMP CubeCoders mais malgré tout j'ai un processus nginx qui continue de démarrer en utilisant toujours les ports 80 et 443…
Lorsque je kill celui-ci, j'arrive à redémarrer nextcloud si je le lance dans les 30sec après mon kill sinon le processus à déjà redémarré…
Et lors du redémarrage de mon NAS, Nextcloud ne sait pas démarrer car le processus nginx et déjà démarré avant…
Quelqu'un aurait une idée de comment résoudre ce problème?
Je commence à être désespéré --'

  • # Systemd

    Posté par  . Évalué à 3.

    Salut,

    potentiellement ça pourrait être parce que le service est relancé s'il vient à être interrompu sans passer pas le gestionnaire de service. Je ne connais pas AMP CubeCoders, mais potentiellement ils ont pu créer un service nginx personnalisé avec des directives du type Restart=on-failure et RestartSec=30s de systemd.

    Il faudrait donc plutôt stopper proprement le service plutôt que de tuer le processus nginx directement pour éviter ce comportement.

    Si cela ne règle pas ton soucis, il faudrait que tu vérifies à l'aide de systemctl list-units --type=service comment s'appelle le service à stopper/désactiver.

  • # Options

    Posté par  . Évalué à 2.

    Hello.

    Je sais pas si Nginx a ete installe deliberement, ou par le biais d'un script d'install de AMP CubeCoders, mais si tu veux faire cohabiter les 2, tu vas devoir reconfigurer des choses. Pour faire au plus simple:
    Option 1: reconfigurer Nginx pour utiliser d'autres ports que 80/443 (8080/8443 par ex.)
    Option 2: reconfigurer NextCloud pour utiliser d'autres ports que 80/443 (8080/8443 par ex. encore)

    Apres tu peux aussi regarder ici et t'en inspirer pour faire en sorte que tout soit accessible sur les ports standards.

    Et tant d'autres possibilites encore!

    ++
    Gi)

    • [^] # Re: Options

      Posté par  . Évalué à 1.

      Merci je vais regarder ça aussi!
      Mais le truc c'est que j'aimerais tout simplement désactiver le fait que ngnix pour AMP utilise les ports 80 et 443 car j'ai désinstallé AMP Cubecoder… J'ai donc le service web qui tourne mais il n'y a rien dessus…

  • # Plusieurs processus nginx...

    Posté par  . Évalué à 1. Dernière modification le 20/08/21 à 20:16.

    J'ai bien un service nginx qui tourne mais le problème c'est que le processus nginx qui tourne pour OMV et pour le service de AMP CubeCoders a le même PID.

    Service
    https://www.dropbox.com/s/ihrqgdhdb4wcjnt/Service.png?dl=0

    Comme vous pouvez voir sur le screenshot suivant, c'est le processus 10245 qui gère les ports 82 et 449 (OpenMediaVault) mais également les ports 80 et 443. (serveur administration AMP Cubecoder) Lorsque je ferme proprement nginx ou que je kill le processus 10245 cela me permet de relancer Nextcloud mais m’empêche temporairement de d'accéder à la page d'administration de OMV. Et lorsque je redémarre le serveur il y a de nouveau le service nginx qui vient utiliser le port 80 et 443.

    Port
    https://www.dropbox.com/s/facjg848gl57mlt/port_.jpg?dl=0

    Et j'ai également ceci :
    pgrep nginx -a
    pgrep
    https://www.dropbox.com/s/zrqvz7rn9fmgbai/pgrep.png?dl=0

  • # /!\Résolut

    Posté par  . Évalué à 1.

    Un tout grand merci à vous!
    J'ai enfin réussis à résoudre le problème après de nombreuse recherche!!
    C'était un simple fichier qui polluait nginx dans /etc/nginx/conf.d

Suivre le flux des commentaires

Note : les commentaires appartiennent à celles et ceux qui les ont postés. Nous n’en sommes pas responsables.