Forum Linux.debian/ubuntu Connexion qui deconne

Posté par  (site Web personnel) .
Étiquettes : aucune
0
27
juil.
2006
Bonjour a tous,

Je suis encore un peu débutant sous linux, et il y a quelques jours j'ai choisi d'abandonner ma mandriva au profit de debian.
J'ai fait une install de debian testing via internet. Tous s'est bien déroulé. Seulement, au démarrage, ma connexion reseau ne marchait plus, en fait elle n'etait pas configurée. Je l'ai donc fait, mais maintenant, lorsque je ping ma passerelle, j'ai l'erreur Destination Host Unreachable ...
Je suis sous debian testing. Ma carte mere est une asus a7n8x-e, et le cable réseau est branché sur la carte Marvell Yukon 88E8001/8003/8010 PCI Gigabit Ethernet Controller.
D'apres lsmod, le pilote sk98lin (pour la carte réseau) est bien chargé.

Mon fichier /etc/network/interfaces:
http://www.valouche.info/linuxfr/interfaces.txt

Ce que renvoie ifconfig:
http://www.valouche.info/linuxfr/ifconfig.txt

Ce que renvoie /sbin/route:
http://www.valouche.info/linuxfr/route.txt

S'il vous plaît, aidez moi !
  • # Tout a l'air correct

    Posté par  . Évalué à 3.

    Si 192.168.0.1 est bien l'adresse IP de ta passerelle, et que celle-ci a le même masque de réseau, alors ta configuration est correcte.

    Es-tu certain de l'adresse de ta passerelle ?
    Ta passerelle répond-elle aux ping (pas de filtrage ?)

    default 192.168.0.1 0.0.0.0 UG 0 0 0 eth0 //cette ligne met beaucoup de temps a s'afficher

    Le fait que cette ligne mette du temps à s'afficher bien du fait que la passerelle ne ping pas et que la résolution DNS inverse ne fonctionne pas.

    Si tu veux afficher la table de routage sans avoir à attendre des plombes, "netstat -rn"
    • [^] # Re: Tout a l'air correct

      Posté par  (site Web personnel) . Évalué à 1.

      merci de ta reponse symoon
      Je suis sur de l'adresse de la passerelle (192.168.0.1). D'habitude (sa configuration n'a pas changé), elle repond aux ping, mais la aucun ping ne repond (sauf la boucle locale)...
      Je viens de remarquer quelque chose: mon ip est 192.168.0.2, avec comme masque 255.255.255.0, mais route indique genmask: 0.0.0.0. Peut etre est ce un probleme ???
      • [^] # Re: Tout a l'air correct

        Posté par  . Évalué à 2.

        Je suis sur de l'adresse de la passerelle (192.168.0.1). D'habitude (sa configuration n'a pas changé), elle repond aux ping, mais la aucun ping ne repond (sauf la boucle locale)...

        Tu peux lancer un ethereal sur ta machine voire ta passerelle histoire d'étuder ce qu'il se passe.

        Que donne un mii-tool eth0 ?

        Je viens de remarquer quelque chose: mon ip est 192.168.0.2, avec comme masque 255.255.255.0, mais route indique genmask: 0.0.0.0. Peut etre est ce un probleme ???

        Non c'est normal, c'est une route par défaut, donc par nature il n'y a pas de masque associé.
        • [^] # /etc/resolv.conf

          Posté par  . Évalué à 2.

          Peut etre un probleme de DNS, est ce que tu as mis les DNS dans /etc/resolv.conf ?
          • [^] # Re: /etc/resolv.conf

            Posté par  (site Web personnel) . Évalué à 1.

            >> alban
            Je pense qu'une erreur de dns peut etre exclue, puisque meme un ping 192.168.0.1 ne fonctionne pas !

            >>symoon
            je suis desolé, mais je n'ai pas ethereal d'installé, et sans connexion internet, je ne sais pas comment installé toutes les dependances (j'ai telecharger le paquet pour debian testing), mais je vais continuer a essayer.
            Pour mii-tool, il me renvoie ça :

            valouche:/home/valentin# mii-tool
            SIOCGMIIPHY on 'eth0' failed: Operation not supported
            SIOCGMIIPHY on 'eth2' failed: Operation not supported
            no MII interfaces found
            valouche:/home/valentin#


            merci pour vos reponses ;)
            • [^] # Re: /etc/resolv.conf

              Posté par  (site Web personnel) . Évalué à 1.

              C'est bon j'ai installé ethereal !
              Mais l'interface est tres chargée et je ne connais pas.
              Je lui ai demandé de surveiller eth0, une fenetre s'est ouverte, avec des jauges, puis j'ai lancé un ping en local, puis sur la passerelle: rien n'est enregistré !
              Je trouve cela tres bizarre ...
              Sinon pourrait on envisager d'utiliser dhcp sur eth0 (et comment configurer cela ?)?
    • [^] # Re: Tout a l'air correct

      Posté par  (site Web personnel) . Évalué à 1.

      Effectivement tout à l'air bien paramétré mais il me semble qu'il y a deux interfaces réseau sur cette carte mère. Il est possible que ton interface eth0 corresponde à la carte nforce et non pas à la Marvell.

      Essaye de te brancher sur l'autre interface pour voir si le ping passe.
      • [^] # Re: Tout a l'air correct

        Posté par  (site Web personnel) . Évalué à 1.

        merci enoch !
        je vais essayer ça, mais si le cable n'est pas branché, ne devrait il pas plutot me renvoyer 'Network unreachable'?
        • [^] # Re: Tout a l'air correct

          Posté par  (site Web personnel) . Évalué à 1.

          Si le câble est débranché, le ping ne te renvoi rien pdt un moment puis te met "Destination Host Unreachable" quand le timeout est écoulé.

          Une bonne façon de tester ça est de passer en commande (avec Ctrl+Alt+F1, ça ne fonctionne pas avec un terminal graphique)

          Une fois sur la console tu débranche le câble, il devrait t'afficher "skge eth0: Link is down" et quand tu rebranche "skge eth0: Link is up at 1000 Mbps, ..."

          Si rien ne s'affiche essaye sur l'autre interface réseau de la carte mère et vérifie que l'autre extrémité du câble est bien branché (on sait jamais, il suffit d'une prise RJ45 un peu foireuse ...)

          Petite précision : j'ai aussi une Marvell Yukon 88E8001/8003/8010 PCI Gigabit sur ma carte mère et elle fonctionne parfaitement bien sous debian testing sans avoir à installer un pilote particulier. Ce qui confirme ce que tu à pu voir avec lsmod ...

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.