Forum Linux.debian/ubuntu Connexions TCP en l'air

Posté par .
Tags : aucun
0
20
avr.
2005
Bonjour,
j'ai un problème sur un serveur Debian-Sarge+Cyrus-2.2.8: lorsque j'examine les connexions actives avec le pid (netstat -tnp), j'en trouve certaines sans processus correspondant:
tcp 0 0 10.1.1.1:143 10.1.1.2:23000 ESTABLISHED-

Elles existent dans /proc/net/ip_conntrack mais même en cherchant les flux ouverts pour tous les processus (lsof -p), aucun ne correspond. Autre symptome, le serveur Cyrus est très lent lorsque ce genre de connexion apparait. S'agit-t-il de connexions restant en mode noyau ?
  • # droits !

    Posté par (page perso) . Évalué à 2.

    je parie que tu lance netstat en tant que user, en fait les pid que tu ne vois pas sont des pid de process appartenant à un utilisateur pour lesquels tu n'as pas le droit de lire les infos !!

    relance la commande (netstat -taupe) en tant que root et tout devrait être plus clair !!!

    M.
    • [^] # Re: droits !

      Posté par . Évalué à 1.

      Non bien sûr, netstat est lancé en tant que root et j'ai également examiné les connexions et processus dans /proc qui confirment qu'aucun processus n'est attaché à cette connexion mais qu'elle existe bien dans ip_conntrack
      • [^] # Hum ...

        Posté par . Évalué à 1.

        Essaie chkrootkit ou rkhunter on ne sait jamais ...
  • # Au hasard ...

    Posté par (page perso) . Évalué à 1.

    lsof -ni

    Ca dit quoi ça ?

    A++

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.