Forum Linux.debian/ubuntu CTRL-ALT-F*

Posté par .
Tags : aucun
0
9
déc.
2004
Je me permets de remettre le problème évoqué ici http://linuxfr.org/forums/15/4157.html(...)
sur la place.
Depuis presque un an, ctrl+alt+f1 ne fait plus rien pas plus que les autres. Et ça commence à me chauffer.
Oui les getty sont là, ils tournent (si je fait un /etc/init.d/gdm stop, je les ai, et je peux même passer de l'un à l'autre par alt+F*).

Je suis sur une debian sid, ce qui fait à peu près 4.3.0.dfsg.1-8, et je ne me souviens absolument plus quand ça a commencé.

J'utilise le pilote nvidia proprio, je devrais peut être essayer avec nv pour voir.
  • # Re

    Posté par . Évalué à -2.


    J'utilise le pilote nvidia proprio, je devrais peut être essayer avec nv pour voir.


    Je trouve ça abusé de poster dans les forums sans même avoir tenté de trouver une solution par toi même.

    Maintenant, tout le monde n'as pas ton probl_me et n'a pas non plus de sid (et oui, paske faut en vouloir aussi pour utiliser une sid), donc si par exemple tu pouvais nous paster ton XF86Config, je pense que ça nous aiderait pas mal.
    Peut être aussi que des indications quant à ton window manager serait pas mal.
    Et pour finir, jette donc un oeil à la page de man, il y a une option qui il me semble pourrait être en cause:


    Option "DontVTSwitch" "boolean"
    This disallows the use of the Ctrl+Alt+Fn sequence (where Fn
    refers to one of the numbered function keys). That sequence is
    normally used to switch to another "virtual terminal" on operat-
    ing systems that have this feature. When this option is
    enabled, that key sequence has no special meaning and is passed
    to clients. Default: off.

    • [^] # Re: Re

      Posté par . Évalué à 2.

      Ne pas avoir tenté de régler le problème par moi même?
      Ça fait UN AN (comme dit ci dessus) que j'essaie par moi même!
      D'après une recherch google, plusieurs personnes ont reporté ce truc, sans jamais de solution.

      Le window manager ne peut intercepter cette combinaison de touches, le serveur X a la priorité.

      Je ne connaissait pas cette option. Cela dit, je ne me souviens pas l'avoir ajoutée. Je vérifie.
      • [^] # Re: Re

        Posté par . Évalué à 2.

        Non, pas de DontVT... dans mon XF86Config-4, qui d'ailleurs ne contient rien d'exceptionnel.


        Section "Files"
        FontPath "unix/:7100" # local font server
        # if the local font server has problems, we can fall back on these
        FontPath "/usr/lib/X11/fonts/misc"
        FontPath "/usr/lib/X11/fonts/cyrillic"
        FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
        FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
        FontPath "/usr/lib/X11/fonts/Type1"
        FontPath "/usr/lib/X11/fonts/Speedo"
        FontPath "/usr/lib/X11/fonts/100dpi"
        FontPath "/usr/lib/X11/fonts/75dpi"
        EndSection

        Section "Module"

        Load "bitmap"
        Load "dbe"
        Load "ddc"
        Load "extmod"
        Load "freetype"
        Load "glx"
        Load "int10"
        Load "record"
        Load "speedo"
        Load "type1"
        Load "vbe"
        Load "xie"
        EndSection

        Section "InputDevice"
        Identifier "Generic Keyboard"
        Driver "keyboard"
        Option "CoreKeyboard"
        Option "XkbRules" "xfree86"
        Option "XkbModel" "pc105"
        Option "XkbLayout" "fr-latin9"
        EndSection

        Section "InputDevice"
        Identifier "Configured Mouse"
        Driver "mouse"
        Option "CorePointer"
        Option "Device" "/dev/psaux"
        Option "Protocol" "ImPS/2"
        Option "ZAxisMapping" "4 5"
        EndSection

        Section "InputDevice"
        Identifier "Generic Mouse"
        Driver "mouse"
        Option "SendCoreEvents" "true"
        Option "Device" "/dev/input/mice"
        Option "Protocol" "ImPS/2"
        Option "ZAxisMapping" "4 5"
        EndSection

        Section "Device"
        Identifier "Generic Video Card"
        Driver "nvidia"
        Option "NvAGP" "3"
        Option "NoLogo" "true"
        EndSection
        #Section "Device"
        # Identifier "Generic Video Card"
        # Driver "nv"
        #EndSection

        Section "Monitor"
        Identifier "Generic Monitor"
        HorizSync 30-70
        VertRefresh 50-160
        Option "DPMS"
        EndSection

        Section "Screen"
        Identifier "Default Screen"
        Device "Generic Video Card"
        Monitor "Generic Monitor"
        DefaultDepth 24
        SubSection "Display"
        Depth 1
        Modes "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
        Depth 4
        Modes "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
        Depth 8
        Modes "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
        Depth 15
        Modes "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
        Depth 16
        Modes "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
        Depth 24
        Modes "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        EndSection

        Section "ServerLayout"
        Identifier "Default Layout"
        Screen "Default Screen"
        InputDevice "Generic Keyboard"
        InputDevice "Configured Mouse"
        InputDevice "Generic Mouse"
        EndSection
    • [^] # Re: Re

      Posté par . Évalué à 3.

      > et oui, paske faut en vouloir aussi pour utiliser une sid

      oh un troll...
      vu !

      ps. on dit "parce que" ;-)
  • # et ton noyeau?

    Posté par (page perso) . Évalué à 1.

    Tu as recompilé ton kernel? si oui tu aurais pas un "console on serial port" ou un truc du genre...
    Je dis ca, je dis rien...
    • [^] # Re: et ton noyau?

      Posté par . Évalué à 1.

      Une quarantaine de recompilations cet été (chasse à un bug en remontant bk, alors qu'en fait c'était matériel), une dizaine d'autres sinon.

      Pour le Console on 8250/16550 and compatible, il est bien désactivé, sinon, tuer X ne changerait rien (mais pris d'un doute, j'ai quand même vérifé, comme quoi ;)
  • # clavier usb ?

    Posté par . Évalué à 1.

    je sais que je ne peux pas changer de vt avec un clavier USB, chose qui fonctionne pourtant tres bien avec un clavier ps/2. Peut etre que c'est ton cas ?
  • # udev

    Posté par . Évalué à 2.

    Etant a l'origine du premier Post, j'ai réussi a arranger tout ca. J'aurais du repondre a mon probleme pardon ...


    En fait chez moi c'est udev qui fouttait la grouille et depuis que je l'ai viré tout est rentré dans l'ordre ...

    Mais je suis obligé de monter mon APN a la main quand je le connecte (remarques il ne le faisait pas avec udev non plus mais j'avais bon espoir d'arriver a le faire fonctionner ...)

    Dam
    • [^] # Re: udev

      Posté par . Évalué à 2.

      Ok, merci.
      Je suis content que tu t'en sois tiré. Mais bon, moi j'ai pas udev. Du moins je crois pas. Sauf si ça a été installé dans mon dos.
      Remarque, udev n'était pas très répandu il y a un an :)
  • # chvt

    Posté par . Évalué à 4.

    Et chvt, il marche ou pas?
    • [^] # Re: chvt

      Posté par . Évalué à 2.

      Ah, je ne connaissait pas cette commande, mais je sens qu'on progresse :

      mick@nimoya:~$ chvt 1
      Couldnt get a file descriptor referring to the console
      • [^] # Re: chvt

        Posté par (page perso) . Évalué à 2.

        Tu as bien tous les /dev/tty* qu'il faut ?

        pertinent adj. Approprié : qui se rapporte exactement à ce dont il est question.

        • [^] # Re: chvt

          Posté par . Évalué à 2.

          oui, ils existent.
          Je repète : quand je tue X, les VT sont là et je peux passer de l'un à l'autre.
      • [^] # Re: chvt

        Posté par . Évalué à 2.

        On dirait que tu n'es pas propriétaire de la console... Comme si tu étais loggé à distance (par exemple par ssh). Maintenant, quant à savoir d'où vient le problème...
        • [^] # Re: chvt

          Posté par . Évalué à 2.

          Non, c'est tout bête : quand je me "su" en root, ça marche.
      • [^] # Re: chvt

        Posté par . Évalué à 1.

        Même message d'erreur chez moi (en cooker) à partir du serveur X alors que ctrl+alt+f1 fonctionne.
        Par contre chvt 2 fonctionne à partir de vt1...

        Bonne chance
        • [^] # Re: chvt

          Posté par . Évalué à 2.

          Je précise, suite au post de KoinKoin:

          En root, à partir de X, chvt n fonctionne.
          • [^] # Re: chvt

            Posté par . Évalué à 2.

            C'est exact, ça marche en root. Est-ce qu'il faut être root pour faire ctrl-alt-f1? Où est-ce que quelque chose a pourri les permissions de /dev/tty*?
            • [^] # Re: chvt

              Posté par . Évalué à 2.

              accessoirement, Ctrl Alt + et - ne marchent pas non plus, mais Ctrl Alt BS marchent.
            • [^] # Re: chvt

              Posté par (page perso) . Évalué à 2.

              Il faut pas être root pour faire ctrl-alt-f1 mais il faut l'être pour pouvoir faire un chvt depuis X parce que le process qui utilise la console courante (X) appartient à root (X est suid root). Quand tu fais ctrl-alt-fx, c'est directement interprété par X et donc ça marche (normalement). Enfin je pense.

              Je sais pas où sont définis les raccourcis clavier ctrl-alt-fx (dans X ? dans init ? dans le noyau ?).

              pertinent adj. Approprié : qui se rapporte exactement à ce dont il est question.

              • [^] # Re: chvt

                Posté par . Évalué à 2.

                En principe, ces raccourcis sont dans X. Si tu es sous console, il suffit de faire alt+fn pour changer de VT.
                Mais les fichiers de config de X, je sais pas pourquoi, je ne les encadre pas :)
                • [^] # Re: chvt

                  Posté par . Évalué à 2.

                  Question bête : est-ce que X est bien suid root, et installé sur une partition où le bit suid n'est pas désactivé?
  • # Solution

    Posté par (page perso) . Évalué à 0.

    Je sais que X a une option qui permet de desactiver le support de
    ^M-Sup
    et
    ^M <-

    parcontre je n ai aucune idee d ou ca se regle. Tout ce dont je me rappelle c est qu un outil de conf automatise m as une fois propose de les inhiber. Donc c est fesable !

    Je te cherche ca dans la soiree.
    • [^] # Re: Solution

      Posté par (page perso) . Évalué à 0.

      Bon ... je n ai plus Xfree, je me rappelle juste que c etait sous xf86Cfg ( le truc graphique ) ... impossible de t en dire plus. DSL.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.