Forum Linux.debian/ubuntu Debian, apache, userdir, 403 forbidden

Posté par . Licence CC by-sa.
Tags :
0
13
juin
2013

Bonjour,

J'ai profité des récents changements dans sid pour purger mes paquets apache (depuis le temps ce n'était pas une mauvaise chose).

Si le serveur fonctionne bien (it works!), je ne peux pas en dire autant du mod_userdir.

J'ai suivi le wiki debian à la lettre mais en lieu et place de l'habituel localhost/~user j'ai droit à un triste 403 forbidden. Je suppose qu'il y a un maillon faible dans les permissions de mon chemin mais je n'arrive pas à l'identifier.

J'ai changé le groupe de mon dossier public_html :

chgrp www-data /home/<username>/public_html

J'ai modifié les permissions du dossier utilisateur :

chmod 755 /home/<username>

J'ai ajouté mon utilisateur au groupe www-data et vice-versa.

J'ai essayé de chmod a+x mon dossier, mais rien n'y fait.

Je précise que le serveur a été redémarré après chaque manip.

Auriez-vous une idée ?

Merci beaucoup !

Contenu du /etc/apache2/mods-enabled/userdir.conf :

<IfModule mod_userdir.c>
        UserDir public_html
        UserDir disabled root

        <Directory /home/*/public_html>
                AllowOverride All
                Options MultiViews Indexes SymLinksIfOwnerMatch
                <Limit GET POST OPTIONS>
                        Order allow,deny
                        Allow from all
                </Limit>
                <LimitExcept GET POST OPTIONS>
                        Order deny,allow
                        Deny from all
                </LimitExcept>
        </Directory>
</IfModule>

  • # Résolu

    Posté par . Évalué à 2.

    Bon la solution :

    <IfModule mod_userdir.c>
            UserDir public_html
            UserDir disabled root
    
            <Directory /home/*/public_html>
             Options All
             AllowOverride All
             Require all granted
                    Options MultiViews Indexes SymLinksIfOwnerMatch
                    <Limit GET POST OPTIONS>
                            Order allow,deny
                            Allow from all
                    </Limit>
                    <LimitExcept GET POST OPTIONS>
                            Order deny,allow
                            Deny from all
                    </LimitExcept>
            </Directory>
    </IfModule>
    
    
    • [^] # Re: Résolu

      Posté par (page perso) . Évalué à 2.

      erf … j'ai eu le souci tout à l'heure … je t'aurais bien répondu mais visiblement c'est trop tard! : )

      wind0w$ suxX, GNU/Linux roxX!

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.