Forum Linux.debian/ubuntu Debian, Sympa et spam non filtré

Posté par  (site Web personnel) . Licence CC By‑SA.
Étiquettes :
0
16
mar.
2013

Depuis le crash disque du nouvel an sur mon serveur kimsufi, j'ai tout réinstallé et en ai profité pour upgrader quelques composants, notamment remplacer courier par dovecot.

En passant j'ai aussi remplacé procmail par sieve pour filtrer les mails reçus, et c'est là que ca pose un petit souci. Maintenant, lorsque je reçois un spam sur mes listes gérées par sympa, ca mes les redirige automatiquement dans le pool de modération et m'envoie un mail par la même occasion.

J'ai eu beau chercher, j'ai pas trouvé comment éliminer silencieusement les spams. Sympa parle de scenarii dans cette page : http://www.sympa.org/manual/antispam , mais je ne trouve pas les fichiers dont ils parlent, sûrement parce que je suis sous Debian stable et que les fichiers ne sont pas au même endroit.
D'autre part, sieve ne filtre apparemment pas les mails inline.

J'ai l'intuition que la solution est à la fois simple et efficace, mais je ne l'ai pas encore trouvée. Quelqu'un a-t-il déjà eu à traiter ce cas ?

  • # Expérience perso (config plus ou moins similaire)

    Posté par  . Évalué à 2.

    Salut,

    Je ne sais pas quel type de stockage tu utilises pour tes boites emails mais perso en maildir/virtual mail j'ajoute un fichier .dovecot.sieve dans le répertoire racine de la boite.

    Et par exemple, pour déplacer automatiquement les mails qui ont un X-Spam-Flag à YES au niveau du header dans le répertoire Junk (qui n'est pas sous INBOX, d'où le "fileinto") :

    require "fileinto";
    if exists "X-Spam-Flag: YES" {
    fileinto "Junk";
    }

    Pour plus d'options, voir: http://wiki.dovecot.org/LDA/Sieve#Mailbox_names_with_fileinto

    • [^] # Re: Expérience perso (config plus ou moins similaire)

      Posté par  (site Web personnel) . Évalué à 1.

      Merci, mais c'est bien ca le problème, j'utilise Maildir pour stocker les mails et dovecot/sieve pour les filtrer.

      Ta méthode fonctionne pour les spams classiques (qui me sont envoyés à moi) mais pas pour les spams qui sont envoyés à Sympa, parce que sympa les insère en inline dans un autre mail et me renvoie le tout. Mon filtre Sieve ne voit pas le header X-Spam-Flag parce qu'il n'est plus dans le header, mais dans le corps du message…

      • [^] # Re: Expérience perso (config plus ou moins similaire)

        Posté par  . Évalué à 2.

        Alors voir du coté de http://www.ietf.org/rfc/rfc5173.txt

            require ["body", "fileinto"];
        
            # This will match a message containing the literal text
            # "MAKE MONEY FAST" in body parts (ignoring any
            # content-transfer-encodings) or MIME headers other than
            # the outermost RFC 2822 header.
        
            if body :raw :contains "X-Spam-Flag" "YES" {
                    fileinto "INBOX.junk";
            }
        
        

        Et peut être voir à ce que ce soit dans une fichier de conf global:

        protocol lda {
        [...]
        global_script_path = /path/to/globalsieverc
        [...]
        }

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.