Forum Linux.debian/ubuntu docker.io

Posté par  . Licence CC By‑SA.
2
24
jan.
2022

J'ai installé docker.io et docker-compose depuis les dépôts de debian 11.
Lorsque je tente un docker-compose up -d, j'ai l'erreur suivante :

ERROR: Version in "./docker-compose.yml" is unsupported. You might be seeing this error because you're using the wrong Compose file version. Either specify a supported version (e.g "2.2" or "3.3") and place your service definitions under the `services` key, or omit the `version` key and place your service definitions at the root of the file to use version 1.

For more on the Compose file format versions, see https://docs.docker.com/compose/compose-file/

Ce qui est logique (si je ne me trompe pas) puisque la version docker.io est en avance sur la docker-ce.

J'ai tenté version: "3.9" mais ça ne change rien.

Y-a-t'il un moyen de corriger ça sans devoir installer docker-ce?

  • # Changer le numéro de version et tester

    Posté par  . Évalué à 4.

    Il faut utiliser un numéro de version inférieur. Avec 3.7 cela devrait fonctionner.
    Tu peux tester tes modifications avec :

    docker-compose config

Suivre le flux des commentaires

Note : les commentaires appartiennent à celles et ceux qui les ont postés. Nous n’en sommes pas responsables.