Forum Linux.debian/ubuntu DPKG

Posté par .
Tags : aucun
0
3
nov.
2008
Bonjour,

Je travail avec la distribution ubuntu 8.04 Desktop edition :

Je ne peux plus installé aucun paquet, depuis que j'ai désinstallé openoffice
et tenté de le réinstaller , voici ce que me renvoie sudo apt-get -f install :

 
sudo apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Les paquets suivants seront ENLEVÉS :
openoffice.org-thesaurus-de openoffice.org-thesaurus-de-ch
0 mis à jour, 0 nouvellement installés, 2 à enlever et 62 non mis à jour.
2 partiellement installés ou enlevés.
Après cette opération, 9175ko d'espace disque seront libérés.
Souhaitez-vous continuer [O/n] ? o
(Lecture de la base de données... 115892 fichiers et répertoires déjà installés.)
Suppression de openoffice.org-thesaurus-de ...
/var/lib/dpkg/info/openoffice.org-thesaurus-de.postrm: line 6: update-openoffice-dicts : commande introuvable
dpkg : erreur de traitement de openoffice.org-thesaurus-de (--remove) :
le sous-processus post-removal script a retourné une erreur de sortie d'état 127
Suppression de openoffice.org-thesaurus-de-ch ...
/var/lib/dpkg/info/openoffice.org-thesaurus-de-ch.postrm: line 6: update-openoffice-dicts : commande introuvable
dpkg : erreur de traitement de openoffice.org-thesaurus-de-ch (--remove) :
le sous-processus post-removal script a retourné une erreur de sortie d'état 127
Des erreurs ont été rencontrées pendant l'exécution :
openoffice.org-thesaurus-de
openoffice.org-thesaurus-de-ch
E: Sub-process /usr/bin/dpkg returned an error code (1)


Je suis vraiment dans l'embarras !
Merci de votre aide
  • # reinstall openoffice

    Posté par . Évalué à 2.

    /var/lib/dpkg/info/openoffice.org-thesaurus-de-ch.postrm: line 6: update-openoffice-dicts : commande introuvable

    il ne trouve plus la commande update-openoffice-dicts
    qui est probablement fournit avec openoffice

    il ne peut donc plus desinstaller les dictionnaires.

    1°) reinstall openoffice
    2°) desinstalle les dictionnaires
    3°) desinstalle openoffice

    ca devrait aller mieux
    • [^] # Re: reinstall openoffice

      Posté par . Évalué à 1.

      Merci, Le problème c'est que je ne peux pas réinstaller openoffice , voici le retour :
      sudo apt-get install openoffice.org
      Lecture des listes de paquets... Fait
      Construction de l'arbre des dépendances       
      Lecture des informations d'état... Fait
      Les paquets supplémentaires suivants seront installés : 
        bsh dictionaries-common libhsqldb-java libjaxp1.3-java libjline-java
        libservlet2.4-java libxalan2-java libxerces2-java openoffice.org-base
        openoffice.org-base-core openoffice.org-calc openoffice.org-common
        openoffice.org-core openoffice.org-draw openoffice.org-filter-binfilter
        openoffice.org-filter-mobiledev openoffice.org-impress
        openoffice.org-java-common openoffice.org-math openoffice.org-officebean
        openoffice.org-style-human openoffice.org-writer openoffice.org-writer2latex
        python-uno
      Paquets suggérés :
        libservlet2.3-java bsh-doc emacsen-common ispell jed-extra
        libhsqldb-java-doc libhsqldb-java-gcj libjline-java-doc
        libservlet2.4-java-gcj libxalan2-java-doc libbsf-java libxsltc-java
        libxerces2-java-doc gstreamer0.10-plugins-bad gstreamer0.10-plugins-ugly
        hunspell-dictionary menu msttcorefonts myspell-dictionary
        openclipart-openoffice.org openoffice.org-gnome openoffice.org-kde
        openoffice.org-help-2.4 openoffice.org-hyphenation openoffice.org-l10n-2.4
        pstoedit libmyodbc odbc-postgresql libsqliteodbc tdsodbc mdbtools
        libmysql-java libpg-java openoffice.org-gcj openoffice.org-report-builder
        openoffice.org-style-hicontrast openoffice.org-style-industrial
      Paquets recommandés :
        bsh-gcj libgcj8-1-awt libjaxp1.3-java-gcj libxalan2-java-gcj
        libxerces2-java-gcj
      Les paquets suivants seront ENLEVÉS :
        openoffice.org-thesaurus-de openoffice.org-thesaurus-de-ch
      Les NOUVEAUX paquets suivants seront installés :
        bsh dictionaries-common libhsqldb-java libjaxp1.3-java libjline-java
        libservlet2.4-java libxalan2-java libxerces2-java openoffice.org
        openoffice.org-base openoffice.org-base-core openoffice.org-calc
        openoffice.org-common openoffice.org-core openoffice.org-draw
        openoffice.org-filter-binfilter openoffice.org-filter-mobiledev
        openoffice.org-impress openoffice.org-java-common openoffice.org-math
        openoffice.org-officebean openoffice.org-style-human openoffice.org-writer
        openoffice.org-writer2latex python-uno
      0 mis à jour, 25 nouvellement installés, 2 à enlever et 62 non mis à jour.
      2 partiellement installés ou enlevés.
      Il est nécessaire de prendre 0o/70,5Mo dans les archives.
      Après cette opération, 244Mo d'espace disque supplémentaires seront utilisés.
      Souhaitez-vous continuer [O/n] ? o
      Préconfiguration des paquets...
      (Lecture de la base de données... 115892 fichiers et répertoires déjà installés.)
      Suppression de openoffice.org-thesaurus-de ...
      /var/lib/dpkg/info/openoffice.org-thesaurus-de.postrm: line 6: update-openoffice-dicts : commande introuvable
      dpkg : erreur de traitement de openoffice.org-thesaurus-de (--remove) :
       le sous-processus post-removal script a retourné une erreur de sortie d'état 127
      Suppression de openoffice.org-thesaurus-de-ch ...
      /var/lib/dpkg/info/openoffice.org-thesaurus-de-ch.postrm: line 6: update-openoffice-dicts : commande introuvable
      dpkg : erreur de traitement de openoffice.org-thesaurus-de-ch (--remove) :
       le sous-processus post-removal script a retourné une erreur de sortie d'état 127
      Des erreurs ont été rencontrées pendant l'exécution :
       openoffice.org-thesaurus-de
       openoffice.org-thesaurus-de-ch
      E: Sub-process /usr/bin/dpkg returned an error code (1)
      admin@ns26180:~$ 
      
      
      
      • [^] # Re: reinstall openoffice

        Posté par . Évalué à 2.

        reinstalle donc aussi les dictionnaires pour ne pas qu'il essaie de les enlever en meme temps qu'il installe openoffice
        • [^] # Re: reinstall openoffice

          Posté par . Évalué à 1.

          Bon, ce n'est pas aussi simple, le gestionnaire n'installe plus aucun paquet : exemple : installation de gimp
          sudo apt-get install gimp
          
          sudo apt-get install gimp
          Lecture des listes de paquets... Fait
          Construction de l'arbre des dépendances       
          Lecture des informations d'état... Fait
          gimp est déjà la plus récente version disponible.
          Les paquets suivants seront ENLEVÉS :
            openoffice.org-thesaurus-de openoffice.org-thesaurus-de-ch
          0 mis à jour, 0 nouvellement installés, 2 à enlever et 62 non mis à jour.
          2 partiellement installés ou enlevés.
          Après cette opération, 9175ko d'espace disque seront libérés.
          Souhaitez-vous continuer [O/n] ? o
          (Lecture de la base de données... 115892 fichiers et répertoires déjà installés.)
          Suppression de openoffice.org-thesaurus-de ...
          /var/lib/dpkg/info/openoffice.org-thesaurus-de.postrm: line 6: update-openoffice-dicts : commande introuvable
          dpkg : erreur de traitement de openoffice.org-thesaurus-de (--remove) :
           le sous-processus post-removal script a retourné une erreur de sortie d'état 127
          Suppression de openoffice.org-thesaurus-de-ch ...
          /var/lib/dpkg/info/openoffice.org-thesaurus-de-ch.postrm: line 6: update-openoffice-dicts : commande introuvable
          dpkg : erreur de traitement de openoffice.org-thesaurus-de-ch (--remove) :
           le sous-processus post-removal script a retourné une erreur de sortie d'état 127
          Des erreurs ont été rencontrées pendant l'exécution :
           openoffice.org-thesaurus-de
           openoffice.org-thesaurus-de-ch
          E: Sub-process /usr/bin/dpkg returned an error code (1)
          
          
  • # --no-remove peut etre

    Posté par (page perso) . Évalué à 1.

    Essaye d'utiliser apt-get avec l'option --no-remove . Pas sur que cela fonctionne vu que le man dit :
    "Quand des paquets doivent être supprimés, apt-get s’arrête immédiatement sans poser de questions."

    Autre potentielle solution : l'option --download-only d'apt-get suivie d'une installation manuelle du .deb (dpkg -i). De meme je ne suis pas sur que cela fonctionne; je ne peux pas tester
    • [^] # Re: --no-remove

      Posté par . Évalué à 1.

      avec --no-remove :
      sudo apt-get install --no-remove openoffice.org
      Lecture des listes de paquets... Fait
      Construction de l'arbre des dépendances       
      Lecture des informations d'état... Fait
      Les paquets supplémentaires suivants seront installés : 
        bsh dictionaries-common libhsqldb-java libjaxp1.3-java libjline-java
        libservlet2.4-java libxalan2-java libxerces2-java openoffice.org-base
        openoffice.org-base-core openoffice.org-calc openoffice.org-common
        openoffice.org-core openoffice.org-draw openoffice.org-filter-binfilter
        openoffice.org-filter-mobiledev openoffice.org-impress
        openoffice.org-java-common openoffice.org-math openoffice.org-officebean
        openoffice.org-style-human openoffice.org-writer openoffice.org-writer2latex
        python-uno
      Paquets suggérés :
        libservlet2.3-java bsh-doc emacsen-common ispell jed-extra
        libhsqldb-java-doc libhsqldb-java-gcj libjline-java-doc
        libservlet2.4-java-gcj libxalan2-java-doc libbsf-java libxsltc-java
        libxerces2-java-doc gstreamer0.10-plugins-bad gstreamer0.10-plugins-ugly
        hunspell-dictionary menu msttcorefonts myspell-dictionary
        openclipart-openoffice.org openoffice.org-gnome openoffice.org-kde
        openoffice.org-help-2.4 openoffice.org-hyphenation openoffice.org-l10n-2.4
        pstoedit libmyodbc odbc-postgresql libsqliteodbc tdsodbc mdbtools
        libmysql-java libpg-java openoffice.org-gcj openoffice.org-report-builder
        openoffice.org-style-hicontrast openoffice.org-style-industrial
      Paquets recommandés :
        bsh-gcj libgcj8-1-awt libjaxp1.3-java-gcj libxalan2-java-gcj
        libxerces2-java-gcj
      Les paquets suivants seront ENLEVÉS :
        openoffice.org-thesaurus-de openoffice.org-thesaurus-de-ch
      Les NOUVEAUX paquets suivants seront installés :
        bsh dictionaries-common libhsqldb-java libjaxp1.3-java libjline-java
        libservlet2.4-java libxalan2-java libxerces2-java openoffice.org
        openoffice.org-base openoffice.org-base-core openoffice.org-calc
        openoffice.org-common openoffice.org-core openoffice.org-draw
        openoffice.org-filter-binfilter openoffice.org-filter-mobiledev
        openoffice.org-impress openoffice.org-java-common openoffice.org-math
        openoffice.org-officebean openoffice.org-style-human openoffice.org-writer
        openoffice.org-writer2latex python-uno
      0 mis à jour, 25 nouvellement installés, 2 à enlever et 62 non mis à jour.
      2 partiellement installés ou enlevés.
      E: Les paquets doivent être enlevés mais la désinstallation est désactivée.
       
      Sinon j'ai telechargé le ;deb et à l'ouverture , j'ai une boite de dialoge disant : Votre système à un problème de dépendances cassés, cette application (GDebi) ne peut pas continuer tant que cela n'est pas réparé....... Bref, pas sorti d'l auberge...
      • [^] # Re: --no-remove

        Posté par . Évalué à 1.

        C'est BON !!!! finallement , j'ai fait un dpkg -i le paquet, suivi d'un sudo apt-get -f install Merci à tous!!!!

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.