Forum Linux.debian/ubuntu Gros problèmes pour l'installation d'une Debian 3.1 Sarge sur un serveur

Posté par  .
Étiquettes : aucune
0
20
juin
2005
Les problèmes en bref :
CDROM introuvable pour être monté à l'installation
Disque dur invisible

C'est sur... c'est tout de suite plus difficile !



Le serveur par lui même:
- Carte mère : Asus P5GDC Deluxe
- Proc : Intel P4
- RAID Hardware : Carte Rocket Raid 1520 Sata
- Disques : 2 disques SATA Ibm 120 Go
- Ram : 1Gb Corsair DDR 533
- CD : Pionner DVD-RW
- Réseau : 2 cartes réseaux 100Mb

Après montage de la machine, pour tester la bête, je met une Mepis 3.3
Et la.. plantage au boot !

Kernel Panic, dès le début. Surprise... Je tente alors avec un System Rescue CD 0.2.2

Pareil !!

Je me dit que cela doit venir de l'optimisation faites sur ces lives distrib (mais je n'y crois pas quand même !)

Bon qu'a cela ne tienne.. je met le 1 cd de la Debian, cela fonctionne,
je choisis la langue, le clavier, jusque la tout va bien... et ensuite ca se complique

j'ai le message
"modprobe -v ide-generic" qui m'indique qu'il est impossible de monter mon CD pour continuer.

Après plusieurs essai, toujours avec le meme message, le menu d'installation change !
Je vois apparaitre la ligne me permettant de partitionner mon disque

Déception encore... il me note : Aucun disque dur n'est disponible.

Bon avec la carte Raid je m'en doutait un peu.

Mais impossible de trouver le moyen de faire reconnaitre la carte Raid ...
Je veux du Raid 1, j'ai déja créer le Array dans le menu du Bios avec les deux durs.

Voila..... je suis bien embété avec tout cela.. d'autant que j'ai mis un windows xp dans la bête histoire de savoir si ce n'était quand même pas un pb hardware.. et cet os tant
méprisé par moi même boot et voit du 1er coup UN disque de 120 Go.. donc tout normal.

Des idées ?


Sébastien Gamier
  • # Un peut rapide mais...

    Posté par  (site Web personnel) . Évalué à 2.

    Je pense que ton raid c'est du 1/2 soft, bref t'as besoin de drivers specifique pour qu'il soit reconnu comme c'est souvent le cas sur les carte raid pas cher.
    Donc deja pour le reconnaitre des le depart c'est pas gagné, je pourrais seulement de conseiller ca : http://www.ubuntuforums.org/showthread.php?t=2557(...) qui donne des conseil sur comment utiliser du raid deja present.

    Sinon il te faut un noyeau qui support le sata si t'es disque sont sur le sata sinon tu les verra pas, voir même qui support le controlleur Rocket Raid 1520.

    Voila. Tu peut toujours regarder si la knoppix elle le reconnais ou pas.
    • [^] # Re: Un peut rapide mais...

      Posté par  . Évalué à 0.

      Donc il me reste 2 solutions :

      - Rendre cette carte et prendre une vraie carte 100% RAID hardware SATA (j'en connais pas ? Et vous ?)
      - Rendre cette carte et faire du raid Software avec Linux...

      Le pb du cdrom non montable est-t'il lié ?

      Sébastien Gamier
      • [^] # Re: Un peut rapide mais...

        Posté par  (site Web personnel) . Évalué à 0.

        Carte 3ware ou adaptec...

        C'est cher mais supporté a 100%...
      • [^] # Re: Un peut rapide mais...

        Posté par  (site Web personnel) . Évalué à 2.

        Je ne pense pas que le probleme du CD soit liée, enfin pas totalement.
        En fait le probleme du CD pourrait venir d'un noyeau un peut trop vieux qui ne supporte pas ton controlleur ide potentiellement trop recent mais c'est a voir.

        Pour savoir c'est bien un CD sarge que t'a pris (la stable actuelle) et pas un vieux woody?
        T'a regarder ce que donne une knoppix?
  • # Même problème sur Mandrake 10.1

    Posté par  (site Web personnel) . Évalué à 1.

    J'ai eu un problème similaire sur une Mandrake 10.1 (kernel 2.6.9) et une config Serial ATA. L'installation était tout-à-fait possible en 2.4 et c'est ce qui a été fait.
    Avec la Mandriva (kernel 2.6.11), il n'y a plus de problème.

    Le nommage des disques SATA a changé à partir du 2.6.3. Ils étaient nommés comme des IDE (hda) alors que depuis ils sont reconnu en SCSI (sda).

    Donc : vois si tu peux essayer avec un noyau > 2.6.9 ou un 2.4.
  • # Probleme classique avec le raid et le sata

    Posté par  . Évalué à 3.

  • # Essaye avec un vrai CD de Debian

    Posté par  (site Web personnel) . Évalué à 2.

    Ensuite teste avec un kernel 2.4 et un kernel 2.6...

    Si tu as toujours des soucis reposte les différences de comportement entre les 2 kernel (oui, oui on peut sélectionner le kernel que l'on souhaite installer sous Debian)
    • [^] # Re: Essaye avec un vrai CD de Debian

      Posté par  . Évalué à 0.

      Merci pour tout ces conseils.

      J'ai essayé avec install en 2.4 ou en 2.6 ... idem.

      Je me disais donc que la meilleur solution pour moi serait donc de prendre une carte comme celle ci

      SCSI - Adaptec 39320A-R RAID

      C'est sur les prix n'ont rien à voir mais c'est pour le serveur d'une entreprise.

      Et il me faut des disques scsi.

      D'après ce que je comprend avec cela je créé mon Raid au niveau du Bios, et je ne verrais donc plus qu'un seul disque scsi pour mon install ?

      Je veux bien essayer avant la Knoopix, mais en admettant que cela fonctionne, comment vais-je ensuite faire pour installer la Debian (La toute derniere la 3.1 Sarge ?)

      J'ai vu qu'il y avait aussi des solutions de création de noyau offsite en intégrant le module prenant en charge la carte... pfiou.. cela me semble bien compliqué.



      Sébastien Gamier
      • [^] # Re: Essaye avec un vrai CD de Debian

        Posté par  . Évalué à 1.

        Je ne peux pas tester chez moi mais essaie ça :
        boote avec le CD de Debian
        tape linux26 pour forcer l'installe en 2.6.8
        et une fois la langue et le pays choisis au lieu de faire continuer tu choisis retour
        Normalement (si ma mémoire est bonne) tu tombe sur la liste des taches à faire pour l'installation. Tu peux alors choisir de lancer une console dans laquelle tu tapes :
        modprobe ata_piix
        pour forcer l'insertion de ce module
        (malheureusement j'ai pas accès à mon pingouin favoris donc je ne suis pas certains que ce soit le bon module. Il y a peut etre un module qui s'appele megaraid qu'il peut etre interessant de charger)

        Si ça marche tu peux sortir de la console et continuer l'installation

        Si par chance l'installation se passe bien il peut y avoir des problèmes au reboot mais c'est une autre histoire


        Si la knoppix fonctionne tu peux lancer l'installeur, c'est un fichier executable qui se trouve sur le CD dans un des repertoires


        enfin essaie l'iso que l'on peut trouver sur
        http://wiki.osuosl.org/display/LNX/Debian%20on%20Dell%20Servers(...)
        et fait un apt-get dist-upgrade pour passer de la woody à la sarge :) (après avoir verifie le sources.list)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.