Forum Linux.debian/ubuntu Kubuntu drivers graphiques

Posté par (page perso) .
Tags : aucun
-1
25
oct.
2009
Bonjour à tous,

Cela fait près de 7 mois que j'attends pour que mon problème se résolve par lui même mais je ne vois rien changer.

- J'utilise une Kubuntu Jaunty à jour.
- J'utilise KDE 4.2
- Et voici ma carte graphique :

$ glxinfo | grep -i direct; grep -i radeon /var/log/Xorg.0.log | grep Chipset

direct rendering: Yes
(--) fglrx(0): Chipset: "ATI Radeon HD 3600 Series " (Chipset = 0x9598)


Voici mon Xorg :

Section "ServerLayout"
Identifier "aticonfig Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:4:0:0"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Modes "1600x1050@60"
Viewport 0 0
Depth 24
EndSubSection
EndSection


Et enfin, voici mes deux problèmes :
1) Lorsque je vais dans "Configuration du système" -> "Bureau" -> "Options avancées" -> "OpenGL" et que j'applique les changements, j'obtiens "Impossible d'activer les effets de bureau avec ces options de configuration".

Tout ce que je souhaite c'est d'activer les effets et bien sûr qu'ils soient pris en charge par la carte graphique. Que dois-je changer ?

2) Lorsque je démarre ma machine, je démarre avec une petite résolution, on dirait du 800x600 ou plus petit encore.

Que dois-je changer pour que mon système démarre en 1600x1200 avec déjà les effets 3d activés ?


J'ai essayé en installant les drivers fourni par ma distrib et aussi en téléchargeant ceux fourni par AMD mais je ne sais pas quoi changer dans xorg pour qu'ils soient utilisés.


Pouvez-vous m'aider SVP ?
Merci beaucoup.
  • # au hazard sur internet

    Posté par . Évalué à 4.

    1°) ajouter l'option vga=798 sur ta ligne de boot grub (grub 1.x)
    798 etant un code de resolution vga
    http://manual.sidux.com/fr/cheatcodes-vga-fr.htm

    2°) merci qui ?

    merci google fglrx compiz jaunty 8e lien
    http://blog.klauskiwi.com/archives/24
  • # Résolution partielle

    Posté par (page perso) . Évalué à 1.

    Pour ceux qui tombent ici suite à une recherche, voici une partie de la résolution. En espérant que ça puisse vous aider. Pour info, ça concernait Jaunty mais également Karmic (que je viens d'installer).


    Maintenant, lorsque je démarre ma machine, kdm démarre avec la bonne résolution - Youpie!

    J'ai l'impression que le simple fait d'avoir supprimé @60 dans la ligne
    Modes "1600x1050@60"
    résout le problème. Je ne me rappelle plus avoir changé autre chose.

    J'ai dû redémarrer ma machine pour me rendre compte de cela.
    À essayer donc.


    L'autre problème persiste en mettant "OpenGL" j'ai essayé avec les drivers propriétaires et les drivers radeonhd. Si je mets xrender, ça fonctionne mais ça ne me semble pas accéléré, lorsque je redimensionne ma fenêtre c'est extrêmement lent/saccadé.
    • [^] # Re: Résolution partielle

      Posté par (page perso) . Évalué à 1.

      Et voilà la suite de la résolution que je viens de trouver.

      Pour pouvoir utiliser OpenGL et donc utiliser tous les effets 3D, il suffit de mettre :
      - Mode OpenGL = Texture à partir d'une image

      Pour le reste, j'ai :
      - Conserver les miniatures des fenêtres = Seulement pour les fenêtres affichées.
      - Filtre de texture = Bilinéaire
      - Activer le rendu direct
      - Utiliser Vsync


      Voilà, en espérant que ça aide quelqu'un :)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.