Forum Linux.debian/ubuntu Password root

Posté par  .
Étiquettes : aucune
0
21
oct.
2004
Bonjour,

Est-ce que c'est possible de changer le mot de passe du root
car je ne m'en souviens plus (lol !!!!)

j'ai crée un autre compte (rootsav) appartenant au groupe root
donc pour l'instant je m'en sort comme ca mais c'est pas le top.

est-ce que je peux réinitialiser le mot de passe du compte root à partir du compte rootsav.

Si oui quelle est la commande ? merci

@++
  • # Ben...

    Posté par  . Évalué à 3.

    Si t'as un compte avec acces root, t'edites le fichier shadow et tu vires/change le mot de passe.

    Si t'as pas acces, tu bootes sur un autre CD, tu montes la partition / et tu fais de meme.
  • # Facile

    Posté par  . Évalué à 3.

    Tu as certainement une distrib standard installée de façon standard...

    Deux cas :
    1) si tu as Lilo en mode graphique, reboote en mode "failsafe" (c'est le nom sous Mandrake);
    2) Si tu as Grub, édite la ligne de commande lors du boot, remplace le "5" final par un "1", et boote.

    Dans les deux cas de figure, après avoir fait ça, tape "passwd", et entre le nouveau mot de passe root qui te plait.

    A+!
    • [^] # Re: Facile

      Posté par  . Évalué à 1.

      En faite j'ai debian
      et j'ai la prompt d'entrée en session

      donc à ce niveau il faut que j'entre un login

      et je n'utilise pas d'interface graphique
      c'est tout en mode texte (console)

      Merci
      • [^] # Re: Facile

        Posté par  . Évalué à 3.

        non tu boote en "linux single" et il va te donner un shell minimum sous root
        Te reste plus qu'a faire "passwd" et mettre ce que tu veux
        • [^] # Re: Facile

          Posté par  . Évalué à -1.

          et comment faire ton pour booter en linux single ?????
        • [^] # Re: Facile

          Posté par  (site Web personnel) . Évalué à 2.

          ca ca marche pas partout, sur certaines distro il te demande tjrs le passwd ;)
          • [^] # Re: Facile

            Posté par  . Évalué à 2.

            >ça, ça marche pas partout, sur certaines distro il te demande tjrs le passwd ;)

            ???

            Ca me surprend. Sur d'autres UNIX, c'est vrai, mais sous Linux, je n'ai jamais vu ça.

            Bon, si c'est le cas, booter directement en Single, sans passer par le niveau 1, devrait résoudre le problème. Si ça ne marche toujours pas, ajouter "init=/bin/sh" à la ligne de commande du boot devrait marcher (mais c'est assez violent, comme méthode).
            • [^] # Re: Facile

              Posté par  (site Web personnel) . Évalué à 2.

              > sous Linux, je n'ai jamais vu ça.

              Si on parle bien de la même chose, c'est le cas sous Debian, pourtant.

              ("Enter root password for maintainance, or Control-D for normal startup: " ou quelque chose comme ça.)
              • [^] # Re: Facile

                Posté par  . Évalué à 3.

                >"Enter root password for maintainance, or Control-D for normal startup: "

                Ha oui, mais non, ça, ce n'est pas un boot en runlevel 1, c'est un échec du montage de la partition root (ce qui se produit typiquement lorsque l'on éteint brutalement une machine et que le système de fichiers de la partition racine n'est pas journalisé).
                • [^] # Re: Facile

                  Posté par  (site Web personnel) . Évalué à 2.

                  > Ha oui, mais non, ça, ce n'est pas un boot en runlevel 1, c'est un échec du montage de la partition root

                  Ben chez moi, c'est les deux. D'ailleurs, si mes souvenirs sont bons, "init 1" redemande le mot de passe root.
                  • [^] # Re: Facile

                    Posté par  (site Web personnel) . Évalué à 2.

                    Dans ce cas tu lances linux avec
                    init=/bin/sh
                    en paramètre de lilo,
                    tu remontes la partition / en rw
                    mount -oremount /
                    et tu change le mot de passe:
                    passwd
                  • [^] # Re: Facile

                    Posté par  . Évalué à 2.

                    >Si mes souvenirs sont bons, "init 1" redemande le mot de passe root.

                    Heu, tu parles de quoi? Pour taper "init 1", il faut effectivement être root, en revanche, si tu bootes directement en runlevel 1, alors là, non, il n'y a pas de demande du mot de passe root. Je l'ai encore vérifié cette semaine sur un (futur) serveur de prod'.
                    • [^] # Re: Facile

                      Posté par  (site Web personnel) . Évalué à 2.

                      > Pour taper "init 1", il faut effectivement être root,

                      Oui, mais le "init 1" tu le shell dans lequel tu te trouves.

                      Bon, faudra que je reteste ça de chez moi. Je n'utilise pas ça très souvent et j'ai la mémoire courte ;-)

                      > Je l'ai encore vérifié cette semaine

                      Sur quelle distrib' ? Je parle de Debian, mais à une époque, j'étais sous Red Hat, et effectivement, il ne demandait pas le mot de passe.

                      (par contre, il n'y a pas de mot de passe sur mon lilo, ça je suis sur !)
                      • [^] # Re: Facile

                        Posté par  . Évalué à 2.

                        >Oui, mais le "init 1" tu le shell dans lequel tu te trouves.

                        s/shell/tapes dans le shell/g, je suppose...

                        Oui et non, si je veux descendre en runlevel 1, il me faut effectivement un shell, si je veux démarrer en runlevel 1, il me suffit de retoucher ma ligne de commande de boot.

                        >Sur quelle distrib' ?

                        Une Redhat, effectivement. Ca vaut aussi pour Mdk, mais je n'ai jamais testé sous Debian.
                        • [^] # Re: Facile

                          Posté par  (site Web personnel) . Évalué à 2.

                          > s/shell/tapes dans le shell/g, je suppose...

                          Ahem, non: "tu", du verbe "tuer" ;-) Bon, c'était vendredi soir, ma touche "e" était toute rouillée, toussa, ...

                          Sinon, je viens de revérifier. Sous Debian (unstable), j'ai bien

                          * linux 1 dans le prompt LILO boote puis demande le mot de passe root
                          * init 1 dans un shell passe en runlevel 1, en tuant en particulier le shell dans lequel on se trouve, et redemande le mot de passe
                          * Par contre, linux init=/bin/sh dans LILO ne demande rien et ouvre un shell root.
                  • [^] # Re: Facile

                    Posté par  . Évalué à 1.

                    Remarque : il ne faut pas confondre le mot de passe root et l'éventuel mot de passe protégeant le chargeur de démarrage... Je pense que c'est de là que vient la confusion :-) .
  • # Solution plus simple et moins agressive.

    Posté par  (site Web personnel) . Évalué à 6.

    Hello, si tu n'est pas un crack dans l'edition du shadow, tu peux faire ceci:

    Te procurer, graver et booter sur une knoppix (ou équivalent).
    Une fois dans ton environnement, ouvre un shell (par exemple Konsole sous Knoppix). Tu tapes:
    su <-- Tu vas être en root
    mkdir /mnt/MonDebian <-- Créer un point de montage
    mount /dev/XXX /mnt/MonDebian <-- Ou XXX est la partition racine de ta Debian sur ton disque.
    chroot /mnt/MonDebian /bin/bash <-- Chrooter dans ton système
    passwd
    Enter password: TON NOUVEAU MOT DE PASSE ROOT
    Confirm password: REPETE TON MOT DE PASSE
    exit <-- Quitter le chroot
    umount /mnt/MonDebian <-- Démonter ton Debian
    init 0 <-- Eteindre le PC

    Et ton mot de passe devrait être changé!!!
  • # lilo

    Posté par  (site Web personnel) . Évalué à 2.

    si tu as lilo et que Linux est ton étiquette entre ça au boot:
    Linux init=/bin/bash

    ça va booter et tu vas attérir dans un shell en tant que root.
    tu dois maintenant remounté le root en lecture/écriture, tape ceci:
    mount -o remount,rw /

    si ça fait une erreur, lis plus bas¹.

    tu n'as plus qu'à changer le mot de passe avec la commande "passwd".

    ¹ si l'erreur chiale à propos de LABEL, tu dois tout d'abord trouver quel est la device de ton root, tape "df" et regarde ce qui est à côté de / .

    si t'es paresseux: df | head -n 2 | tail -n 1 | sed -e "s/\(\/dev\/\w\+\).\+/\\1/"

    si c'est /dev/hda6, tape ceci:
    mount -o remount,rw /dev/hda6 /

    tu peux maintenant taper "passwd"
  • # autre solution

    Posté par  (site Web personnel) . Évalué à 4.

    autre solution: utiliser john pour craquer ton mdp root. Si tu as mis un mauvais mot de passe, il te le trouvera rapidement, et ça t'apprendra à en mettre un meilleur pour la prochaine fois :-/
    • [^] # Re: autre solution

      Posté par  (site Web personnel) . Évalué à 2.

      Et comment tu récupères le hash du mdp root si t'es pas root ?

      pertinent adj. Approprié : qui se rapporte exactement à ce dont il est question.

  • # booter linux en singleuser

    Posté par  (site Web personnel) . Évalué à 1.

    déjà écrit plus haut, je fais la version abrégée :
    au moment du boot (lilo)

    s'affiche :
    LILO (plus ou moins longtemps selon tes options)
    appuyer (éventuellement avant, se préparer) sur Shift Controle ou Alt.

    saffiche alors
    LILO :
    (les ":" font toute la différence)

    appuyer sur tab pour savoir quoi taper.(souvent linux, ou debian...)

    alors taper "debian" (exemple) ET "s"
    LILO : debian s
    ou singleuser (je sais plus)

    ça va booter et tu seras root.

    alors tape "passwd" et change ton mot de passe.

    sinon, la commande passwd root fera ce que tu veux SI TU EN AS LES PERMISSIONS.

Suivre le flux des commentaires

Note : les commentaires appartiennent à celles et ceux qui les ont postés. Nous n’en sommes pas responsables.