Forum Linux.debian/ubuntu plugdev

Posté par (page perso) .
Tags : aucun
0
6
juin
2008
Bonjour à tous,

Je voudrais comprendre quelque chose qui m'échappe totalement.
Je me suis rajouté au groupe "plugdev" pour pouvoir utiliser mon appareil photo.

Mais lorsque je tape (en utilisateur) :
$ groups
J'ai
anakin dialout cdrom floppy audio video camera fuse

Par contre si je tape en root :
# groups anakin
J'ai
anakin dialout cdrom floppy audio video camera fuse plugdev

Étrange non ?
Pourquoi mon utilisateur ne se voit pas dans le groupe plugdev ?

Merci pour vos éclaircissements.
  • # Redémarrer la session

    Posté par . Évalué à 5.

    Pour que le changement de groupe marche, il faut redémarrer sa session.

    Le plus rapide pour vérifier c'est d'ouvrir une nouvelle console (ctrl+alt+F2 par exemple) et vérifier.

    Sinon, au cas où... La commande pour s'ajouter dans un groupe est :
    adduser toi ton_groupe

    (ou adduser ton_goupe toi mais je crois que c'est bien adduser toi ton_groupe)
    • [^] # Re: Redémarrer la session

      Posté par (page perso) . Évalué à 1.

      Ah en effet, c'était juste ça !
      Merci
    • [^] # Re: Redémarrer la session (ou pas)

      Posté par (page perso) . Évalué à 2.

      Une autre solution consiste à faire "newgrp plugdev", qui considèrera dès lors que ton groupe principal (celui utilisé lorsque tu créés des fichiers) est plugdev, et te permettra d'accéder aux fichiers du groupe plugdev sans avoir besoin de redémarrer ta session.

      Pour revenir en mode normal tout en conservant ton "droit" de groupe plugdev, tu fais un newgrp, sans nom de groupe cette fois, ce qui reprend ton groupe par défaut.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.