Forum Linux.debian/ubuntu Port jack sur Azus x205ta

Posté par  . Licence CC By‑SA.
Étiquettes :
0
22
oct.
2020

Bonjour,

J'ai récemment installé la dernière version de Xubuntu sur un pc Asus Eeebook et tout fonctionne correctement excepté que lorsque je branche un casque, une enceinte ou autre sur mon port jack, ils ne sont pas pris en compte et le son continue de sortir des hauts parleurs intégrés de l'ordinateur.

Lorsque je regarde PulseAudio il indique "Headphones unplugged" dans les périphériques de sortie et quand je regarde l'onglet configuration : pour nom de la carte j'ai toute une liste mais tout est en unplugged unavailable et c'est "éteint" qui est sélectionné, ensuite dans l'onglet audio interne c'est sur "default".

J'ai cru comprendre que je devrais essayer d'installer ceci : alsa-lib-x205taAUR via le lien https://wiki.archlinux.org/index.php/ASUS_x205ta#Sound

mais je ne sais pas comment procéder pour ça

Help s'il vous plait !

  • # Pas explicite en effet

    Posté par  . Évalué à 1 (+0/-0).

    Hello,

    Il faut que tu ouvres le fichier /etc/modprobe.d/50-x205ta.conf et que tu ajoutes ces informations sur une ligne options snd_soc_rt5645 quirk=0x31

    Pour cela, avec l'éditeur nano nano /etc/modprobe.d/50-x205ta.conf et puis ensuite tu copies/colles options snd_soc_rt5645 quirk=0x31 sur une nouvelle ligne

    Il est possible que ce fichier n'existes pas, il est alors demandé implicitement de le créer

    Tu nous dis si ça fonctionne comme attendu ?
    :-)

    Julien_c'est_bien (y'a pas que Seb)

    • [^] # Re: Pas explicite en effet

      Posté par  . Évalué à 1 (+1/-1). Dernière modification le 23/10/20 à 17:22.

      Bonjour,

      J'ai crée un fichier via Nano, je l'ai nommé /etc/modprobe.d/50-x205ta.conf et dedans j'ai copié options snd_soc_rt5645 quirk=0x31

      mais quand je veux l'enregistrer un message d'erreur me dit "impossible d'enregistrer permission non accordée"

      qu'est-ce que j'ai mal fait ?

      • [^] # sudo

        Posté par  . Évalué à 2 (+0/-0).

        Bonjour,

        Il faut être root (administrateur) pour pouvoir écrire dans les répertoires du système.

        Utilise sudo, qui permet de lancer une commande en tant que root : sudo nano /etc/modprobe.d/50-x205ta.conf

        Frаnсе : 50957, Allеmаgnе : 15586. Масrоn : 35371.

        • [^] # Re: sudo

          Posté par  . Évalué à 1 (+0/-0).

          Désolé je suis débutant sur linux, donc je ne comprends pas encore tout :

          j'ai utilisé la commande avec sudo, ensuite cela ouvre une sorte une fenêtre qui semble être un mix entre nano et un terminal, mais quand j'ai inscrit dedans la ligne "options snd …" que dois-je faire ensuite, je ne peux pas enregistrer et si je veux fermer la fenêtre cela me dit qu'un processus est en cours

          • [^] # Éditeur

            Posté par  . Évalué à 3 (+1/-0).

            nano est un éditeur qui fonctionne uniquement dans un terminal texte.

            Un éditeur graphique serait plus facile à utiliser, le tout étant d’en choisir un qui est installé sur ton système.

            Sur Xubuntu, tu devrais avoir Mousepad d’installé, et donc pouvoir lancer : sudo mousepad /etc/modprobe.d/50-x205ta.conf

            Sinon, avec nano, tu fais Ctrl+X pour sortir, il te propose de sauvegarder, tu tapes o pour oui et Entrée pour approuver le nom du fichier.

            Frаnсе : 50957, Allеmаgnе : 15586. Масrоn : 35371.

            • [^] # Re: Éditeur

              Posté par  . Évalué à 1 (+0/-0).

              Ok là c'est bon pour moi, j'ai lancé mousepad avec un terminal en mode root, j'ai tapé la ligne "options snd…" et j'ai enregistré le fichier.

              Et maintenant ?

              (rien n'a changé pour l'instant sur mon problème en tout cas en apparence)

              • [^] # Pilote

                Posté par  . Évalué à 3 (+1/-0).

                Le pilote ne prend pas en compte le changement de ce fichier à la volée, juste à son chargement.

                Ce qui arrivera si tu redémarres.

                Si ce n’est pas mieux après, exécuter dans un terminal lsmod | grep snd_soc_rt5645 te permettra de voir si le pilote est chargé.

                S’il ne l’est pas, sudo modprobe snd_soc_rt5645 essaiera de le charger… s’il est bien présent dans le noyau.

                Frаnсе : 50957, Allеmаgnе : 15586. Масrоn : 35371.

                • [^] # Re: Pilote

                  Posté par  . Évalué à 1 (+1/-1).

                  Super c'était ça ! J'ai redémarré et maintenant j'ai l'option headphones (plugged in) et non plus "unplugged" merci beaucoup !

                  Juste une dernière chose, le changement lorsque je branche un casque ou autre ne se fait pas automatiquement, je dois changer l'option manuellement, est-ce que c'est normal ou est-ce que je peux le rendre automatique ?

                  merci encore !

                  • [^] # Sélection

                    Posté par  . Évalué à 3 (+1/-0).

                    D’après la documentation d’Arch Linux, ce n’est effectivement pas automatique, il faut utiliser l’utilitaire de paramétrage du son de Pulseaudio (il faut fouiller un peu pour trouver l’endroit où configurer la sortie) :

                    To select headphones over speakers (which cannot be done automatically as of kernel 4.14) consider using pavucontrol.

                    S’il n’est pas installé, sudo apt install pavucontrol devrait faire l’affaire.

                    Frаnсе : 50957, Allеmаgnе : 15586. Масrоn : 35371.

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.