Forum Linux.debian/ubuntu Problème d'affichage graphique

Posté par  .
Étiquettes : aucune
0
12
juin
2008
Bonjour,

Mon pc portable à un soucis au niveau de l'écran, j'ai branché dessus un écran externe et depuis ma mise à jour de ubuntu 7.04 -> 7.10, lors de l'ouverture de la session gnome, je n'ai plus rien (écran noir).
Je vois toute la phase de boot et même l'écran d'authentification, mais à l'ouverture de session... plus rien. Par contre j'ai toujours accès à la console...
(le meme problème se pose sous XP ou je perd l'écran lors de la page d'acceuil)
En bootant sur un live-cd ubuntu 7.04, là, ça marche nickel.

Avez vous déjà vu ce problème et/ou voyez vous d'où pourrait provenir le problème ?
Je vais chercher au niveau du xorg.conf (les différences entre celui du live-cd en 7.04 et celui de la 7.10 installée) mais je vois pas trop ce qui pourrait poser problème...

Merci de vos réponses,
Corto
  • # probleme de configuration

    Posté par  . Évalué à 2.

    visiblement ca marche en 7.04
    mais pas en 7.10 ni avec un autre OS (windows)

    le probleme peut donc venir :
    - de la configuration (xorg.conf ou windows) qui demanderait trop par rapport à la carte
    - du driver (driver trop recent ? options non supportées ?), par exemple le livecd demarre peut-etre avec le driver generic de ta carte graphique (vesa par exemple)

    d'ailleurs tu ne nous dis pas ce que c'est comme carte graphique
    intel, nvidia, ati ?

    car (helas) à chacune sa specialité et ses "bugs"
    • [^] # Re: probleme de configuration

      Posté par  . Évalué à 1.

      Merci pour ce début d'explication.

      Le portable est un ASUS M6Ne (de mémoire) avec une carte Ati radeon 9600. Un modèle centrino standart (512 de ram, 60 Go de DD)

      Ce qui m'étonne dans cette histoire c'est que l'affichage sur écran externe fonctionnait tres bien avant que je ne casse l'écran du pc... Ca élimine le problème de driver au moins sous XP puisque celui-la n'a pas changé.
      • [^] # Re: probleme de configuration

        Posté par  . Évalué à 2.

        donc pour resumer

        avant tu avais le LCD du portable + un ecran externe.

        aujourd'hui l'ecran interne (LCD) ne fonctionne plus.

        et tu veux tout envoyer sur l'ecran externe ?

        rien de plus simple, et cela explique peut-etre tes soucis.

        par defaut (et suivant les distributions), seul l'ecran primaire s'active (le LCD)
        si celui ci ne marche plus il faut alors une combinaison de touche pour dire que l'ecran primaire c'est l'autre

        ensuite ca devrait aller tout seul
        • [^] # Re: probleme de configuration

          Posté par  . Évalué à 1.

          C'est la ou je ne comprend pas...
          Quand on branche un écran externe avant de démarrer le portable (sur ce modèle), il passe automatiquement en primaire et cela fonctionnait bien avec la 7.04
          Sous XP j'ai essayé les combinaisons de touches sans succès...

          Pourquoi l'écran est bien en primaire durant toute la phase de boot et plus après...
          • [^] # Re: probleme de configuration

            Posté par  . Évalué à 1.

            simplement parceque dans la phase de boot c'est le hardware qui gere
            apres c'est le driver....

            enfin dans la 7.04, il utilise peut-etre le mode vesa par defaut, ce qui fait que tu as en fait un clone sur les deux ecrans (ce qui pour toi ressemble en fait à l'ecran primaire)
            • [^] # Re: probleme de configuration

              Posté par  . Évalué à 1.

              Apres quelques recherches complémentaire sur le site ubuntu, j'ai trouvé ca :

              Blank screen with some ATI hardware
              * People with ATI display adapters may get a blank screen when loading X due to the driver being unable to initialize certain hardware. Upstream is working on it, and hopefully we'll be able to release an update for 7.10 soon after the release. In the meantime, add 'Option "LVDSBiosNativeMode" "false"' to the driver section of xorg.conf. Bug #132716


              Tu dois avoir raison... je vais faire les tests ce soir ;)

              Merci,
              Corto

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.