Forum Linux.debian/ubuntu Problème de serveur de son sous SID

Posté par .
Tags : aucun
0
29
oct.
2004
Bonjours,

Mon problème semble relativement simple à régler mais je ne trouve pas la solution.

Depuis quelque temps, il m'est impossible de garder activé le serveur de son de gnome (pour les événements) si je veux lancer ET ou Quake. En effet, si ce serveur est activé, le jeu freeze au lancement (le log me dit que cela ce passe au moment de l'initialisation du son)

Donc, la solution que j'utilise pour résoudre ce problème est de désactivé le serveur de son, mais évidemment, cela ne me satisfait pas.

Le plus étonnant, est que cela à marché parfaitement pendant longtemps Mais comme je suis un joueur très occasionnel, je ne peux pas établir de façon précise le moment ou cela à commencé.

Si vous avez des idées pour résoudre ce problème je suis preneur.
Merci.
  • # Re prb de son

    Posté par . Évalué à 2.

    Salut, dis voir, tu es sous SID, certes mais encore sous 2.4 ou 2.6.x ? Et tu utilise OSS ou ALSA ?
    Si tu es souss OSS essaie de compiler un noyau 2.6 avec le support ALSA et alors normalement ca devrait resoudre ton prb, sinon je vois pas.
    • [^] # Re: Re prb de son

      Posté par . Évalué à 2.

      'lut
      Je suis sous 2.6.x et ALSA.
      Ce qui m'étonne c'est que cela fonctionnait parfaitement il y a quinze jours ou trois semaines.
      Tu crois vraiment que le problème vient du noyau ? Car le son fonctionne bien sous ET et Quake, mais uniquement quand le serveur de son sous gnome est désactivé.

      Merci pour ton idée, je vais donc compiler un nouveau noyau pour vérifier.
  • # configuration esd

    Posté par . Évalué à 4.

    Il est possible de configurer esd pour lui demander de libérer la carte son arès tant de secondes d'inactivités :

    http://www.delafond.org/traducmanfr/man/man1/esd.1.html(...)

    esd [options]
    -as SECS libère le dispositif audio après SECS seconds d'inactivité

    J'avais déjà testé cela à l'époque où j'avais des soucis avec alsa, cela marchait bien.

    Si quelqu'un a réussi à faire marcher le son sous Quake3 et une carte son via82xx (carte son intégrée sur CM MSI-KT3), je suis preneur, j'avais abandonné il y a quelques mois :/
  • # esddsp ?

    Posté par . Évalué à 2.

    Salut, peut être devrais tu utiliser le programme esddsp pour lancer quake (ou tout autre programme qui bloque sur les périphériques audio, et qui ne connait pas esd).
    Pour résumer esddsp "intercepte" et reroute les accès au périphérique audio.
    Il a une page de manuel qui te décrit quelques options.

    Après, faut voir si l'utilisation de la surcouche "esd" ne pénalise pas trop ton jeu en terme de perf. ... ;)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.