Forum Linux.debian/ubuntu problème gconf

Posté par  .
Étiquettes : aucune
0
27
mar.
2008
Bonjour,


Je viens d'installer une Debian Etch. Installation sans problème mais quand j'ai voulu bidouiller Gconf pour configurer Nautilus, j'ai perdu mon bureau. Pour etre plus explicite, je n'ai plus d'icones sur le bureau, j'ai juste l'image d'arrière plan, et quand je fais un clique droit sur le bureau, ça ne fait rien. Voici les clés que j'ai modifié dans Gconf :

apps -> nautilus -> preferences -> always_use_browser=1
apps -> nautilus -> preferences -> always_use_location_entry=1
apps -> nautilus -> preferences -> enable_delete=1

Les tests/vérifs que j'ai fait suite à ce problème :

1/ Tout est normal dans apps -> nautilus -> desktop
2/ J'ai créé un nouvel utilisateur et son bureau est normal
3/ Quand je vais dans le "moniteur système", je ne vois aucun processus "nautilus" quand je suis avec le premier utilisateur, alors que je vois ce processus quand je suis sous le deuxième utilisateur
4/ j'ai forcé une réinstallation de gconf, nautilus et gnome-session

Rien de tout ça n'y a fait... et je ne sais pas trop d'ou viens le problème (Nautilus ou Gconf) meme si je soupçonne fortement Nautilus

Est-ce que quelqu'un a une idée ??

--
Rénald.
  • # nautilus pas lancé par la session

    Posté par  . Évalué à 1.

    ca ressemble au fait que tu as desactivé le lancement automatique de nautilus.

    apres comment retrouver ce reglage ?
    c'est un autre probleme.
    • [^] # Re: nautilus pas lancé par la session

      Posté par  . Évalué à 1.

      Ca me parait etre un bon diagnostique, mais quand la session s'ouvre, Nautilus apparait bien. (je parle de la petite fenetre qui s'affiche à l'ouverture d'une session et qui affiche les services au fur et à mesure qu'ils se lancent, dont Nautilus)

      En plus, suite à ton conseil j'ai essayé de rajouter Nautilus dans le menu "Bureau -> Préférences -> Sessions" onglet "Programmes au démarrage", mais rien n'y fait.
      • [^] # Re: nautilus pas lancé par la session

        Posté par  (site Web personnel) . Évalué à 1.

        Et si tu lances nautilus dans un terminal, ça donne quoi?

        A mon avis tu vas voir l'erreur qui l'empêche de se lancer...
        • [^] # Re: nautilus pas lancé par la session

          Posté par  . Évalué à 1.

          Si je tape $ nautilus dans un terminal, il me lance un navigateur nautilus comme si je faisais un double-clic sur mon répertoire perso. C'est d'ailleur un peu ce qui me sauve et qui me permet de travailler à peu près normalement.
      • [^] # Re: nautilus pas lancé par la session

        Posté par  . Évalué à 1.

        de memoire si nautilus n'est pas lancé tu n'as pas les barres de menu...

        il doit donc s'agir d'une option qui "masque" les icones du bureau
        ou simplement tu n'as peut-etre rien a afficher sur le bureau

        perso j'ai mes dossiers sur lesquels je travaille, il se retrouve dans
        /home/user/Desktop/
        ou
        /home/user/Bureau/

        et les disques montés par gnome-vfs et mtab
        • [^] # Re: nautilus pas lancé par la session

          Posté par  . Évalué à 1.

          J'ai la barre de menu qui s'affiche normalement.

          Il y a des fichiers dans /home/user/Desktop.

          Les icônes du bureau sont configurées dans Gconf pour etre visibles.

          Je rappelle aussi que quand je fais un clic droit sur le bureau il ne se passe rien, alors que je devrais avoir un menu qui me propose "Créer un dossier ; Créer un document ; Changer l'arrière plan du bureau" entre autre.

          Je suis dans l'impasse...
          • [^] # Re: nautilus pas lancé par la session

            Posté par  . Évalué à 1.

            C'est l'option /apps/nautilus/preferences/show_desktop qui indique à
            Nautilus s'il doit ou pas gérer le bureau ...

            A vérifier avec gconf-editor.
            • [^] # Re: nautilus pas lancé par la session

              Posté par  . Évalué à 1.

              La clé /apps/nautilus/preferences/show_desktop avait déjà pour valeur "1", mais en la mettant à "0" puis à nouveau à "1" en ligne de commande, ô miracle, mes icônes sont revenues de vacances. Par contre, le problème est aléatoire : j'ai continué à bidouiller cette même clé, toujours en ligne de commande et à un moment donné il a fallu que je redémarre la bête pour que les icônes apparaissent.

              Bref, le problème est résolu mais c'est un bug et je trouve que ça la fout mal pour une Debian.

              Merci à tous pour votre aide.


              --
              Rénald

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.