Forum Linux.debian/ubuntu Problème de connexion ssh entre deux pc en réseau local sous wifi (resolu)

Posté par . Licence CC by-sa.
0
16
oct.
2018

Bonjour,

Je vous soumets ce problème de connexion ssh entre deux pc sur réseau local par wifi.

J'ai un pc sous debian stable qui se connecte au réseau par wifi via un routeur dd-wrt, il utilise une interface wifi ath1 du routeur dans la bande 2,4 Ghz.

J'ai un serveur de fichiers sous debian stable qui est connecté au réseau par wifi en passant par une autre interface ath0 du routeur sur la bande 5 Ghz.

Je synchronise des fichier ente les deux machines avec unison via ssh.

Le problème sur lequel je sèche est le suivant parfois la connexion ssh fonctionne bien et je synchronise correctement.

Parfois la connexion ssh ne s'établit pas et le pc destination ferme la connexion après un temps d'attente.

ssh -vvv donne comme dernière information :
debug 1 SSH2_MSG_KEXINIT sent

là interruption des échanges entre les deux machines et arrêt de la connexion.

Merci pour vos avis et vos conseils

  • # Qwant tu cherches tu trouves :D

    Posté par . Évalué à 4 (+3/-0).

    Hello,

    J'ai qwanté ton message d'erreur et j'ai trouvé ça qui proposes plusieurs cas différents avec le même message d'erreur que toi
    https://stackoverflow.com/questions/2419412/ssh-connection-stop-at-debug1-ssh2-msg-kexinit-sent

    Julien_c'est_bien (y'a pas que Seb)

    • [^] # Re: Qwant tu cherches tu trouves :D

      Posté par . Évalué à 1 (+0/-0).

      Je te remercie pour ce lien.
      Malheureusement, je n'ai pas trouvé d'analogie avec mon propre cas.

      J'ai quand même installée une liaison filaire entre le routeur et le pc destinataire. J'obtiens une nouvelle adresse ip évidemment quand je demande la liaison ssh avec cette ip depuis le poste source, je l'obtiens sans problème.

      Le souci semble provenir des connexions wifi mais je ne trouve rien sur les logs des deux machines.

      J'ai quand même vérifié les versions de ssh qui sont identiques sur les deux machines ainsi que la taille de la mtu des interfaces réseaux toutes deux égales à 1500.

  • # quelques precisions

    Posté par . Évalué à 4 (+2/-0).

    ca ne change rien au probleme, mais :

    • les bandes wifi sont en Ghz et non en Mhz.
    • les cartes wifi sont rarement ethX qui sont l'ancien nom des cartes filaires.

    utilises-tu deux SSID differents pour distinguer ton reseau 2.4Ghz et 5Ghz ?

    ou bien tu utilises le meme SSID est potentiellement la machine change de reseau en fonction de son environnement ?

    et si ce sont 2 cartes wifi differentes (eth0/eth1) utilise-t-elle le meme adressage reseau ?

    car si ca se trouve alors, ton transfert fonctionne quand les 2 machines sont sur 2.4Ghz, mais plante quand l'une d'elle passe sur le 5Ghz

    • [^] # Re: quelques precisions

      Posté par . Évalué à 1 (+0/-0).

      Bonjour,

      Oui, j'ai fait une erreur sur le routeur c'est ath0 et ath1 pour la wifi.

      Les SSID sont bien différentes et l'adressage réseau local est identique quelque soit l'interface.

      Oui, tu as sans doute raison, c"est probablement la différence de fréquence qui est la cause du problème mais je ne trouve rien sur les logs qui permettrait de le confirmer.

      Dans la journée je vais essayer en utilisant le même SSID sur les deux machines et j'aurai donc la même fréquence wifi pour les deux machines.

  • # Même SSID, même fréquence

    Posté par . Évalué à 1 (+0/-0).

    J'ai connecté le pc destinataire via wifi en utilisant le même SSID que celle de la machine source. Et là, la connexion ssh se fait sans problème.
    La synchronisation avec unison via ssh s'exécute parfaitement.

    Je suis ennuyé de ne pas comprendre pourquoi une liaison ssh fonctionne très aléatoirement quand les machines sont connectées au réseau local via deux SSID différentes, est-ce un problème de fréquence ou autre chose encore ? La question reste ouverte.

    • [^] # Re: Même SSID, même fréquence

      Posté par . Évalué à 2 (+1/-0). Dernière modification le 17/10/18 à 12:19.

      une liaison ssh fonctionne très aléatoirement quand les machines sont connectées au réseau local via deux SSID différentes, est-ce un problème de fréquence ou autre chose encore ?

      Je n'ai aucun soucis de ce type hors j’utilise en permanence ce genre de configuration. Par contre je n'ai point testé avec une carte compatible 5Ghz.
      Peut-être vérifier si un de tes routeurs ne devient pas instable (j'ai remarqué sur les routeurs, en vieillissant le premier truc qui plante c'est le wifi, ensuite généralement le dhcp puis enfin le module Ethernet)

      Donation : 1N8QGrhJGWdZNQNSspm3rSGjtXaXv9Ngat (Bitcoin | Bitcoin Cash)

      • [^] # Re: Même SSID, même fréquence

        Posté par . Évalué à 1 (+0/-0).

        Bonjour,

        Si j'ai bien compris tu as au moins deux routeurs et des machines connectées indifféremment en wifi forcément avec des SSID différents et tu ne rencontres pas de problèmes de connexion entre les machines ?

        Moi, je n'ai qu'un seul routeur (tout neuf, à peine un mois) mais qui émet en wifi grâce à deux interfaces l'une sur la fréquence 2,4 Ghz et l'autre sur la fréquence 5 Ghz. Donc deux SSID différents. Je ping bien les machines entre elles. Mais j'ai des problèmes de liaison ssh peut être à cause des fréquences différentes mais les logs sont muettes sur ce point.

        • [^] # Re: Même SSID, même fréquence

          Posté par . Évalué à 2 (+1/-0).

          Si j'ai bien compris tu as au moins deux routeurs et des machines connectées indifféremment en wifi forcément avec des SSID différents et tu ne rencontres pas de problèmes de connexion entre les machines ?

          En effet, peu importe sur lequel de mes wifis je me connecte (tous étant connecté au même LAN), je peux contrôler sans pertes de liaison (*1) mes machines qu'elles soient connecté en wifi ou filaire. Et ce avec plusieurs SSID ou avec un même SSID identique sur plusieurs routeurs.
          Peut-être que ton routeur te permet de connaître (via sa WEBUI) sur quelle fréquence tourne chaque client (car les routeurs peuvent utiliser plusieurs fréquences en même temps). Check que ton SSH ne plante pas durant un changement de fréquence. (mais je pense qu'un client ne peut switcher que du 2,4Ghs <=> 5Ghz, pas entre fréquences de 2,4Ghz)

          *1 que je remarque en tout cas, car ssh est capable de se reconnecter lors des pertes de liaison.

          Donation : 1N8QGrhJGWdZNQNSspm3rSGjtXaXv9Ngat (Bitcoin | Bitcoin Cash)

          • [^] # Re: Même SSID, même fréquence

            Posté par . Évalué à 1 (+0/-0).

            Apparemment il n'y a pas de switch de fréquence sur les postes client.
            Dans mon cas, c'est le pc destinataire qui clôt la connexion. ssh paraît tenir la liaison, le temps d'inactivité du lien entre les deux machines entraine cependant la fermeture de la connexion.

            • [^] # Re: Même SSID, même fréquence

              Posté par . Évalué à 1 (+0/-0).

              Ça me rappel un soucis similaire avec OpenVPN il y a peu (déconnexions répété après peu de temps).
              J'avais fixé l'IP du serveur via le routeur (via MAC) et je me suis aperçus que la machine disposait de deux adresses IP sur le réseau LAN. Celle fixé par le routeur, et une autre dans celles que le routeurs fixe aléatoirement.
              Dans ifconfig , n'était affichée que l'IP fixée par le routeur, mais nmap et ping m'indiquaient que l'autre IP répondait aussi.
              Pour régler le soucis il m'a suffit d'aussi fixer l'IP via la configuration réseau côté client. (et je n'ai toujours pas compris l’existence de ce bug)
              Peut-être vérifier à ce niveau là chez toi?

              Donation : 1N8QGrhJGWdZNQNSspm3rSGjtXaXv9Ngat (Bitcoin | Bitcoin Cash)

  • # Problème identifié

    Posté par . Évalué à 4 (+3/-0). Dernière modification le 17/10/18 à 17:26.

    Bonjour,

    Je pense avoir résolu mon problème.

    Je me suis aperçu que le poste client source bien qu'équipé d'une clé wifi 802.11n se sert en fait du protocole 80211d ainsi que me l'a indiqué modinfo r8188eu le driver linux de cette clé.

    Or j'avais paramétré l'interface wifi ath0 en 5 Ghz du routeur avec mode réseau AC/N uniquement.

    J'ai donc modifié le mode réseau de cette interface en Mixte pour inclure tous les protocoles 802.11.

    J'ai booté le routeur et depuis, la connexion ssh fonctionne chaque fois que je la lance. J'ai fait de nombreux essais. Le lien ssh entre les deux machines se fait bien l'une étant connectée au réseau en wifi 2,4 Ghz et l'autre en wifi 5 Ghz sur deux SSID différents.

    Je vous remercie de vos commentaires qui m'ont poussé à remettre à plat toutes mes configurations et à élargir mon point de vue.

  • # Commentaire supprimé

    Posté par . Évalué à 1 (+0/-0). Dernière modification le 24/10/18 à 07:44.

    Ce commentaire a été supprimé par l'équipe de modération.

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.