Forum Linux.debian/ubuntu Résolu [Debian Jessie LXDE Intel i915]

Posté par . Licence CC by-sa.
Tags : aucun
0
29
avr.
2015

Bonjour,

j'ai remplacé il y a quelques jours mon vieux PC Portable par un HP Elitedesk 820 G2 avec une nouvelle installation Debian Jessie+LXDE.

L'ensemble fonctionne très bien sauf lorsque je déplace une fenêtre (WM : Openbox) où ça lag énormément.

J'ai testé avec un disque sur lequel il y avait une Fedora 21 avec Gnome et c'est très fluide.

Mes recherches restent veines, je ne sais plus dans quelle direction chercher. Ma seule piste est OpenGL qui charge un pilote différent sous Fedora.
Je ne trouve pas comment "forcer" le pilote OpenGL.

Serait-ce dû à la version d'OpenGL (3.0 Mesa 10.4.7 chez Fedora contre 3.0 Mesa 10.3.2 chez Jessie)?

Voici quelques infos techniques :

# lspci | grep "VGA compatible controller"
00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)


# lsmod |grep video
video                  18096  1 i915

# dpkg -l xserver-xorg-video-intel
||/ Nom                           Version          Architecture                    Description
+++-==============================-================-===============================-===============================
ii  xserver-xorg-video-intel      2:2.21.15-2+b2   amd64                           X.Org X server -- Intel i8xx, i9xx display driver


# glxinfo |grep OpenGL
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.5, 256 bits)
OpenGL version string: 3.0 Mesa 10.3.2

Sous Fedora :
# glxinfo |grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 5500 (Broadwell GT2)
OpenGL version string: 3.0 Mesa 10.4.7

Toute piste de travail sera chaleureusement accueillie.

Merci.

  • # OpenGL vendor string: VMware, Inc. ??

    Posté par (page perso) . Évalué à 2.

    Dans le glxinfo de ta Debian, on lit "OpenGL vendor string: VMware, Inc." Or, VMWare sert pour la virtualisation de machine.

    Comment as-tu installé exactement ta machine ? Tu as commencé par faire un test en la virtualisant ?

    A mon avis, tu devrais commencer par réinstaller les paquets qui sont liés à xorg et à mesa (l'implementation libre d'OpenGL):

    apt-get install --reinstall xserver-xorg-video-intel libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core

    • [^] # Re: OpenGL vendor string: VMware, Inc. ??

      Posté par . Évalué à 1.

      Bonjour Olivier,

      Je ne sais pas pourquoi l'OpenGL affiché est VMWARE. J'ai installé directement sur le poste depuis une netinstall avec très peu de paquets (et aucun hyperviseur/émulateur…).

      J'ai suivi ton conseil avec un

      #apt-get install --reinstall xserver-xorg-video-intel libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core 

      Pas mieux.

      Mes versions de libgl :

      ii  libgl1-mesa-dri:amd64  10.3.2-1   amd64
      ii  libgl1-mesa-glx:amd64  10.3.2-1   amd64

      On ne peut plus faire de dpkg-reconfigure xserver-xorg ?
      Je n'ai pas moyen de forcer un xorg.conf pour le modifier ?
      Je ne sais pas comment "forcer" le pilote OpenGL. Ni même s'il a un rapport avec mon souci.

      Pour info, les quelques paquets installés après une install de base sans aucun paquet de coché :

      SYSTEME :

      apt-get install pulseaudio pavucontrol firmware-iwlwifi wvdial sudo cups cups-client hplip

      LXDE :

      apt-get install lxde-core lightdm lxappearance network-manager fdpowermon lxrandr gnome-screenshot

      UTILITAIRES :

      apt-get install ssh bzip2 unrar nmap cifs-utils telnet pdftk

      APPLICATIONS :
      Firefox et Thunderbird depuis les sources Mozilla

      apt-get install openjdk-7-jre icedtea-7-plugin flashplugin-nonfree
      apt-get install libreoffice libreoffice-l10n-fr leafpad vlc gpicview pinta audacity rdesktop xtightvncviewer filezilla xarchiver galculator evince xournal

      pour les tests :

      apt-get install mesa-utils
      apt-get install freeglut3

      Le tout ne fait que 4Gio

      • [^] # Re: OpenGL vendor string: VMware, Inc. ??

        Posté par (page perso) . Évalué à 2.

        Peux-tu mettre sur http://pastebin.com/ (ou autre) le contenu des :
        - /var/log/Xorg.0.log
        - L'intégralité du résultat de "glxinfo"

        • [^] # Re: OpenGL vendor string: VMware, Inc. ??

          Posté par . Évalué à 1.

          Voici :

          PS : je n'ai pas précisé mais j'utilise souvent 2 écrans externe en plus de mon écran (les 3 font du 1920x1080).
          Mais même quand je n'ai que mon laptop, les symptômes sont les mêmes.

          • [^] # Re: OpenGL vendor string: VMware, Inc. ??

            Posté par (page perso) . Évalué à 2.

            Il y a des warning:

            7.044 intel(0): RGB weight 888
            7.044 intel(0): Default visual is TrueColor
            7.044 intel(0): Unknown chipset
            7.044 intel(0): Relaxed fencing disabled

            => Chipset non complètement reconnu par le driver ?

            7.994 Depth 24 pixmap format is 32 bpp
            7.994 intel(0): cannot enable DRI2 whilst forcing software fallbacks
            7.994 intel(0): Allocated new frame buffer 1920x1080 stride 7680, untiled

            => Impossible de charger un firemware/module DRI2

            8.180 intel(0): Disabling Xv because no adaptors could be initialized.
            8.180 intel(0): direct rendering: Failed

            => Pas d'accès rendu direct

            et une erreur:

            8.432 AIGLX: Screen 0 is not DRI2 capable
            8.432 AIGLX: reverting to software rendering
            8.477 AIGLX: Loaded and initialized swrast
            8.477 GLX: Initialized DRISWRAST GL provider for screen 0

            => GLX passe au mode de rendu software. C'est probablement la raison pour laquelle l'affichage est ralenti.

            Il y a pas mal de problème similaire sur le net:
            https://www.google.fr/?q=AIGLX:+Screen+0+is+not+DRI2+capablele

            A mon avis, il faut commencer par regarder du coté du chipset graphique qui ne semble pas très classique :

            lspci | grep "VGA compatible controller"
            00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)

            D'après https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=782690 , le problème semble être corrigé en installant un morceau d'experimental :

            I could nail down the issue a little. Installing
            xserver-xorg-video-intel from experimental (with no need to upgrade
            other components of the stack) is enough to fix it and get DRI2
            support and full hardware rendering.

            • [^] # Re: OpenGL vendor string: VMware, Inc. ??

              Posté par . Évalué à 1.

              Merci Olivier,

              en effet avec le paquet de Experimental :

              ii  xserver-xorg-video-intel  2:2.99.917-1~exp1   amd64  X.Org X server -- Intel i8xx, i9xx display driver

              C'est beaucoup mieux :

              $ cat /var/log/Xorg.0.log |grep rendering
              [     8.055] (II) intel(0): direct rendering: DRI2 enabled

              Plus aucun lag… :)

    • [^] # Re: OpenGL vendor string: VMware, Inc. ??

      Posté par (page perso) . Évalué à 3.

      Pas vraiment surprenant, voire vraiment pas.

      Le projet mesa est né chez Brian Paul, passé chez SGI, puis Tungsten Graphics et enfin VMware (plus de détails sur la page intro de mesa3d.org). Le rachat par VMware date de décembre 2008 !

      Réinstaller les paquets ne va pas changer la vendor string de llvmpipe/gallium, cf. src/gallium/drivers/llvmpipe/lp_screen.c :

          static const char *
          llvmpipe_get_vendor(struct pipe_screen *screen)
          {
             return "VMware, Inc.";
          }
      
      
          static const char *
          llvmpipe_get_name(struct pipe_screen *screen)
          {
             static char buf[100];
             util_snprintf(buf, sizeof(buf), "llvmpipe (LLVM %u.%u, %u bits)",
                           HAVE_LLVM >> 8, HAVE_LLVM & 0xff,
                           lp_native_vector_width );
             return buf;
          }

      Je ne maintiens plus X dans Debian depuis un moment, mais il est probable qu'il manque des bouts dans la stack X pour un support correct de Broadwell. J'avais fourni des backports (libdrm, mesa, serveur X et quelques drivers) pendant un cycle de release. Peut-être quelqu'un voudra-t-il épauler debian-x@ pour celui de Jessie ? La première étape étant d'avoir les composants à jour dans unstable puis testing ; une fois ceci fait, il suffit de suivre les consignes pour contribuer des backports.

      Debian Consultant @ DEBAMAX

  • # re

    Posté par . Évalué à 1.

    cat /etc/X11/xorg.conf | grep "Driver"
    (Attention majuscule)

    • [^] # Re: re

      Posté par . Évalué à 1. Dernière modification le 27/10/18 à 20:31.

      Bonjour Anonyme (NdM: nom supprimé lors de la purge du compte concerné),

      justement, il n'y a plus de xorg.conf par défaut depuis au moins Wheezy.

    • [^] # Re: re

      Posté par (page perso) . Évalué à 2.

      cat

      UUOC

      * Ils vendront Usenet^W les boites noires quand on aura fini de les remplir.

  • # Compositing

    Posté par (page perso) . Évalué à 3.

    Je dirais que ça vient du compositing fait par GNOME (et donc utilisant Opengl) contre Openboxqui ne l'utilise pas.

    « Rappelez-vous toujours que si la Gestapo avait les moyens de vous faire parler, les politiciens ont, eux, les moyens de vous faire taire. » Coluche

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.