Forum Linux.debian/ubuntu [Résolu] Petit problème qwerty/azerty

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
3
27
mai
2020

Salut,

J'ai un petit problème. Je ne sais pas si quelqu'un pourra m'aider ou me donner au moins une piste à creuser.

C'est un problème un peu étrange. Que je croyais avoir réussi à éradiquer via un dist-upgrade. Mais non. il est revenu.

Alors, on commence par la base :

$ uname -a
Linux linka 4.19.0-9-amd64 #1 SMP Debian 4.19.118-2 (2020-04-29) x86_64 GNU/Linux
$ lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 10 (buster)
Release:    10
Codename:   buster

Ensuite par la description du problème :
En fait tout marche, sauf une catégorie spécifique de programmes : les butineurs web et les xterm (de ce que j'ai testé). C'est un problème d'entrée de caractère. Ils prennent mon azerty pour un qwerty. Du coup, c'est un peu "lourd", si puis-je dire.

Logiciels qui mappent plus bien :
firefox, chrome, konqueror, xterm

Exemples qui mappent bien :
gnome-terminal, gedit, eclipse

Alors là où ça devient plus tordu :
Si je me crée disons un compte de test et que je lance mettons firefox (au pif), depuis ma session principale, pareil. Donc ça ne vient pas d'une question de profil utilisateur. Si j'envoie tout balader (reboot que je n'avais pas prévu, mais j'ai sauté sur l'occasion), et plutôt que choisir wayland mais Xorg pour l'utilisateur de test, bin là ça marche sous firefox :(

Et en revenant sur ma session principale, ça ne remarche plus : a est q, etc.

Option 1 : j'ai raté un truc gros comme le nez,
Option 2 : j'ai foutu la grouille quelque part dans ma précédente tentative de résolution (alors, oui, mais où ?)…

Bref, voilà, je suis un peu sec parce qu'en général, toutes les réponses à ce problème sont pour les utilisateurs de windows. J'ai essayé de retourner internet, ça n'a pas trop marché non plus.

Si jamais ça dit quelque chose à quelqu'un, je serai votre obligé.

Merci !

  • # Typo

    Posté par  . Évalué à 1 (+0/-0).

    _
    Exemples qui mappent bien :_

    Tiensm y4q d[u il y qvoir un petit retour chqriot en trop<<<

    Si un ;odo peut si;ple;ent corriger<<<

    C4est lourdm hein M

    • [^] # Re: Typo

      Posté par  . Évalué à 1 (+0/-0).

      Du coup, vu la proposition d'en dessous et un petit test, j'ai fait aussi la correction de typo en modifiant le titre à résolu…

  • # xwayland

    Posté par  (site Web personnel) . Évalué à 6 (+3/-0).

    De ce que je comprends du problème, ce sont les logiciels qui tournent avec xwayland qui posent problème. A mon avis, le serveur xwayland ne gère pas correctement le mapping. Tu as essayer de changer le clavier avec un outil spécifique à X (genre setxkbmap).

    « Rappelez-vous toujours que si la Gestapo avait les moyens de vous faire parler, les politiciens ont, eux, les moyens de vous faire taire. » Coluche

    • [^] # Re: xwayland

      Posté par  . Évalué à 2 (+1/-0). Dernière modification le 27/05/20 à 22:51.

      Salut,

      Merci !

      Problème résolu.

      Et pour la postérité :

      setxkbmap fr

      Donc c'était l'option 1. :/

      Merci de m'avoir remis sur le droit chemin !

      • [^] # Re: xwayland

        Posté par  (site Web personnel) . Évalué à 4 (+1/-0).

        Après, c’est quand même un workaround, c’est bizarre que ça ne fonctionne pas nativement. Tu n’as pas un script de démarrage de X qui ferrait un changement de la disposition du clavier ? Du genre un ~/.xsession ou autre ?

        « Rappelez-vous toujours que si la Gestapo avait les moyens de vous faire parler, les politiciens ont, eux, les moyens de vous faire taire. » Coluche

        • [^] # Re: xwayland

          Posté par  . Évalué à 2 (+1/-0).

          Salut,

          Et bien non, je ne semble pas avoir ça malheureusement. Il va falloir que je creuse plus pour rendre les choses pérennes, tu as raison.

          Le petit hic, c'est que quand j'ai eu le problème initialement il y a deux mois environ, je n'ai pas pris note des commandes effectuées pour tenter de réparer. Donc j'ai peut-être involontairement mis quelque chose, quelque part, qui m'amène dans cette situation. Mais alors où ? Pour l'instant, je ne sais pas… Mais si je trouve, je rajouterai un commentaire ;)

          Disons que pour commencer, je suis satisfait du workaround ;)

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.