Forum Linux.debian/ubuntu Yé tout cassé

Posté par  . Licence CC By‑SA.
Étiquettes :
4
9
mai
2020

Bonjour amis linuxiens,

J'ai un petit problème avec mon système : il m'a proposé hier (en tout cas j'ai accepté hier) de passer en 20.04, donc bah ben je clique sur ok !
A ce niveau là encore pas de problème, si ce n'est que je n'ai plus mon icône de connexion internet (celle où quand on clique dessus les connexions disponibles s'affichent), et vu la box de m… que m'a refilé SFR croyez-moi j'en ai régulièrement besoin.
Qu'à cela ne tienne me dis-je ! et hop, me voilà dans le "modificateur d'apparence" pour mettre une autre interface qui avec un peu de chance me fera apparaître mon icône sésame.
Bon ben pas de bol, depuis mes barres où s'affichent les menus principaux, ainsi que cette fameuse icône, ou encore la date et l'heure, ces barres sont vierges (barre de menu et barre des tâches serais-je tenté de les appeler). Du coup je n'ai plus aucune interaction possible. F12 ne me donne plus de terminal, heureusement il est encore atteignable (avec ctrl+alt+t). J'ai fait la commande sudo apt install gnome-control-center en pensant que c'était ce qui m'intéressais, total je peux effectivement lancer l'application via le terminal, mais tout ce qui s'ouvre est une fenêtre désespérément vierge (j'ai juste "périphérique" écrit avec sur sa droite un "<" permettant normalement de remonter à la commande précédente).
Est-ce que tout ce boxon te parle, ô toi qui lis ces lignes ? Si c'est le cas, je t'en prie explique-moi tout ça avec des mots simples !

Voila, merci de m'avoir lu !

Bien à vous,

Absiaka

Edit : j'ai voulu ouvrir firefox par le terminal (ben oui j'ai plus accès aux programmes), mais l'interface graphique n'apparaît pas…

2ème et dernier edit : pour prendre l'ampleur des dégâts, j'ai voulu lire une vidéo (avec VLC), le programme s'ouvre bien, mais bloque tout le pc : plus aucune réaction. Impossible de cliquer sur une icône du bureau, impossible d'ouvrir un terminal, etc etc.

  • # autre compte

    Posté par  . Évalué à 2.

    Ouvre une session avec un autre compte (au besoin crée le) est ce que le pb est tjs présent ?

    • [^] # Re: autre compte

      Posté par  . Évalué à 1.

      Et pour créer un nouveau compte sans interface graphique, Ctrl+Alt+F3. Un terminal s'ouvre. Se connecter en root, puis taper adduser [nom de l'utilisateur].

      • [^] # Re: autre compte

        Posté par  . Évalué à 1.

        Mmmhh, c'est bizarre.

        J'ai donc créé un nouvel utilisateur, et en quittant le terminal (via alt-f7) connecté avec le nouvel ID, je retombe sur mon interface graphique tjrs aussi foireuse. Bon, redémarrage.
        J'ai voulu essayer de me connecter avec le nouvel utilisateur par le menu de connexion au démarrage du pc, et là on me dit que mon pass est faux.
        Je me reconnecte donc avec mon "vrai" profil, je repasse sur le terminal, et là oh magie sur le terminal je peux me connecter au nouveau profil, plus de problème de mot de passe.
        J'ai essayé trop de fois pour mettre ça sur le compte d'une faute de frappe.

        • [^] # Re: autre compte

          Posté par  . Évalué à 1. Dernière modification le 10/05/20 à 14:56.

          Hihi j'ai mis trop de temps à vouloir éditer mon commentaire…
          Je voulais juste ajouter que j'ai ubuntu-mate, si ça change quelque chose.

          J'en profite pour vous remercier pour vos réponses !

        • [^] # Re: autre compte

          Posté par  . Évalué à 2.

          Salut,

          Dès fois il peut y avoir des surprises azerty/qwerty :)

          Tu peux peut-être mettre un mot de passe temporairement assez simple, genre 0987 et vite le changer une fois dans la session ? :)

          Matricule 23415

          • [^] # Re: autre compte

            Posté par  . Évalué à 1.

            Ca devait être le pad numérique qui foirait le mdp, avec "jiji" sûr de pas se planter !
            Et d'ailleurs, oh magie, ça marche ! Mon interface est flambante !
            Evidemment ça amène son lot de questions subsidiaires, genre : est-ce que mon interface était déjà un peu bugguée quand je n'avais plus l'heure et la liste de connexions wifi etc etc.
            Par ailleurs, chaque user peut avoir sa propre interface graphique ? Il me semble bien que l'interface graphique du nouvel utilisateur est celle par défaut, et non celle que j'ai chargé avec mon profil régulier (celui qui plante).
            C'est possible de réparer ce dernier ?

            Merci en tout les cas de m'avoir dépatouiller de ça, il est au moins utilisable maintenant !

            • [^] # Re: autre compte

              Posté par  . Évalué à 3. Dernière modification le 10/05/20 à 16:02.

              Salut,

              Ca devait être le pad numérique qui foirait le mdp

              Ok super si tu as trouvé un début de solution !

              est-ce que mon interface était déjà un peu bugguée quand je n'avais plus l'heure et la liste de connexions wifi etc etc.

              Il y'a des chances si ça marche "correctement" sur le nouveau compte vierge. Peut-être un fichier de configuration qui n'a pas supporté la migration, peut-être une extension… Là, pour savoir, il faut farfouiller, ce qui peut prendre (beaucoup) de temps.

              Par ailleurs, chaque user peut avoir sa propre interface graphique ?

              Bin oui :) D'où le but du test :p

              C'est possible de réparer ce dernier ?

              Alors là… faudrait lister un peu les choses installées, voir un peu s'il y a des traces dans les logs s'il y a quelque chose de particulier…

              Pour être non destructif (mais il y aura certainement des choses à reparamétrer) je commencerais par un petit :

              $ mv .config .config.old

              dans la session à problème. Puis logout/relogin, histoire de voir

              Matricule 23415

              • [^] # Re: autre compte

                Posté par  . Évalué à 1.

                Et bien ça a déjà démerdé pas mal de choses !
                Le seul truc, c'est qu'au lieu d'avoir une barre de menu qui me proposait "menu" "applications" puis autre chose (je souviens plus), je n'ai plus que "menu". Mais bon ça je devrais y survire !
                A noter qu'au démarrage de la session qui buguAIT (je suis content d'utiliser l'imparfait) j'ai un message qui m'indique "des problèmes logiciels détecté" que je n'ai pas sur le nouvel utilisateur. Mais enfin, je peux m'en accommoder !
                Parce que sinon tout le reste à l'air de fonctionner normalement.

                Merci bien pour vos aides très précieuses !

                • [^] # Re: autre compte

                  Posté par  . Évalué à 3.

                  Je n'utilise pas mate, mais sur ton compte qui ne fonctionne pas tu peux essayer :

                  mv /home/your_username/.mateconf /home/your_username/.mateconf_sav
                  

                  en remplaçant bien sur your_username par l'identifiant du compte ça va effacer les fichiers de conf de mate tout en les sauvegardant dans le dossier .mateconf_sav (si jamais tu veux revenir en arrière)
                  tu quittes ta session et tu la relances

                  • [^] # Re: autre compte

                    Posté par  . Évalué à 1.

                    Bonsoir,

                    je n'étais pas revenu depuis, je vois la dernière réponse seulement maintenant, je vais mettre ce post dans un petit coin de ma tête et essayer la commande proposée seulement si j'ai de nouveau des problèmes, parce que pour l'instant je n'ai pas été gêné (à part ce petit message qui détecte un problème logiciel eu démarrage de session), de plus j'ai omis de préciser que l'erreur est antérieure à la mise à jour, alors peut-être que la commande est obsolète.
                    C'est pour le moment un ordi qui sert essentiellement de navigateur, alors bon… M'en fous de son erreur, tant qu'elle gêne pas ma navigation.

                    En tout cas merci tous, vous m'avez rendu un grand service !

Suivre le flux des commentaires

Note : les commentaires appartiennent à celles et ceux qui les ont postés. Nous n’en sommes pas responsables.