Forum Linux.débutant apache2

Posté par .
Tags : aucun
0
2
sept.
2007
Bonjour

je viens d'installer un serveurs Web apache2, d'après mes recherche je vois que la philosophies de apache 2 a changer,
pour pouvoir configurer un site il faut modifier le fichier /etc/apache2/sites-availebel/default.

et de mettre le répertoir du site dans /var/www/mon_répertoires.

après avoir installer apache et configuré le fichier /etc/apache2/sites-availe/default j'arrive a affichier les deux répertoire

http://localhost/

index Of
apache-default/
mon-répertoire/

Mais cependant je cherche a pouvoir limité l'accès au apache2-default et http://localhost/ et de permettre seulement http://localhost/mon-repertoire

es que quelqu'un peut m'aider ? vous pouvez visulalisé ma config


rt@linux:/etc/apache2/sites-available# more default
NameVirtualHost *
<VirtualHost *>
ServerAdmin webmaster@localhost

DocumentRoot /var/www/

order deny,allow
deny from all
Options None
# Options FollowSymLinks
AllowOverride None

<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order deny,allow
Deny from all
# This directive allows us to have apache2's default start page
# in /apache2-default/, but still have / go to the right place
#RedirectMatch ^/$ /apache2-default/



<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
# This directive allows us to have apache2's default start page
# in /nmap_scan_result/, but still have / go to the right place
#RedirectMatch ^/$ /nmap_scan/


ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all


ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined
ServerSignature On

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Allow from 127.0.0.0/255.0.0.0 ::1/128


</VirtualHost>
rt@ainux:/etc/apache2/sites-available#


Cordialement
  • # la philosophie...

    Posté par . Évalué à 1.

    n'est justement pas de modifier le fichier defaut, mais de creer un fichier de config par site que tu heberges.

    perso pour mes sites j'ai un fichier par site, sur le modele suivant :
    template = utilisateur qui gerera le site
    website = dossier qui contiendra le site
    (il faudra virer les espaces autour des < et > de virtualhost et directory


    < VirtualHost * >
    ServerAdmin webmaster@website.com

    ServerName www.website.com
    ServerAlias website.com
    DocumentRoot /home/template/public_html/website
    < Directory /home/template/public_html/website >
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    allow from all
    < /Directory >

    CustomLog /home/template/logs/website.log combined
    < /VirtualHost >


    attention les options dans Directory sont specifiques à mes sites et pas forcement les plus securitaires.
  • # C'est (presque) déjà dedans

    Posté par . Évalué à 2.

    Dans ton fichier de config tu as déjà la solution (par défaut) :

    #RedirectMatch ^/$ /apache2-default/

    Tu as dailleurs commenté cette ligne pour eviter d'être redirigé sur la page par défaut d'Apache.

    Il suffit donc que tu utilises une syntaxe similaire :

    RedirectMatch ^/$ /mon-repertoire/
    • [^] # Re: C'est (presque) déjà dedans

      Posté par . Évalué à 1.

      bonjour

      oui, mais si vous voyez bien sur le fichier j'ai mit des deny sur la racine / et sur le répertoire par default de apache, le problème c'est que sa ne fonctionne pas j'arrive toujours a y accèdé
      • [^] # reload / restart ?

        Posté par . Évalué à 2.

        après une modification de la configuration , il faut faire un reload ou un restart
        (si tu ne l'a pas fait)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.