Forum Linux.débutant DHCP désactivé mais connection établie

Posté par . Licence CC by-sa.
0
2
juil.
2013

salut tt le monde..je suis sous ubuntu 12.04 j'ai crée un point d'accès a l'aide de hostapd et sa fonctionne.
Cce qui m'inquiète c'est que parfois avant de lancer le hostapd et me connecter depuis mon mobile je désactive le DHCP mais le résultat est le meme que celui quand le DHCP est activé:mon mobile se connecte avec succès avec l'adresse 192.168.0.87!
au début je croyais que le serveur DHCP lui affecte cette adresse mais vu que je le désactive et mon mobile se connecte aussi avec cette adresse je me pose la question d'ou vient cette adresse??

  • # reponse

    Posté par . Évalué à 1.

    Bonjour,

    Je ne connais pas hostpad, mais d'une maniere général as tu fais les vérifications suivantes :
    _ Le mobile est en mode DHCP ou statique ?
    _ As tu les logs dhcp sur hostapd  ?

    • [^] # Re: reponse

      Posté par . Évalué à -4.

      si je désactive le dhcp sur mon pc c'est quoi l'importance de connaitre si le mobile est en mode dhcp ou statique!meme s'il est en mode dhcp il cherchera un serveur dhcp et il le trouvera pas puisqu'il est désactivé..c'est comme sa la procedure nn?!!

      • [^] # Re: reponse

        Posté par (page perso) . Évalué à 4. Dernière modification le 02/07/13 à 18:03.

        Selon les configs de "dhclient", ton mobile devrait faire :
        -Demande de DHCP
        -Pas de réponse
        -Ok je test de mettre directement la dernière IP qu'on m'a filé pour voir si ça passe quand même.

        • [^] # Re: reponse

          Posté par (page perso) . Évalué à 4.

          +1, si le bail est encore valable.

          Système - Réseau - Sécurité Open Source

      • [^] # Re: reponse

        Posté par . Évalué à 3. Dernière modification le 03/07/13 à 01:59.

        Si tu sais comment est "la procédure" et comment fonctionne chaque maillon de la chaîne, tu ne devrais pas avoir à poser la question sur ce forum non ? Des personnes prennent le temps de te répondre.
        Et par écrit c'est délicat de ne pas interpréter de la mauvaise manière, alors attention à soigner la forme dans tes commentaires.

        • [^] # Re: reponse

          Posté par . Évalué à -2.

          salut :) ui je c comment est la procedure mais le problème,que apparament t arrives pas a voir la,c'est que c'est pas le cas ici puisk je désactive le serveur dhcp pourtant le mobile arrive a se connecter avec une ip 192.168.0.87 dont je connais pas l'origine (vu que le serveur dhcp est désactivé qui lui a attribué cette adresse) j esper que j étais clair

  • # wireshark / tcpdump

    Posté par (page perso) . Évalué à 2.

    Tu va voir ce qui se passe.

    Système - Réseau - Sécurité Open Source

  • # serveur dhcp

    Posté par . Évalué à 1.

    Est-ce que tu désactives bien le serveur dhcp et pas le client dhcp de ton interface pas wifi?

  • # désactiver DHCP

    Posté par . Évalué à 0.

    j'ai désactiver le serveur DHCP en commentant le paramètre suivant dans /etc/dnsmasq.conf:

    Uncomment this to enable the integrated DHCP server, you need

    to supply the range of addresses available for lease and optionally

    a lease time. If you have more than one network, you will need to

    repeat this for each network on which you want to supply DHCP

    service.

    dhcp-range=192.168.0.50,192.168.0.150,12h

    • [^] # Re: désactiver DHCP

      Posté par . Évalué à 2.

      https://linuxfr.org/wiki/aide-edition

      Pour ton problème je ne sais pas. Regarde la sortie de la commande dmesg ou dans /var/log/messages pour voir si tu as pas un (autre) serveur DHCP qui pousse une adresse. Ou sinon il réutilise la dernière IP connue comme dit plus haut.

      • [^] # Re: désactiver DHCP

        Posté par . Évalué à 0.

        En faite je pense que commenter la ligne:
        dhcp-range=192.168.0.50,192.168.0.150,12h
        ne désactive pas le serveur DHCP..je pense a utiliser service dnsmasq a sa place pour arreter le serveur DHCP

        • [^] # Re: désactiver DHCP

          Posté par . Évalué à 2. Dernière modification le 05/07/13 à 14:16.

          Je connais pas hostapd (je sais à quoi ça sert mais jamais utilisé) ni dnsmasq (ha je regarde, un DNS forwarder pour NAT, ok. Ça a un rapport avec le DHCP ?)

          En fait j'ai l'impression (je peut me gourer) que tu as deux serveurs DHCP qui tournent : dhcpd + un autre inclus dans hostapd (que tu désactives en commentant cette ligne)

          Pour arrêter le serveur DHCP ne devrais-tu pas plutôt faire un truc du genre : service dhcpd stop (ou /etc/init.d/dhcpd stop) ?

          En regardant sur le client avec un grep DHCP /var/log/daemon.log tu verras s'il utilise le serveur DHCP

          Jul  4 22:55:25 medusa dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 4
          Jul  4 22:55:29 medusa dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 4
          Jul  4 22:55:29 medusa dhclient: DHCPREQUEST on eth0 to 255.255.255.255 port 67
          Jul  4 22:55:29 medusa dhclient: DHCPOFFER from 192.168.0.1
          Jul  4 22:55:30 medusa dhclient: DHCPACK from 192.168.0.1
          
          
          • [^] # Re: désactiver DHCP

            Posté par . Évalué à 0.

            il y a un serveur dhcp et dns dans dnsmasq et j ai pas un autre serveur dhcp!
            j ai pas un réseau installé sinon je pourrai voir d'ou viennent les DHCPOFFER

            • [^] # Re: désactiver DHCP

              Posté par . Évalué à 4.

              j ai pas un réseau installé sinon je pourrai voir d'ou viennent les DHCPOFFER

              Hein?!

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.